Every CVE Search/ Get API key

CVE-2020-11931

Ubuntu modifications to pulseaudio to provide snap security enforcement could be unloaded

3.3 LowFix available

CVE-2020-11931 is a low vulnerability (CVSS 3.3) in Canonical Pulseaudio, published April 16, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 26th percentile. Fixed in pulseaudio 1:8.0-0ubuntu3.12.

An Ubuntu-specific modification to Pulseaudio to provide security mediation for Snap-packaged applications was found to have a bypass of intended access restriction for snaps which plugs any of pulseaudio, audio-playback or audio-record via unloading the pulseaudio snap policy module. This issue affects: pulseaudio 1:8.0 versions prior to 1:8.0-0ubuntu3.12; 1:11.1 versions prior to 1:11.1-1ubuntu7.7; 1:13.0 versions prior to 1:13.0-1ubuntu1.2; 1:13.99.1 versions prior to 1:13.99.1-1ubuntu3.2;

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

0.33%Down 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 3.3

Ubuntu modifications to pulseaudio to provide snap security enforcement could be unloaded

An Ubuntu-specific modification to Pulseaudio to provide security mediation for Snap-packaged applications was found to have a bypass of intended access restriction for snaps which plugs any of pulseaudio, audio-playback or audio-record via unloading the pulseaudio snap policy module. This issue affects: pulseaudio 1:8.0 versions prior to 1:8.0-0ubuntu3.12; 1:11.1 versions prior to 1:11.1-1ubuntu7.7; 1:13.0 versions prior to 1:13.0-1ubuntu1.2; 1:13.99.1 versions prior to 1:13.99.1-1ubuntu3.2;

Record
CVE-2020-11931
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-284
Updated
2026-11-02
EUVDEUVD-2020-4268 3.3

An Ubuntu-specific modification to Pulseaudio to provide security mediation for Snap-packaged applications was found to have a bypass of intended access restriction for snaps which plugs any of pulseaudio, audio-playback or audio-record via unloading the pulseaudio snap policy module. This issue affects: pulseaudio 1:8.0 versions prior to 1:8.0-0ubuntu3.12; 1:11.1 versions prior to 1:11.1-1ubuntu7.7; 1:13.0 versions prior to 1:13.0-1ubuntu1.2; 1:13.99.1 versions prior to 1:13.99.1-1ubuntu3.2;

Record
EUVD-2020-4268
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-m777-7jfr-8wgh No score

An Ubuntu-specific modification to Pulseaudio to provide security mediation for Snap-packaged...

An Ubuntu-specific modification to Pulseaudio to provide security mediation for Snap-packaged applications was found to have a bypass of intended access restriction for snaps which plugs any of pulseaudio, audio-playback or audio-record via unloading the pulseaudio snap policy module. This issue affects: pulseaudio 1:8.0 versions prior to 1:8.0-0ubuntu3.12; 1:11.1 versions prior to 1:11.1-1ubuntu7.7; 1:13.0 versions prior to 1:13.0-1ubuntu1.2; 1:13.99.1 versions prior to 1:13.99.1-1ubuntu3.2;

Record
GHSA-m777-7jfr-8wgh
Updated
2026-11-02
NVD 3.3

An Ubuntu-specific modification to Pulseaudio to provide security mediation for Snap-packaged applications was found to have a bypass of intended access restriction for snaps which plugs any of pulseaudio, audio-playback or audio-record via unloading the pulseaudio snap policy module. This issue affects: pulseaudio 1:8.0 versions prior to 1:8.0-0ubuntu3.12; 1:11.1 versions prior to 1:11.1-1ubuntu7.7; 1:13.0 versions prior to 1:13.0-1ubuntu1.2; 1:13.99.1 versions prior to 1:13.99.1-1ubuntu3.2;

Record
CVE-2020-11931
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-284, CWE-668
Updated
2026-11-02
OSVUBUNTU-CVE-2020-11931 3.3

An Ubuntu-specific modification to Pulseaudio to provide security mediation for Snap-packaged applications was found to have a bypass of intended access restriction for snaps which plugs any of pulseaudio, audio-playback or audio-record via unloading the pulseaudio snap policy module. This issue affects: pulseaudio 1:8.0 versions prior to 1:8.0-0ubuntu3.12; 1:11.1 versions prior to 1:11.1-1ubuntu7.7; 1:13.0 versions prior to 1:13.0-1ubuntu1.2; 1:13.99.1 versions prior to 1:13.99.1-1ubuntu3.2;

Record
UBUNTU-CVE-2020-11931
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVUSN-4355-1 No score

pulseaudio vulnerability

PulseAudio in Ubuntu contains additional functionality to mediate audio recording for snap packages and it was discovered that this functionality did not mediate PulseAudio module unloading. An attacker-controlled snap with only the audio-playback interface connected could exploit this to bypass access controls and record audio.

Record
USN-4355-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pulseaudio
Ubuntu:16.04:LTS
before 1:8.0-0ubuntu3.12, plus listed versions
1:6.0-0ubuntu131:7.1-1ubuntu11:7.1-1ubuntu21:7.1-1ubuntu31:7.1-1ubuntu6
Show 12 moreShow less
1:7.1-1ubuntu71:8.0-0ubuntu21:8.0-0ubuntu31:8.0-0ubuntu3.11:8.0-0ubuntu3.21:8.0-0ubuntu3.31:8.0-0ubuntu3.41:8.0-0ubuntu3.71:8.0-0ubuntu3.81:8.0-0ubuntu3.91:8.0-0ubuntu3.101:8.0-0ubuntu3.11
1:8.0-0ubuntu3.12
pulseaudio
Ubuntu:18.04:LTS
before 1:11.1-1ubuntu7.7, plus listed versions
1:10.0-2ubuntu31:11.1-1ubuntu11:11.1-1ubuntu21:11.1-1ubuntu41:11.1-1ubuntu5
Show 6 moreShow less
1:11.1-1ubuntu61:11.1-1ubuntu71:11.1-1ubuntu7.11:11.1-1ubuntu7.21:11.1-1ubuntu7.41:11.1-1ubuntu7.5
1:11.1-1ubuntu7.7
pulseaudio
Ubuntu:20.04:LTS
before 1:13.99.1-1ubuntu3.2, plus listed versions
1:13.0-1ubuntu11:13.0-1ubuntu41:13.0-1ubuntu51:13.0-3ubuntu11:13.0-3ubuntu21:13.99.1-1ubuntu11:13.99.1-1ubuntu21:13.99.1-1ubuntu3
1:13.99.1-1ubuntu3.2

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open