Every CVE Search/ Get API key

CVE-2020-11975

Improper Input Validation in Apache Unomi

9.8 CriticalPublic exploitFix available

Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

30.6%Up 17.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.

Record
CVE-2020-11975
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.

Record
CVE-2020-11975
Updated
2026-11-02
EUVDEUVD-2022-1189 No score

Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.

Record
EUVD-2022-1189
Updated
2026-11-03
GitHub AdvisoriesGHSA-v6fq-q792-j46j 9.8

Improper Input Validation in Apache Unomi

Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.

Record
GHSA-v6fq-q792-j46j
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 9.8

Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.

Record
CVE-2020-11975
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-v6fq-q792-j46j 9.8

Improper Input Validation in Apache Unomi

Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.

Record
GHSA-v6fq-q792-j46j
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.unomi:unomi
Maven
before 1.5.4
1.5.4
org.apache.unomi:unomi
Maven
before 1.5.4, plus listed versions
1.0.0-incubating1.1.0-incubating1.2.0-incubating1.3.0-incubating1.5.01.5.11.5.21.5.3
1.5.4

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
NucleiApache Unomi - Remote Code Execution
PoC in GitHub1135/unomi_exploit2020-11-24

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-11975 is a critical vulnerability (CVSS 9.8) in Apache Unomi, published June 5, 2020. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 30.6%, the 98th percentile. Fixed in org.apache.unomi:unomi 1.5.4.

References

MoveEnter Open