Every CVE Search/ Get API key

CVE-2020-12648

Cross-site scripting vulnerability in TinyMCE

6.1 MediumFix available

A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote attackers to inject arbitrary web script when configured in classic editing mode.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.80%Up 1.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote attackers to inject arbitrary web script when configured in classic editing mode.

Record
CVE-2020-12648
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote attackers to inject arbitrary web script when configured in classic editing mode.

Record
CVE-2020-12648
Updated
2026-11-02
EUVDEUVD-2020-0644 No score

A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote attackers to inject arbitrary web script when configured in classic editing mode.

Record
EUVD-2020-0644
Updated
2026-11-03
GitHub AdvisoriesGHSA-vrv8-v4w8-f95h 6.1

Cross-site scripting vulnerability in TinyMCE

Impact

A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower.

Patches

This vulnerability has been patched in TinyMCE 4.9.11 and 5.4.1 by improved HTML parsing and sanitization logic.

Workarounds

The workarounds available are:

  • upgrade to either TinyMCE 4.9.11 or TinyMCE 5.4.1 or
  • enable the media plugin, which overrides the default parsing behaviour for iframes or
  • add the following workaround to update the parsing schema rules for iframes:

Example: Change the default schema for iframes

setup: function(editor) {
  editor.on('PreInit', function() {
    editor.schema.getSpecialElements()['iframe'] = /</iframe[^>]*>/gi;
  });
}

Acknowledgements

Tiny Technologies would like to thank George Steketee and Chris Davis at Bishop Fox for discovering this vulnerability.

References

https://www.tiny.cloud/docs/release-notes/release-notes54/#securityfixes

For more information

If you have any questions or comments about this advisory:

Record
GHSA-vrv8-v4w8-f95h
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote attackers to inject arbitrary web script when configured in classic editing mode.

Record
CVE-2020-12648
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-vrv8-v4w8-f95h 6.1

Cross-site scripting vulnerability in TinyMCE

Impact

A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower.

Patches

This vulnerability has been patched in TinyMCE 4.9.11 and 5.4.1 by improved HTML parsing and sanitization logic.

Workarounds

The workarounds available are:

  • upgrade to either TinyMCE 4.9.11 or TinyMCE 5.4.1 or
  • enable the media plugin, which overrides the default parsing behaviour for iframes or
  • add the following workaround to update the parsing schema rules for iframes:

Example: Change the default schema for iframes

setup: function(editor) {
  editor.on('PreInit', function() {
    editor.schema.getSpecialElements()['iframe'] = /</iframe[^>]*>/gi;
  });
}

Acknowledgements

Tiny Technologies would like to thank George Steketee and Chris Davis at Bishop Fox for discovering this vulnerability.

References

https://www.tiny.cloud/docs/release-notes/release-notes54/#securityfixes

For more information

If you have any questions or comments about this advisory:

Record
GHSA-vrv8-v4w8-f95h
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2020-12648 6.1

A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote attackers to inject arbitrary web script when configured in classic editing mode.

Record
UBUNTU-CVE-2020-12648
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
tinymce
npm
before 4.9.11
4.9.11
tinymce
npm
5.0.0 up to 5.4.1
5.4.1
tinymce
Ubuntu:16.04:LTS
All versions, plus listed versions
3.4.8+dfsg0-1
None known
tinymce
Ubuntu:18.04:LTS
All versions, plus listed versions
3.4.8+dfsg0-2
None known
tinymce
Ubuntu:20.04:LTS
All versions, plus listed versions
3.4.8+dfsg0-2
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-12648 is a medium vulnerability (CVSS 6.1) in Tiny Tinymce, published August 11, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.80%, the 78th percentile. Fixed in tinymce 4.9.11.

References

Show 4 moreShow less
MoveEnter Open