Every CVE Search/ Get API key

CVE-2020-13663

Drupal Core Cross-Site Request Forgery (CSRF) vulnerability

8.8 HighFix available

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.69%Up 0.3 points since Jun 12, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Record
CVE-2020-13663
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Record
CVE-2020-13663
Updated
2026-11-02
EUVDEUVD-2022-4500 No score

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Record
EUVD-2022-4500
Updated
2026-11-03
GitHub AdvisoriesGHSA-m648-hpf8-qcjw 8.8

Drupal Core Cross-Site Request Forgery (CSRF) vulnerability

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Record
GHSA-m648-hpf8-qcjw
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSVALPINE-CVE-2020-13663 8.8

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Record
ALPINE-CVE-2020-13663
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.8

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Record
CVE-2020-13663
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-m648-hpf8-qcjw 8.8

Drupal Core Cross-Site Request Forgery (CSRF) vulnerability

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Record
GHSA-m648-hpf8-qcjw
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSVUBUNTU-CVE-2020-13663 8.8

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Record
UBUNTU-CVE-2020-13663
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-drupal-2020-13663 No score

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Record
BIT-drupal-2020-13663
Updated
2026-11-02
OSVDRUPAL-CORE-2020-004 No score

The Drupal core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Record
DRUPAL-CORE-2020-004
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal/core
Packagist
8.9.0 up to 8.9.1
8.9.1
drupal/core
Packagist
9.0.0 up to 9.0.1
9.0.1
drupal/core
Packagist
7.0.0 up to 7.72
7.72
drupal/core
Packagist
8.0.0 up to 8.8.8
8.8.8
drupal/drupal
Packagist
7.0.0 up to 7.72
7.72
drupal/drupal
Packagist
8.0.0 up to 8.8.8
8.8.8
drupal/drupal
Packagist
8.9.0 up to 8.9.1
8.9.1
drupal/drupal
Packagist
9.0.0 up to 9.0.1
9.0.1
drupal7
Alpine:v3.11
before 7.72-r0
7.72-r0
drupal7
Alpine:v3.12
before 7.72-r0
7.72-r0
Show 16 moreShow less
Affected packages
PackageAffectedFixed
drupal7
Alpine:v3.13
before 7.72-r0
7.72-r0
drupal7
Alpine:v3.14
before 7.72-r0
7.72-r0
drupal7
Alpine:v3.15
before 7.72-r0
7.72-r0
drupal7
Alpine:v3.16
before 7.72-r0
7.72-r0
drupal7
Alpine:v3.17
before 7.72-r0
7.72-r0
drupal7
Alpine:v3.18
before 7.72-r0
7.72-r0
drupal7
Alpine:v3.19
before 7.72-r0
7.72-r0
drupal7
Alpine:v3.20
before 7.72-r0
7.72-r0
drupal
Bitnami
7.0.0 up to 7.72.0, 8.8.0 up to 8.8.8, 8.9.0 up to 8.9.1, 9.0.0 up to 9.0.1
7.72.08.8.88.9.19.0.1
drupal7
Debian:8
before 7.32-1+deb8u19, plus listed versions
7.32-1+deb8u107.32-1+deb8u117.32-1+deb8u127.32-1+deb8u137.32-1+deb8u14
Show 13 moreShow less
7.32-1+deb8u157.32-1+deb8u167.32-1+deb8u177.32-1+deb8u187.32-1+deb8u37.32-1+deb8u47.32-1+deb8u4~bpo70+17.32-1+deb8u57.32-1+deb8u5~bpo70+17.32-1+deb8u67.32-1+deb8u77.32-1+deb8u87.32-1+deb8u9
7.32-1+deb8u19
drupal/core
Packagist
8.0.0 up to 8.8.8, 8.9.0 up to 8.9.1, 9.0.0 up to 9.0.1, plus listed versions
8.0.18.0.28.0.38.0.48.0.5
Show 45 moreShow less
8.0.68.1.08.1.0-beta18.1.0-beta28.1.0-rc18.1.18.1.108.1.28.1.38.1.48.1.58.1.68.1.78.1.88.1.98.2.08.2.0-beta18.2.0-beta28.2.0-beta38.2.0-rc18.2.0-rc28.2.18.2.28.2.38.2.48.2.58.2.68.2.78.2.88.3.08.3.0-alpha18.3.0-beta18.3.0-rc18.3.0-rc28.3.18.3.28.3.38.3.48.3.58.3.68.3.78.3.88.3.98.4.08.4.0-alpha1
8.8.88.9.19.0.1
drupal7
Debian:9
before 7.52-2+deb9u11, plus listed versions
7.52-27.52-2+deb9u17.52-2+deb9u107.52-2+deb9u27.52-2+deb9u3
Show 6 moreShow less
7.52-2+deb9u47.52-2+deb9u57.52-2+deb9u67.52-2+deb9u77.52-2+deb9u87.52-2+deb9u9
7.52-2+deb9u11
drupal/core
Packagist
8.0.0 up to 8.8.8, plus listed versions
8.0.18.0.28.0.38.0.48.0.5
Show 45 moreShow less
8.0.68.1.08.1.0-beta18.1.0-beta28.1.0-rc18.1.18.1.108.1.28.1.38.1.48.1.58.1.68.1.78.1.88.1.98.2.08.2.0-beta18.2.0-beta28.2.0-beta38.2.0-rc18.2.0-rc28.2.18.2.28.2.38.2.48.2.58.2.68.2.78.2.88.3.08.3.0-alpha18.3.0-beta18.3.0-rc18.3.0-rc28.3.18.3.28.3.38.3.48.3.58.3.68.3.78.3.88.3.98.4.08.4.0-alpha1
8.8.8
drupal/drupal
Packagist
8.0.0 up to 8.8.8, plus listed versions
8.0.18.0.28.0.38.0.48.0.5
Show 45 moreShow less
8.0.68.1.08.1.0-beta18.1.0-beta28.1.0-rc18.1.18.1.108.1.28.1.38.1.48.1.58.1.68.1.78.1.88.1.98.2.08.2.0-beta18.2.0-beta28.2.0-beta38.2.0-rc18.2.0-rc28.2.18.2.28.2.38.2.48.2.58.2.68.2.78.2.88.3.08.3.0-alpha18.3.0-beta18.3.0-rc18.3.0-rc28.3.18.3.28.3.38.3.48.3.58.3.68.3.78.3.88.3.98.4.08.4.0-alpha1
8.8.8
drupal7
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
7.23-17.24-17.24-27.26-17.26-1ubuntu0.17.26-1ubuntu0.1+esm17.26-1ubuntu0.1+esm27.26-1ubuntu0.1+esm3
None known
drupal7
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
7.38-17.41-17.44-1ubuntu1~16.04.07.44-1ubuntu1~16.04.0+esm17.44-1ubuntu1~16.04.0+esm27.44-1ubuntu1~16.04.0+esm3
None known

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-13663 is a high vulnerability (CVSS 8.8) in Drupal, published June 17, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 53rd percentile. Fixed in drupal/core 8.9.1.

References

Show 7 moreShow less
This page doesn't list everything

Left out here: 252 versions. The JSON record has them.

MoveEnter Open