Every CVE Search/ Get API key

CVE-2020-13942

Remote Code Execution in Apache Unomi

9.8 CriticalPublic exploitFix available

It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

68.5%Up 48.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.

Record
CVE-2020-13942
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20, CWE-74
Updated
2026-11-02
CVE List No score

Remote Code Execution in Apache Unomi

It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.

Record
CVE-2020-13942
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2022-1257 0.0

It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.

Record
EUVD-2022-1257
CVSS
0.0 NoneCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-xp5j-wj4h-2jq9 9.8

Injection and Improper Input Validation in Apache Unomi

It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.

Record
GHSA-xp5j-wj4h-2jq9
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20, CWE-74
Updated
2026-11-02
OSV 9.8

It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.

Record
CVE-2020-13942
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-xp5j-wj4h-2jq9 9.8

Injection and Improper Input Validation in Apache Unomi

It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.

Record
GHSA-xp5j-wj4h-2jq9
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20, CWE-74
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.unomi:unomi
Maven
before 1.5.2
1.5.2
org.apache.unomi:unomi
Maven
before 1.5.2, plus listed versions
1.0.0-incubating1.1.0-incubating1.2.0-incubating1.3.0-incubating1.5.01.5.1
1.5.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
NucleiApache Unomi <1.5.2 - Remote Code Execution
PoC in GitHubCyberCTF/vulhub-unomi-cve-2020-139422026-10-08
PoC in GitHubProdrious/CVE-2020-139422021-09-05
PoC in GitHubblackmarketer/CVE-2020-139422020-11-21
PoC in GitHubcorsisechero/CVE-2020-13942byVulHub2025-04-02
PoC in GitHubdev-team-12x/apche_unomi_rce2021-01-11
PoC in GitHubeugenebmx/CVE-2020-139422020-11-19
PoC in GitHublp008/CVE-2020-139422020-11-18
PoC in GitHubshifa123/CVE-2020-13942-POC-2020-11-20
PoC in GitHubyaunsky/Unomi-CVE-2020-139422020-12-22

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-13942 is a critical vulnerability (CVSS 9.8) in Apache Unomi, published November 24, 2020. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 68.5%, the 99th percentile. Fixed in org.apache.unomi:unomi 1.5.2.

References

Show 11 moreShow less
MoveEnter Open