Every CVE Search/ Get API key

CVE-2020-13947

Cross-site scripting (XSS) in Apache ActiveMQ

6.1 MediumFix available

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

79.2%Up 75.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Record
CVE-2020-13947
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Record
CVE-2020-13947
Updated
2026-11-02
EUVDEUVD-2022-0856 No score

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Record
EUVD-2022-0856
Updated
2026-11-03
GitHub AdvisoriesGHSA-66gw-ch5v-74v8 6.1

Cross-site scripting (XSS) in Apache ActiveMQ

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Record
GHSA-66gw-ch5v-74v8
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Record
CVE-2020-13947
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2020-13947 6.1

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Record
DEBIAN-CVE-2020-13947
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-66gw-ch5v-74v8 6.1

Cross-site scripting (XSS) in Apache ActiveMQ

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Record
GHSA-66gw-ch5v-74v8
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2020-13947 6.1

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Record
UBUNTU-CVE-2020-13947
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVBIT-activemq-2020-13947 No score

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

Record
BIT-activemq-2020-13947
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.activemq:activemq-parent
Maven
5.16.0 up to 5.16.1
5.16.1
org.apache.activemq:activemq-parent
Maven
before 5.15.14
5.15.14
activemq
Bitnami
before 5.15.14, 5.16.0 up to 5.16.1
5.15.145.16.1
activemq
Debian:12
before 5.16.1-1
5.16.1-1
activemq
Debian:13
before 5.16.1-1
5.16.1-1
org.apache.activemq:activemq-parent
Maven
before 5.15.14, plus listed versions
4.1.14.1.25.0.05.1.05.10.0
Show 45 moreShow less
5.10.15.10.25.11.05.11.15.11.25.11.35.11.45.12.05.12.15.12.25.12.35.13.05.13.15.13.25.13.35.13.45.13.55.14.05.14.15.14.25.14.35.14.45.14.55.15.05.15.15.15.105.15.115.15.125.15.135.15.25.15.35.15.45.15.55.15.65.15.75.15.85.15.95.2.05.3.05.3.15.3.25.4.05.4.15.4.25.4.3
5.15.14
activemq
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
5.6.0+dfsg1-4+deb8u1ubuntu15.6.0+dfsg1-55.13.2+dfsg-25.13.2+dfsg-2ubuntu0.1~esm1
None known
activemq
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
5.14.5-35.15.2-25.15.3-25.15.8-2~18.045.15.8-2~18.04.1~esm1
None known
activemq
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
5.15.10-15.15.11-15.15.11-1ubuntu0.1~esm1
None known
activemq
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
5.16.1-15.16.1-1ubuntu0.1~esm15.16.1-1ubuntu0.1
None known
Show 4 moreShow less
Affected packages
PackageAffectedFixed
activemq
Ubuntu:24.04:LTS
All versions, plus listed versions
5.17.2+dfsg-25.17.6+dfsg-1
None known
activemq
Ubuntu:25.10
All versions, plus listed versions
5.17.6+dfsg-15.17.6+dfsg-2
None known
activemq
Ubuntu:26.10
All versions, plus listed versions
5.17.6+dfsg-25.17.6+dfsg-2ubuntu1
None known
activemq
Ubuntu:26.04:LTS
All versions, plus listed versions
5.17.6+dfsg-2
None known

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-13947 is a medium vulnerability (CVSS 6.1) in Apache Activemq, published February 8, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 79.2%, the 99th percentile. Fixed in org.apache.activemq:activemq-parent 5.16.1.

References

Show 11 moreShow less
This page doesn't list everything

Left out here: 7 versions. The JSON record has them.

MoveEnter Open