Every CVE Search/ Get API key

CVE-2020-14424

Cacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter...

6.1 MediumFix available

Cacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter theme.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.48%Up 0.7 points since Nov 15, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

Cacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter theme.

Record
CVE-2020-14424
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter theme.

Record
CVE-2020-14424
Updated
2026-11-02
EUVDEUVD-2020-6563 No score

Cacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter theme.

Record
EUVD-2020-6563
Updated
2026-11-03
GitHub AdvisoriesGHSA-5gvx-jvhg-chfx No score

Cacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter...

Cacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter theme.

Record
GHSA-5gvx-jvhg-chfx
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Cacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter theme.

Record
CVE-2020-14424
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2020-14424 6.1

Cacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter theme.

Record
DEBIAN-CVE-2020-14424
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2020-14424 6.1

Cacti before 1.2.18 allows remote attackers to trigger XSS via template import for the midwinter theme.

Record
UBUNTU-CVE-2020-14424
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2021:1190-1 No score

Security update for cacti, cacti-spine

This update for cacti, cacti-spine fixes the following issues:

cacti-spine 1.2.18:

  • Fix missing time parameter on FROM_UNIXTIME function

cacti 1.2.18:

  • CVE-2020-14424: Lack of escaping on template import can lead to XSS exposure under 'midwinter' theme (boo#1188188)
  • Real time graphs can expose XSS issue
Record
openSUSE-SU-2021:1190-1
Updated
2026-11-02
OSVopenSUSE-SU-2021:1208-1 No score

Security update for cacti, cacti-spine

This update for cacti, cacti-spine fixes the following issues:

cacti-spine 1.2.18:

  • Fix missing time parameter on FROM_UNIXTIME function

cacti 1.2.18:

  • CVE-2020-14424: Lack of escaping on template import can lead to XSS exposure under 'midwinter' theme (boo#1188188)
  • Real time graphs can expose XSS issue

This update was imported from the openSUSE:Leap:15.2:Update update project.

Record
openSUSE-SU-2021:1208-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10670-1 No score

cacti-1.2.18-1.2 on GA media

These are all security issues fixed in the cacti-1.2.18-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10670-1
Updated
2026-11-02
OSVUSN-5214-1 No score

cacti vulnerabilities

It was discovered that Cacti was incorrectly validating permissions for user accounts that had been recently disabled. An authenticated attacker could possibly use this to obtain unauthorized access to application and system data. (CVE-2020-13230)

It was discovered that Cacti was incorrectly performing authorization checks in auth_profile.php. A remote unauthenticated attacker could use this to perform a CSRF attack and set a new admin email or make other changes. This issue only affected Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2020-13231)

It was discovered that Cacti incorrectly handled user provided input sent through request parameters to the color.php script. A remote authenticated attacker could use this issue to perform SQL injection attacks. This issue only affected Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2020-14295)

It was discovered that Cacti did not properly escape file input fields when performing template import operations for various themes. An authenticated attacker could use this to perform XSS attacks. This issue only affected Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2020-14424)

It was discovered that Cacti incorrectly handled user provided input sent through request parameters to the data_debug.php script. A remote authenticated attacker could use this issue to perform SQL injection attacks. This issue only affected Ubuntu 20.04 ESM. (CVE-2020-35701)

Record
USN-5214-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cacti
Debian:12
before 1.2.19+ds1-1
1.2.19+ds1-1
cacti
Debian:13
before 1.2.19+ds1-1
1.2.19+ds1-1
cacti
Debian:14
before 1.2.19+ds1-1
1.2.19+ds1-1
cacti
Ubuntu:Pro:18.04:LTS
before 1.1.38+ds1-1ubuntu0.1~esm1, plus listed versions
1.1.18+ds1-11.1.27+ds1-21.1.27+ds1-31.1.28+ds1-21.1.35+ds1-11.1.36+ds1-11.1.38+ds1-1
1.1.38+ds1-1ubuntu0.1~esm1
cacti
Ubuntu:Pro:20.04:LTS
before 1.2.10+ds1-1ubuntu1+esm1, plus listed versions
1.2.4+ds1-2ubuntu31.2.9+ds1-1ubuntu11.2.9+ds1-1ubuntu21.2.10+ds1-1ubuntu1
1.2.10+ds1-1ubuntu1+esm1
cacti
Ubuntu:Pro:16.04:LTS
From an advisory covering 5 CVEs
before 0.8.8f+ds1-4ubuntu4.16.04.2+esm1, plus listed versions
0.8.8f+ds1-20.8.8f+ds1-30.8.8f+ds1-40.8.8f+ds1-4ubuntu10.8.8f+ds1-4ubuntu2
Show 5 moreShow less
0.8.8f+ds1-4ubuntu30.8.8f+ds1-4ubuntu40.8.8f+ds1-4ubuntu4.16.040.8.8f+ds1-4ubuntu4.16.04.10.8.8f+ds1-4ubuntu4.16.04.2
0.8.8f+ds1-4ubuntu4.16.04.2+esm1
cacti
Ubuntu:Pro:18.04:LTS
From an advisory covering 5 CVEs
before 1.1.38+ds1-1ubuntu0.1~esm1, plus listed versions
1.1.18+ds1-11.1.27+ds1-21.1.27+ds1-31.1.28+ds1-21.1.35+ds1-11.1.36+ds1-11.1.38+ds1-1
1.1.38+ds1-1ubuntu0.1~esm1
cacti
Ubuntu:Pro:20.04:LTS
From an advisory covering 5 CVEs
before 1.2.10+ds1-1ubuntu1+esm1, plus listed versions
1.2.4+ds1-2ubuntu31.2.9+ds1-1ubuntu11.2.9+ds1-1ubuntu21.2.10+ds1-1ubuntu1
1.2.10+ds1-1ubuntu1+esm1
cacti
SUSE:Package Hub 12
before 1.2.18-bp153.2.3.1
1.2.18-bp153.2.3.1
cacti-spine
SUSE:Package Hub 12
before 1.2.18-bp153.2.3.1
1.2.18-bp153.2.3.1
Show 9 moreShow less
Affected packages
PackageAffectedFixed
cacti
SUSE:Package Hub 15 SP3
before 1.2.18-bp153.2.3.1
1.2.18-bp153.2.3.1
cacti-spine
SUSE:Package Hub 15 SP3
before 1.2.18-bp153.2.3.1
1.2.18-bp153.2.3.1
cacti
openSUSE:Leap 15.2
before 1.2.18-bp153.2.3.1
1.2.18-bp153.2.3.1
cacti-spine
openSUSE:Leap 15.2
before 1.2.18-bp153.2.3.1
1.2.18-bp153.2.3.1
cacti
openSUSE:Leap 15.3
before 1.2.18-bp153.2.3.1
1.2.18-bp153.2.3.1
cacti-spine
openSUSE:Leap 15.3
before 1.2.18-bp153.2.3.1
1.2.18-bp153.2.3.1
cacti
SUSE:Package Hub 15 SP2
before 1.2.18-bp152.2.13.1
1.2.18-bp152.2.13.1
cacti-spine
SUSE:Package Hub 15 SP2
before 1.2.18-bp152.2.10.1
1.2.18-bp152.2.10.1
cacti
openSUSE:Tumbleweed
From an advisory covering 31 CVEs
before 1.2.18-1.2
1.2.18-1.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-14424 is a medium vulnerability (CVSS 6.1) in Cacti, published August 25, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.48%, the 74th percentile. Fixed in cacti 1.2.19+ds1-1.

References

Show 41 moreShow less
MoveEnter Open