CVE-2020-15154
Cross Site Scripting in baserCMS
CVE-2020-15154 is a high vulnerability (CVSS 7.3) in Basercms, published August 28, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in baserproject/basercms 4.3.7.
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) via arbitrary script execution. Admin access is required to exploit this vulnerability. The affected components are: content_fields.php, content_info.php, content_options.php, content_related.php, index_list_tree.php, jquery.bcTree.js. The issue is fixed in version 4.3.7.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.3
Cross Site Scripting in baserCMS
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) via arbitrary script execution. Admin access is required to exploit this vulnerability. The affected components are: content_fields.php, content_info.php, content_options.php, content_related.php, index_list_tree.php, jquery.bcTree.js. The issue is fixed in version 4.3.7.
- Record
CVE-2020-15154- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2020-0616
7.3
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) via arbitrary script execution. Admin access is required to exploit this vulnerability. The affected components are: content_fields.php, content_info.php, content_options.php, content_related.php, index_list_tree.php, jquery.bcTree.js. The issue is fixed in version 4.3.7.
- Record
EUVD-2020-0616- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cpxc-67rc-c775
7.3
Cross Site Scripting in baserCMS
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS).
- Impact: XSS via Arbitrary script execution.
- Attack vector is: Administrator must be logged in.
- Components are: content_fields.php, content_info.php, content_options.php, content_related.php, index_list_tree.php, jquery.bcTree.js
- Tested baserCMS Version : 4.3.6 (Latest)
- Affected baserCMS Version : 4.0.0 ~ 4.3.6
- Patches : https://basercms.net/security/20200827
Found by Aquilao Null
- Record
GHSA-cpxc-67rc-c775- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
7.3
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) via arbitrary script execution. Admin access is required to exploit this vulnerability. The affected components are: content_fields.php, content_info.php, content_options.php, content_related.php, index_list_tree.php, jquery.bcTree.js. The issue is fixed in version 4.3.7.
- Record
CVE-2020-15154- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N - CVSS 2.0
- 2.1 Low
AV:N/AC:H/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
7.3
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) via arbitrary script execution. Admin access is required to exploit this vulnerability. The affected components are: content_fields.php, content_info.php, content_options.php, content_related.php, index_list_tree.php, jquery.bcTree.js. The issue is fixed in version 4.3.7.
- Record
CVE-2020-15154- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-cpxc-67rc-c775
7.3
Cross Site Scripting in baserCMS
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS).
- Impact: XSS via Arbitrary script execution.
- Attack vector is: Administrator must be logged in.
- Components are: content_fields.php, content_info.php, content_options.php, content_related.php, index_list_tree.php, jquery.bcTree.js
- Tested baserCMS Version : 4.3.6 (Latest)
- Affected baserCMS Version : 4.0.0 ~ 4.3.6
- Patches : https://basercms.net/security/20200827
Found by Aquilao Null
- Record
GHSA-cpxc-67rc-c775- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
baserproject/basercmsPackagist |
4.0.0 to 4.3.6 | 4.3.7 |
baserproject/basercmsPackagist |
4.0.0 up to 4.3.7, plus listed versions 4.0.14.0.104.0.10.14.0.114.0.2 Show 33 moreShow less4.0.2.14.0.34.0.44.0.54.0.5.14.0.5.24.0.64.0.74.0.84.0.94.1.04.1.0.14.1.14.1.24.1.34.1.44.1.54.1.64.1.74.1.84.2.04.2.14.2.24.2.34.2.44.2.54.3.04.3.14.3.24.3.34.3.44.3.54.3.6 |
4.3.7 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |