CVE-2020-15861
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink)...
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink) following.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink) following.
- Record
CVE-2020-15861- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.2 High
AV:L/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-59
- Updated
- 2026-11-02
CVE List
7.8
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink) following.
- Record
CVE-2020-15861- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-59
- Updated
- 2026-11-02
EUVDEUVD-2020-7842
7.8
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink) following.
- Record
EUVD-2020-7842- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-mfrp-422x-34qv
7.8
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink)...
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink) following.
- Record
GHSA-mfrp-422x-34qv- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-59
- Updated
- 2026-11-02
OSV
7.8
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink) following.
- Record
CVE-2020-15861- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-15861
7.8
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink) following.
- Record
DEBIAN-CVE-2020-15861- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-15861
7.8
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink) following.
- Record
UBUNTU-CVE-2020-15861- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4471-1 No score
net-snmp vulnerabilities
Tobias Neitzel discovered that Net-SNMP incorrectly handled certain symlinks. An attacker could possibly use this issue to access sensitive information. (CVE-2020-15861)
It was discovered that Net-SNMP incorrectly handled certain inputs. An attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2020-15862)
- Record
USN-4471-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
net-snmpDebian:12 |
before 5.8+dfsg-5 | 5.8+dfsg-5 |
net-snmpDebian:13 |
before 5.8+dfsg-5 | 5.8+dfsg-5 |
net-snmpDebian:14 |
before 5.8+dfsg-5 | 5.8+dfsg-5 |
net-snmpDebian:9 |
before 5.7.3+dfsg-1.7+deb9u3, plus listed versions 5.7.3+dfsg-1.75.7.3+dfsg-1.7+deb9u15.7.3+dfsg-1.7+deb9u2 |
5.7.3+dfsg-1.7+deb9u3 |
net-snmpDebian:10 From an advisory covering 2 CVEs |
before 5.7.3+dfsg-5+deb10u1, plus listed versions 5.7.3+dfsg-5 |
5.7.3+dfsg-5+deb10u1 |
net-snmpUbuntu:Pro:14.04:LTS |
before 5.7.2~dfsg-8.1ubuntu3.3+esm1, plus listed versions 5.7.2~dfsg-8ubuntu15.7.2~dfsg-8ubuntu25.7.2~dfsg-8.1ubuntu15.7.2~dfsg-8.1ubuntu25.7.2~dfsg-8.1ubuntu35.7.2~dfsg-8.1ubuntu3.15.7.2~dfsg-8.1ubuntu3.25.7.2~dfsg-8.1ubuntu3.3 |
5.7.2~dfsg-8.1ubuntu3.3+esm1 |
net-snmpUbuntu:16.04:LTS |
before 5.7.3+dfsg-1ubuntu4.5, plus listed versions 5.7.3+dfsg-1ubuntu25.7.3+dfsg-1ubuntu35.7.3+dfsg-1ubuntu45.7.3+dfsg-1ubuntu4.15.7.3+dfsg-1ubuntu4.25.7.3+dfsg-1ubuntu4.35.7.3+dfsg-1ubuntu4.4 |
5.7.3+dfsg-1ubuntu4.5 |
net-snmpUbuntu:18.04:LTS |
before 5.7.3+dfsg-1.8ubuntu3.5, plus listed versions 5.7.3+dfsg-1.7ubuntu15.7.3+dfsg-1.8ubuntu15.7.3+dfsg-1.8ubuntu25.7.3+dfsg-1.8ubuntu35.7.3+dfsg-1.8ubuntu3.15.7.3+dfsg-1.8ubuntu3.25.7.3+dfsg-1.8ubuntu3.3 |
5.7.3+dfsg-1.8ubuntu3.5 |
net-snmpUbuntu:20.04:LTS |
before 5.8+dfsg-2ubuntu2.3, plus listed versions 5.7.3+dfsg-5ubuntu55.7.3+dfsg-5ubuntu65.8+dfsg-2ubuntu15.8+dfsg-2ubuntu25.8+dfsg-2ubuntu2.15.8+dfsg-2ubuntu2.2 |
5.8+dfsg-2ubuntu2.3 |
net-snmpUbuntu:Pro:14.04:LTS From an advisory covering 2 CVEs |
before 5.7.2~dfsg-8.1ubuntu3.3+esm1, plus listed versions 5.7.2~dfsg-8ubuntu15.7.2~dfsg-8ubuntu25.7.2~dfsg-8.1ubuntu15.7.2~dfsg-8.1ubuntu25.7.2~dfsg-8.1ubuntu35.7.2~dfsg-8.1ubuntu3.15.7.2~dfsg-8.1ubuntu3.25.7.2~dfsg-8.1ubuntu3.3 |
5.7.2~dfsg-8.1ubuntu3.3+esm1 |
net-snmpUbuntu:16.04:LTS From an advisory covering 2 CVEs |
before 5.7.3+dfsg-1ubuntu4.5, plus listed versions 5.7.3+dfsg-1ubuntu25.7.3+dfsg-1ubuntu35.7.3+dfsg-1ubuntu45.7.3+dfsg-1ubuntu4.15.7.3+dfsg-1ubuntu4.25.7.3+dfsg-1ubuntu4.35.7.3+dfsg-1ubuntu4.4 |
5.7.3+dfsg-1ubuntu4.5 |
net-snmpUbuntu:18.04:LTS From an advisory covering 2 CVEs |
before 5.7.3+dfsg-1.8ubuntu3.5, plus listed versions 5.7.3+dfsg-1.7ubuntu15.7.3+dfsg-1.8ubuntu15.7.3+dfsg-1.8ubuntu25.7.3+dfsg-1.8ubuntu35.7.3+dfsg-1.8ubuntu3.15.7.3+dfsg-1.8ubuntu3.25.7.3+dfsg-1.8ubuntu3.3 |
5.7.3+dfsg-1.8ubuntu3.5 |
net-snmpUbuntu:20.04:LTS From an advisory covering 2 CVEs |
before 5.8+dfsg-2ubuntu2.3, plus listed versions 5.7.3+dfsg-5ubuntu55.7.3+dfsg-5ubuntu65.8+dfsg-2ubuntu15.8+dfsg-2ubuntu25.8+dfsg-2ubuntu2.15.8+dfsg-2ubuntu2.2 |
5.8+dfsg-2ubuntu2.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-15861 is a high vulnerability (CVSS 7.8) in Net-snmp, published August 4, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 39th percentile. Fixed in net-snmp 5.8+dfsg-5.