Every CVE Search/ Get API key

CVE-2020-15888

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection,...

8.8 HighFix available

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.44%Up 1.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

Record
CVE-2020-15888
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-125, CWE-416, CWE-787
Updated
2026-11-02
CVE List No score

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

Record
CVE-2020-15888
Updated
2026-11-02
EUVDEUVD-2020-7862 No score

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

Record
EUVD-2020-7862
Updated
2026-11-03
GitHub AdvisoriesGHSA-4f5v-4r5w-g4x3 8.8

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection,...

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

Record
GHSA-4f5v-4r5w-g4x3
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-125, CWE-416
Updated
2026-11-02
OSVAZL-6670 8.8

CVE-2020-15888 affecting package lua for versions less than 5.3.5-11

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

Record
AZL-6670
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBELL-CVE-2020-15888 8.8

CVE-2020-15888 does not affect BellSoft software

Record
BELL-CVE-2020-15888
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSV 8.8

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

Record
CVE-2020-15888
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-15888 8.8

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

Record
DEBIAN-CVE-2020-15888
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-lua-2020-15888 No score

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

Record
BIT-lua-2020-15888
Updated
2026-11-02
OSVopenSUSE-SU-2024:11029-1 No score

liblua5_4-5-32bit-5.4.3-4.2 on GA media

These are all security issues fixed in the liblua5_4-5-32bit-5.4.3-4.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11029-1
Updated
2026-11-02
OSVopenSUSE-SU-2025:15401-1 No score

liblua5_5-5-5.5.0~beta1-1.1 on GA media

These are all security issues fixed in the liblua5_5-5-5.5.0~beta1-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15401-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lua
Azure Linux:2
before 5.3.5-11
5.3.5-11
lua
Bitnami
5.4.0 up to 5.4.1
5.4.1
lua5.4
Debian:12
before 5.4.1-1
5.4.1-1
lua5.4
Debian:13
before 5.4.1-1
5.4.1-1
lua5.4
Debian:14
before 5.4.1-1
5.4.1-1
lua55
openSUSE:Tumbleweed
From an advisory covering 9 CVEs
before 5.5.0~beta1-1.1
5.5.0~beta1-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-15888 is a high vulnerability (CVSS 8.8) in Lua, published July 21, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.44%, the 84th percentile. Fixed in lua 5.3.5-11.

References

Show 13 moreShow less
MoveEnter Open