CVE-2020-16093
In LemonLDAP::NG (aka lemonldap-ng) through 2.0.8, validity of the X.509 certificate is not...
In LemonLDAP::NG (aka lemonldap-ng) through 2.0.8, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
In LemonLDAP::NG (aka lemonldap-ng) through 2.0.8, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used.
- Record
CVE-2020-16093- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
CVE List No score
In LemonLDAP::NG (aka lemonldap-ng) through 2.0.8, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used.
- Record
CVE-2020-16093- Updated
- 2026-11-02
EUVDEUVD-2020-8060 No score
In LemonLDAP::NG (aka lemonldap-ng) through 2.0.8, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used.
- Record
EUVD-2020-8060- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9c48-27fx-7952
7.5
In LemonLDAP::NG (aka lemonldap-ng) through 2.0.8, validity of the X.509 certificate is not...
In LemonLDAP::NG (aka lemonldap-ng) through 2.0.8, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used.
- Record
GHSA-9c48-27fx-7952- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
OSV
7.5
In LemonLDAP::NG (aka lemonldap-ng) through 2.0.8, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used.
- Record
CVE-2020-16093- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-16093
7.5
In LemonLDAP::NG (aka lemonldap-ng) through 2.0.8, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used.
- Record
DEBIAN-CVE-2020-16093- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-16093
7.5
In LemonLDAP::NG (aka lemonldap-ng) through 2.0.8, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used.
- Record
UBUNTU-CVE-2020-16093- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lemonldap-ngDebian:12 |
before 2.0.9+ds-1 | 2.0.9+ds-1 |
lemonldap-ngDebian:13 |
before 2.0.9+ds-1 | 2.0.9+ds-1 |
lemonldap-ngDebian:14 |
before 2.0.9+ds-1 | 2.0.9+ds-1 |
lemonldap-ngDebian:10 From an advisory covering 2 CVEs |
before 2.0.2+ds-7+deb10u8, plus listed versions 2.0.2+ds-7+deb10u12.0.2+ds-7+deb10u22.0.2+ds-7+deb10u32.0.2+ds-7+deb10u42.0.2+ds-7+deb10u52.0.2+ds-7+deb10u62.0.2+ds-7+deb10u7 |
2.0.2+ds-7+deb10u8 |
lemonldap-ngUbuntu:16.04:LTS |
All versions, plus listed versions 1.3.3-11.4.6-11.4.6-21.4.6-3 |
None known |
lemonldap-ngUbuntu:18.04:LTS |
All versions, plus listed versions 1.9.10-11.9.13-21.9.14-11.9.15-11.9.16-2 |
None known |
lemonldap-ngUbuntu:20.04:LTS |
All versions, plus listed versions 2.0.5+ds-22.0.6+ds-22.0.7+ds-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-16093 is a high vulnerability (CVSS 7.5) in Debian Linux, published July 17, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.78%, the 56th percentile. Fixed in lemonldap-ng 2.0.9+ds-1.
References
lemonldap-ng.org/download
gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/2250
lists.debian.org/debian-lts-announce/2023/01/msg00027.html
nvd.nist.gov/vuln/detail/CVE-2020-16093
github.com/advisories/GHSA-9c48-27fx-7952
security-tracker.debian.org/tracker/CVE-2020-16093
ubuntu.com/security/CVE-2020-16093
cve.org/CVERecord?id=CVE-2020-16093