CVE-2020-16122
Packagekit's apt backend lets user install untrusted local packages
PackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is based on repository trust and not on the contents of individual files. On sites with configured PolicyKit rules this may allow users to install malicious packages.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.2
Packagekit's apt backend lets user install untrusted local packages
PackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is based on repository trust and not on the contents of individual files. On sites with configured PolicyKit rules this may allow users to install malicious packages.
- Record
CVE-2020-16122- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
EUVDEUVD-2020-8088
8.2
PackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is based on repository trust and not on the contents of individual files. On sites with configured PolicyKit rules this may allow users to install malicious packages.
- Record
EUVD-2020-8088- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jfj4-x686-g8vv
7.8
PackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is...
PackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is based on repository trust and not on the contents of individual files. On sites with configured PolicyKit rules this may allow users to install malicious packages.
- Record
GHSA-jfj4-x686-g8vv- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-345
- Updated
- 2026-11-02
NVD
8.2
PackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is based on repository trust and not on the contents of individual files. On sites with configured PolicyKit rules this may allow users to install malicious packages.
- Record
CVE-2020-16122- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 2.1 Low
AV:L/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-269, CWE-345
- Updated
- 2026-11-02
OSV
7.8
PackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is based on repository trust and not on the contents of individual files. On sites with configured PolicyKit rules this may allow users to install malicious packages.
- Record
CVE-2020-16122- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-16122
7.8
PackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is based on repository trust and not on the contents of individual files. On sites with configured PolicyKit rules this may allow users to install malicious packages.
- Record
DEBIAN-CVE-2020-16122- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-16122
7.8
PackageKit's apt backend mistakenly treated all local debs as trusted. The apt security model is based on repository trust and not on the contents of individual files. On sites with configured PolicyKit rules this may allow users to install malicious packages.
- Record
UBUNTU-CVE-2020-16122- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 8.2 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4538-1 No score
packagekit vulnerabilities
Vaisha Bernard discovered that PackageKit incorrectly handled certain methods. A local attacker could use this issue to learn the MIME type of any file on the system. (CVE-2020-16121)
Sami Niemimäki discovered that PackageKit incorrectly handled local deb packages. A local user could possibly use this issue to install untrusted packages, contrary to expectations. (CVE-2020-16122)
- Record
USN-4538-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
packagekitDebian:12 |
before 1.2.1-1 | 1.2.1-1 |
packagekitDebian:13 |
before 1.2.1-1 | 1.2.1-1 |
packagekitDebian:14 |
before 1.2.1-1 | 1.2.1-1 |
packagekitDebian:9 From an advisory covering 2 CVEs |
before 1.1.5-2+deb9u2, plus listed versions 1.1.5-21.1.5-2+deb9u1 |
1.1.5-2+deb9u2 |
packagekitUbuntu:16.04:LTS |
before 0.8.17-4ubuntu6~gcc5.4ubuntu1.5, plus listed versions 0.8.17-4ubuntu6~gcc5.30.8.17-4ubuntu6~gcc5.4ubuntu10.8.17-4ubuntu6~gcc5.4ubuntu1.10.8.17-4ubuntu6~gcc5.4ubuntu1.20.8.17-4ubuntu6~gcc5.4ubuntu1.30.8.17-4ubuntu6~gcc5.4ubuntu1.4 |
0.8.17-4ubuntu6~gcc5.4ubuntu1.5 |
packagekitUbuntu:18.04:LTS |
before 1.1.9-1ubuntu2.18.04.6, plus listed versions 1.1.7-11.1.9-11.1.9-1ubuntu11.1.9-1ubuntu21.1.9-1ubuntu2.18.04.11.1.9-1ubuntu2.18.04.31.1.9-1ubuntu2.18.04.41.1.9-1ubuntu2.18.04.5 |
1.1.9-1ubuntu2.18.04.6 |
packagekitUbuntu:20.04:LTS |
before 1.1.13-2ubuntu1.1, plus listed versions 1.1.12-5ubuntu41.1.13-11.1.13-21.1.13-2build11.1.13-2ubuntu1 |
1.1.13-2ubuntu1.1 |
packagekitUbuntu:16.04:LTS From an advisory covering 2 CVEs |
before 0.8.17-4ubuntu6~gcc5.4ubuntu1.5, plus listed versions 0.8.17-4ubuntu6~gcc5.30.8.17-4ubuntu6~gcc5.4ubuntu10.8.17-4ubuntu6~gcc5.4ubuntu1.10.8.17-4ubuntu6~gcc5.4ubuntu1.20.8.17-4ubuntu6~gcc5.4ubuntu1.30.8.17-4ubuntu6~gcc5.4ubuntu1.4 |
0.8.17-4ubuntu6~gcc5.4ubuntu1.5 |
packagekitUbuntu:18.04:LTS From an advisory covering 2 CVEs |
before 1.1.9-1ubuntu2.18.04.6, plus listed versions 1.1.7-11.1.9-11.1.9-1ubuntu11.1.9-1ubuntu21.1.9-1ubuntu2.18.04.11.1.9-1ubuntu2.18.04.31.1.9-1ubuntu2.18.04.41.1.9-1ubuntu2.18.04.5 |
1.1.9-1ubuntu2.18.04.6 |
packagekitUbuntu:20.04:LTS From an advisory covering 2 CVEs |
before 1.1.13-2ubuntu1.1, plus listed versions 1.1.12-5ubuntu41.1.13-11.1.13-21.1.13-2build11.1.13-2ubuntu1 |
1.1.13-2ubuntu1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-16122 is a high vulnerability (CVSS 8.2) in Packagekit, published June 13, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in packagekit 1.2.1-1.
References
bugs.launchpad.net/ubuntu/+source/packagekit/+bug/1882098
nvd.nist.gov/vuln/detail/CVE-2020-16122
github.com/advisories/GHSA-jfj4-x686-g8vv
security-tracker.debian.org/tracker/CVE-2020-16122
ubuntu.com/security/CVE-2020-16122
ubuntu.com/security/notices/USN-4538-1
cve.org/CVERecord?id=CVE-2020-16122
ubuntu.com/security/CVE-2020-16121