CVE-2020-16253
PgHero gem allows CSRF
The PgHero gem through 2.6.0 for Ruby allows CSRF.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
The PgHero gem through 2.6.0 for Ruby allows CSRF.
- Record
CVE-2020-16253- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:P - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
The PgHero gem through 2.6.0 for Ruby allows CSRF.
- Record
CVE-2020-16253- Updated
- 2026-11-02
EUVDEUVD-2020-0642 No score
The PgHero gem through 2.6.0 for Ruby allows CSRF.
- Record
EUVD-2020-0642- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v6fx-752r-ccp2
8.1
PgHero gem allows CSRF
The PgHero gem through 2.6.0 for Ruby allows CSRF. PgHero normally uses the protect_from_forgery method from Rails to prevent CSRF. However, this defaults to :null_session, which has no effect on non-session based authentication methods. Thus the ruby gem is vulnerable with non-session based authentication methods like basic authentication.
- Record
GHSA-v6fx-752r-ccp2- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV
8.1
The PgHero gem through 2.6.0 for Ruby allows CSRF.
- Record
CVE-2020-16253- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-v6fx-752r-ccp2
8.1
PgHero gem allows CSRF
The PgHero gem through 2.6.0 for Ruby allows CSRF. PgHero normally uses the protect_from_forgery method from Rails to prevent CSRF. However, this defaults to :null_session, which has no effect on non-session based authentication methods. Thus the ruby gem is vulnerable with non-session based authentication methods like basic authentication.
- Record
GHSA-v6fx-752r-ccp2- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pgheroRubyGems |
before 2.7.0 | 2.7.0 |
pgheroRubyGems |
before 2.7.0, plus listed versions 0.0.10.0.20.0.30.1.00.1.1 Show 45 moreShow less0.1.100.1.20.1.30.1.40.1.50.1.60.1.70.1.80.1.91.0.01.0.11.1.01.1.11.1.21.1.31.1.41.2.01.2.11.2.21.2.31.2.41.3.01.3.11.3.21.4.01.4.11.4.21.5.01.5.11.5.21.5.31.6.01.6.11.6.21.6.31.6.41.6.51.7.02.0.02.0.12.0.22.0.32.0.42.0.52.0.6 |
2.7.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-16253 is a high vulnerability (CVSS 8.1) in Pghero Project Pghero, published August 5, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 40th percentile. Fixed in pghero 2.7.0.
References
Left out here: 13 versions. The JSON record has them.