CVE-2020-17353
scm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when ...
scm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when -dsafe is used, lacks restrictions on embedded-ps and embedded-svg, as demonstrated by including dangerous PostScript code.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
scm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when -dsafe is used, lacks restrictions on embedded-ps and embedded-svg, as demonstrated by including dangerous PostScript code.
- Record
CVE-2020-17353- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
scm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when -dsafe is used, lacks restrictions on embedded-ps and embedded-svg, as demonstrated by including dangerous PostScript code.
- Record
CVE-2020-17353- Updated
- 2026-11-02
EUVDEUVD-2020-9307 No score
scm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when -dsafe is used, lacks restrictions on embedded-ps and embedded-svg, as demonstrated by including dangerous PostScript code.
- Record
EUVD-2020-9307- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wg4f-3xq5-x79h
9.8
scm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when ...
scm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when -dsafe is used, lacks restrictions on embedded-ps and embedded-svg, as demonstrated by including dangerous PostScript code.
- Record
GHSA-wg4f-3xq5-x79h- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
9.8
scm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when -dsafe is used, lacks restrictions on embedded-ps and embedded-svg, as demonstrated by including dangerous PostScript code.
- Record
CVE-2020-17353- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-17353
9.8
scm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when -dsafe is used, lacks restrictions on embedded-ps and embedded-svg, as demonstrated by including dangerous PostScript code.
- Record
DEBIAN-CVE-2020-17353- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2020-17353
9.8
scm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when -dsafe is used, lacks restrictions on embedded-ps and embedded-svg, as demonstrated by including dangerous PostScript code.
- Record
UBUNTU-CVE-2020-17353- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2020-0414 No score
Updated lilypond package fixes a security vulnerability
It was discovered that Lilypond, a program for typesetting sheet music, did not restrict the inclusion of Postscript and SVG commands when operating in safe mode, which could result in the execution of arbitrary code when rendering a typesheet file with embedded Postscript code. (CVE-2020-17353)
- Record
MGASA-2020-0414- Updated
- 2026-11-02
OSVopenSUSE-SU-2020:1453-1 No score
Security update for lilypond
This update for lilypond fixes the following issues:
- CVE-2020-17353: When -dsafe is used, LilyPond lacks restrictions on embedded-ps and embedded-svg (boo#1174949).
- Record
openSUSE-SU-2020:1453-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2020:1506-1 No score
Security update for lilypond
This update for lilypond fixes the following issues:
- CVE-2020-17353: When -dsafe is used, LilyPond lacks restrictions on embedded-ps and embedded-svg (boo#1174949).
This update was imported from the openSUSE:Leap:15.2:Update update project.
- Record
openSUSE-SU-2020:1506-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11021-1 No score
lilypond-2.23.3-1.3 on GA media
These are all security issues fixed in the lilypond-2.23.3-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11021-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lilypondDebian:12 |
before 2.20.0-2 | 2.20.0-2 |
lilypondDebian:13 |
before 2.20.0-2 | 2.20.0-2 |
lilypondDebian:14 |
before 2.20.0-2 | 2.20.0-2 |
lilypondDebian:10 |
before 2.19.81+really-2.18.2-13+deb10u1, plus listed versions 2.19.81+really-2.18.2-13 |
2.19.81+really-2.18.2-13+deb10u1 |
lilypondMageia:7 |
before 2.19.83-1.1.mga7 | 2.19.83-1.1.mga7 |
lilypondUbuntu:16.04:LTS |
All versions, plus listed versions 2.18.2-42.18.2-4.1 |
None known |
lilypondUbuntu:18.04:LTS |
All versions, plus listed versions 2.18.2-92.18.2-112.18.2-122.18.2-12build1 |
None known |
lilypondUbuntu:20.04:LTS |
All versions, plus listed versions 2.19.81+really-2.18.2-13ubuntu12.19.81+really-2.18.2-13ubuntu22.19.81+really-2.18.2-142.20.0-1 |
None known |
lilypondSUSE:Package Hub 15 SP2 |
before 2.20.0-bp152.2.5.6 | 2.20.0-bp152.2.5.6 |
lilypond-docSUSE:Package Hub 15 SP2 |
before 2.20.0-lp152.2.5.10 | 2.20.0-lp152.2.5.10 |
Show 4 moreShow less
| Package | Affected | Fixed |
|---|---|---|
lilypondopenSUSE:Leap 15.2 |
before 2.20.0-bp152.2.5.6 | 2.20.0-bp152.2.5.6 |
lilypond-docopenSUSE:Leap 15.2 |
before 2.20.0-lp152.2.5.10 | 2.20.0-lp152.2.5.10 |
lilypondSUSE:Package Hub 15 SP2 |
before 2.20.0-bp152.2.8.1 | 2.20.0-bp152.2.8.1 |
lilypondopenSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 2.23.3-1.3 | 2.23.3-1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-17353 is a critical vulnerability (CVSS 9.8) in Lilypond, published August 5, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.31%, the 83rd percentile. Fixed in lilypond 2.20.0-2.
References
git.savannah.gnu.org/gitweb?p=lilypond.git%3Ba=commit%3Bh=b84ea4740f3279516905c5db05f4074e777c16ff
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QG2JUV4UTIA27JUE6IZLCEFP5PYSFPF4
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/W2JYMVLTPSNYS5F7TBHKIXUZZJIJAMRX
debian.org/security/2020/dsa-4756
lists.opensuse.org/opensuse-security-announce/2020-09/msg00064.html
lists.opensuse.org/opensuse-security-announce/2020-09/msg00076.html
Show 16 moreShow less
nvd.nist.gov/vuln/detail/CVE-2020-17353
lists.fedoraproject.org/archives/list/[email protected]/message/QG2JUV4UTIA27JUE6IZLCEFP5PYSFPF4
lists.fedoraproject.org/archives/list/[email protected]/message/W2JYMVLTPSNYS5F7TBHKIXUZZJIJAMRX
git.savannah.gnu.org/gitweb?p=lilypond.git;a=commit;h=b84ea4740f3279516905c5db05f4074e777c16ff
github.com/advisories/GHSA-wg4f-3xq5-x79h
security-tracker.debian.org/tracker/CVE-2020-17353
advisories.mageia.org/MGASA-2020-0414.html
bugs.mageia.org/show_bug.cgi?id=27174
lists.fedoraproject.org/archives/list/[email protected]/thread/QG2JUV4UTIA27JUE6IZLCEFP5PYSFPF4
ubuntu.com/security/CVE-2020-17353
cve.org/CVERecord?id=CVE-2020-17353
lists.opensuse.org/archives/list/[email protected]/thread/LZLU3RBT6EACHJVY3TSE3V25RFIN7ZMM
bugzilla.suse.com/1174949
suse.com/security/cve/CVE-2020-17353
lists.opensuse.org/archives/list/[email protected]/thread/MJP3VB3XJ47C64LSD4XRTENGM2FHG2VC
suse.com/security/cve/CVE-2018-10992