Every CVE Search/ Get API key

CVE-2020-17354

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def...

8.6 HighFix available

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.41%Up 0.4 points since Apr 16, 2023
90%50%10%1%

What each source reports

NVD Score used 8.6

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.

Record
CVE-2020-17354
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
CVE List 8.6

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.

Record
CVE-2020-17354
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2020-9308 8.6

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.

Record
EUVD-2020-9308
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-vm3h-24gm-v3q6 8.6

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def...

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.

Record
GHSA-vm3h-24gm-v3q6
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
OSV 8.6

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.

Record
CVE-2020-17354
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-17354 8.6

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.

Record
DEBIAN-CVE-2020-17354
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-17354 8.6

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.

Record
UBUNTU-CVE-2020-17354
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2023-0325 No score

Updated lilypond packages fix a security vulnerability

Updated lilypond packages fix a security vulnerability:

LilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.

Record
MGASA-2023-0325
Updated
2026-11-02
OSVopenSUSE-SU-2023:0137-1 No score

Security update for guile1, lilypond

This update for guile1, lilypond fixes the following issues:

guile1:

  • Add service file to download release from git excluding the directory with commercial non free files.
  • Update to version 2.2.6 to enable lilypond to be updated to 2.24.1 to fix boo#1210502 and CVE-2020-17354.

lilypond:

  • Update to version lilypond-2.24.1 to fix boo#1210502 - CVE-2020-17354: lilypond: Lilypond allows attackers to bypass the -dsafe protection mechanism.
Record
openSUSE-SU-2023:0137-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lilypond
Debian:12
before 2.22.1-1
2.22.1-1
lilypond
Debian:13
before 2.22.1-1
2.22.1-1
lilypond
Debian:14
before 2.22.1-1
2.22.1-1
lilypond
Mageia:9
before 2.24.2-2.mga9
2.24.2-2.mga9
lilypond
Ubuntu:16.04:LTS
All versions, plus listed versions
2.18.2-42.18.2-4.1
None known
lilypond
Ubuntu:18.04:LTS
All versions, plus listed versions
2.18.2-92.18.2-112.18.2-122.18.2-12build1
None known
lilypond
Ubuntu:20.04:LTS
All versions, plus listed versions
2.19.81+really-2.18.2-13ubuntu12.19.81+really-2.18.2-13ubuntu22.19.81+really-2.18.2-142.20.0-1
None known
guile1
SUSE:Package Hub 15 SP4
From an advisory covering 2 CVEs
before 2.2.6-bp154.3.3.1
2.2.6-bp154.3.3.1
lilypond
SUSE:Package Hub 15 SP4
From an advisory covering 2 CVEs
before 2.24.1-bp154.2.3.2
2.24.1-bp154.2.3.2
guile1
openSUSE:Leap 15.4
From an advisory covering 2 CVEs
before 2.2.6-bp154.3.3.1
2.2.6-bp154.3.3.1
lilypond
openSUSE:Leap 15.4
From an advisory covering 2 CVEs
before 2.24.1-bp154.2.3.2
2.24.1-bp154.2.3.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-17354 is a high vulnerability (CVSS 8.6) in Lilypond, published April 15, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.41%, the 35th percentile. Fixed in lilypond 2.22.1-1.

References

Show 16 moreShow less
MoveEnter Open