CVE-2020-17480
Cross-site scripting vulnerability in TinyMCE
TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.
- Record
CVE-2020-17480- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.
- Record
CVE-2020-17480- Updated
- 2026-11-02
EUVDEUVD-2020-0245 No score
TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.
- Record
EUVD-2020-0245- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-27gm-ghr9-4v95 No score
Cross-site scripting vulnerability in TinyMCE
Impact
A cross-site scripting (XSS) vulnerability was discovered in: the core parser, paste and visualchars plugins. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.6 or lower and TinyMCE 5.1.3 or lower.
Patches
This vulnerability has been patched in TinyMCE 4.9.7 and 5.1.4 by improved parser logic and HTML sanitization.
Workarounds
The workarounds available are:
- disable the impacted plugins
- manually sanitize the content using the
BeforeSetContentevent (see below) - upgrade to either TinyMCE 4.9.7 or TinyMCE 5.1.4
Example: Manually sanitize content
editor.on('BeforeSetContent', function(e) {
var sanitizedContent = ...; // Manually sanitize content here
e.content = sanitizedContent;
});
Acknowledgements
Tiny Technologies would like to thank Michał Bentkowski for discovering this vulnerability.
References
https://www.tiny.cloud/docs/release-notes/release-notes514/#securityfixes
For more information
If you have any questions or comments about this advisory:
- Open an issue in the TinyMCE repo
- Email us at [email protected]
- Record
GHSA-27gm-ghr9-4v95- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.
- Record
CVE-2020-17480- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-17480
6.1
TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.
- Record
UBUNTU-CVE-2020-17480- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-27gm-ghr9-4v95 No score
Cross-site scripting vulnerability in TinyMCE
Impact
A cross-site scripting (XSS) vulnerability was discovered in: the core parser, paste and visualchars plugins. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.6 or lower and TinyMCE 5.1.3 or lower.
Patches
This vulnerability has been patched in TinyMCE 4.9.7 and 5.1.4 by improved parser logic and HTML sanitization.
Workarounds
The workarounds available are:
- disable the impacted plugins
- manually sanitize the content using the
BeforeSetContentevent (see below) - upgrade to either TinyMCE 4.9.7 or TinyMCE 5.1.4
Example: Manually sanitize content
editor.on('BeforeSetContent', function(e) {
var sanitizedContent = ...; // Manually sanitize content here
e.content = sanitizedContent;
});
Acknowledgements
Tiny Technologies would like to thank Michał Bentkowski for discovering this vulnerability.
References
https://www.tiny.cloud/docs/release-notes/release-notes514/#securityfixes
For more information
If you have any questions or comments about this advisory:
- Open an issue in the TinyMCE repo
- Email us at [email protected]
- Record
GHSA-27gm-ghr9-4v95- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
tinymcenpm |
before 4.9.7 | 4.9.7 |
tinymcenpm |
5.0.0 up to 5.1.4 | 5.1.4 |
tinymceUbuntu:16.04:LTS |
All versions, plus listed versions 3.4.8+dfsg0-1 |
None known |
tinymceUbuntu:18.04:LTS |
All versions, plus listed versions 3.4.8+dfsg0-2 |
None known |
tinymceUbuntu:20.04:LTS |
All versions, plus listed versions 3.4.8+dfsg0-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-17480 is a medium vulnerability (CVSS 6.1) in Tiny Tinymce, published January 30, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.25%, the 69th percentile. Fixed in tinymce 4.9.7.
References
github.com/tinymce/tinymce/security/advisories/GHSA-27gm-ghr9-4v95
tiny.cloud/docs/release-notes/release-notes514
nvd.nist.gov/vuln/detail/CVE-2020-17480
portswigger.net/daily-swig/xss-vulnerability-patched-in-tinymce
github.com/advisories/GHSA-27gm-ghr9-4v95
github.com/tinymce/tinymce
ubuntu.com/security/CVE-2020-17480
cve.org/CVERecord?id=CVE-2020-17480