Every CVE Search/ Get API key

CVE-2020-18971

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via...

5.5 MediumFix available

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via the component 'src/base/PdfDictionary.cpp:65'.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.68%Up 0.2 points since Aug 26, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via the component 'src/base/PdfDictionary.cpp:65'.

Record
CVE-2020-18971
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via the component 'src/base/PdfDictionary.cpp:65'.

Record
CVE-2020-18971
Updated
2026-11-02
EUVDEUVD-2020-10882 No score

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via the component 'src/base/PdfDictionary.cpp:65'.

Record
EUVD-2020-10882
Updated
2026-11-03
GitHub AdvisoriesGHSA-xrmq-h6xp-2vgc No score

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via...

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via the component 'src/base/PdfDictionary.cpp:65'.

Record
GHSA-xrmq-h6xp-2vgc
Weakness
CWE-787
Updated
2026-11-02
OSV 5.5

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via the component 'src/base/PdfDictionary.cpp:65'.

Record
CVE-2020-18971
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-18971 5.5

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via the component 'src/base/PdfDictionary.cpp:65'.

Record
DEBIAN-CVE-2020-18971
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-18971 5.5

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via the component 'src/base/PdfDictionary.cpp:65'.

Record
UBUNTU-CVE-2020-18971
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVSUSE-SU-2026:4311-1 No score

Security update for podofo

This update for podofo fixes the following issues:

  • CVE-2018-8002: infinite loop vulnerability in ParseFileComplete() (bsc#1084891).
  • CVE-2020-18971: stack-based buffer overflow in src/base/PdfDictionary.cpp (bsc#1190178).
  • CVE-2021-30470: uncontrolled recursive call of funtions in src/base/PdfTokenizer.cpp can lead to a stack overflow (bsc#1186588).
  • CVE-2021-30471: uncontrolled recursive call in PdfNamesTree:AddToDictionary function in src/podofo/doc/PdfNamesTree.cpp (bsc#1184645).
Record
SUSE-SU-2026:4311-1
Updated
2026-11-02
OSVUSN-7217-1 No score

libpodofo vulnerabilities

It was discovered that the PoDoFo library could dereference a NULL pointer when getting the number of pages in a PDF. If a user or application were tricked into opening a crafted PDF file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2018-11255)

It was discovered that PoDoFo library incorrectly handled memory when computing an encryption key, which could lead to a buffer overflow. If a user or application were tricked into opening a crafted PDF file, an attacker could possibly use this issue to cause a denial of service. (CVE-2018-12983)

It was discovered that the PoDoFo library incorrectly handled memory allocation. If a user or application were tricked into opening a crafted PDF file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2018-20797)

It was discovered that the PoDoFo library did not properly validate memcpy arguments. If a user or application were tricked into opening a crafted PDF file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2018-5308)

It was discovered that the PoDoFo library incorrectly handled memory in the GetNextToken function, which could lead to a buffer overflow. If a user or application were tricked into opening a crafted PDF file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 LTS. (CVE-2017-5886)

It was discovered that the PoDoFo library could enter an infinite loop, which could lead to a stack overflow. If a user or application were tricked into opening a crafted PDF file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2018-8002, CVE-2020-18971, CVE-2021-30471, CVE-2021-30470)

It was discovered that the PoDoFo library incorrectly handled memory allocation due to nInitialSize not being validated. If a user or application were tricked into opening a crafted PDF file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2019-10723)

Record
USN-7217-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libpodofo
Debian:12
before 0.9.8+dfsg-1
0.9.8+dfsg-1
libpodofo
Debian:13
before 0.9.8+dfsg-1
0.9.8+dfsg-1
libpodofo
Debian:14
before 0.9.8+dfsg-1
0.9.8+dfsg-1
podofo
SUSE:Linux Enterprise Module for Package Hub 15 SP7
before 0.9.6-150300.3.18.1
0.9.6-150300.3.18.1
libpodofo
Ubuntu:Pro:20.04:LTS
before 0.9.6+dfsg-5ubuntu0.1~esm1, plus listed versions
0.9.6+dfsg-50.9.6+dfsg-5build1
0.9.6+dfsg-5ubuntu0.1~esm1
libpodofo
Ubuntu:Pro:22.04:LTS
before 0.9.7+dfsg-3ubuntu0.1~esm1, plus listed versions
0.9.7+dfsg-20.9.7+dfsg-2build10.9.7+dfsg-2build20.9.7+dfsg-3
0.9.7+dfsg-3ubuntu0.1~esm1
libpodofo
Ubuntu:Pro:14.04:LTS
before 0.9.0-1.2ubuntu0.1~esm3, plus listed versions
0.9.0-1.1ubuntu10.9.0-1.20.9.0-1.2ubuntu0.1~esm1
0.9.0-1.2ubuntu0.1~esm3
libpodofo
Ubuntu:Pro:16.04:LTS
before 0.9.3-4ubuntu0.1~esm1, plus listed versions
0.9.0-1.30.9.3-30.9.3-4
0.9.3-4ubuntu0.1~esm1
libpodofo
Ubuntu:Pro:18.04:LTS
before 0.9.5-9ubuntu0.1~esm1, plus listed versions
0.9.5-60.9.5-80.9.5-8build10.9.5-9
0.9.5-9ubuntu0.1~esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-18971 is a medium vulnerability (CVSS 5.5) in Podofo Project Podofo, published August 25, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.68%, the 52nd percentile. Fixed in libpodofo 0.9.8+dfsg-1.

References

Show 19 moreShow less
MoveEnter Open