Every CVE Search/ Get API key

CVE-2020-19189

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in...

6.5 MediumFix available

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in ncurses 6.1 allows remote attackers to cause a denial of service via crafted command.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.29%Up 2.2 points since Aug 23, 2023
90%50%10%1%

What each source reports

NVD Score used 6.5

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in ncurses 6.1 allows remote attackers to cause a denial of service via crafted command.

Record
CVE-2020-19189
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in ncurses 6.1 allows remote attackers to cause a denial of service via crafted command.

Record
CVE-2020-19189
Updated
2026-11-02
EUVDEUVD-2020-11096 No score

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in ncurses 6.1 allows remote attackers to cause a denial of service via crafted command.

Record
EUVD-2020-11096
Updated
2026-11-02
GitHub AdvisoriesGHSA-gx38-wj66-8wfr 6.5

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in...

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in ncurses 6.1 allows remote attackers to cause a denial of service via crafted command.

Record
GHSA-gx38-wj66-8wfr
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 6.5

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in ncurses 6.1 allows remote attackers to cause a denial of service via crafted command.

Record
CVE-2020-19189
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-19189 6.5

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in ncurses 6.1 allows remote attackers to cause a denial of service via crafted command.

Record
DEBIAN-CVE-2020-19189
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVJLSEC-2026-449 6.5

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in ncurses 6.1 allows remote attackers to cause a denial of service via crafted command.

Record
JLSEC-2026-449
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-19189 6.5

Buffer Overflow vulnerability in postprocess_terminfo function in tinfo/parse_entry.c:997 in ncurses 6.1 allows remote attackers to cause a denial of service via crafted command.

Record
UBUNTU-CVE-2020-19189
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-6451-1 No score

ncurses vulnerability

It was discovered that ncurses could be made to read out of bounds. An attacker could possibly use this issue to cause a denial of service.

Record
USN-6451-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ncurses
Debian:12
before 6.1+20191019-1
6.1+20191019-1
ncurses
Debian:13
before 6.1+20191019-1
6.1+20191019-1
ncurses
Debian:14
before 6.1+20191019-1
6.1+20191019-1
ncurses
Debian:10
before 6.1+20181013-2+deb10u4, plus listed versions
6.1+20181013-26.1+20181013-2+deb10u16.1+20181013-2+deb10u26.1+20181013-2+deb10u3
6.1+20181013-2+deb10u4
Ncurses_jll
Julia
before 6.2.0+0
6.2.0+0
ncurses
Ubuntu:Pro:14.04:LTS
before 5.9+20140118-1ubuntu1+esm4, plus listed versions
5.9+20130608-1ubuntu15.9+20131221-1ubuntu15.9+20140118-1ubuntu15.9+20140118-1ubuntu1+esm15.9+20140118-1ubuntu1+esm25.9+20140118-1ubuntu1+esm3
5.9+20140118-1ubuntu1+esm4
ncurses
Ubuntu:Pro:16.04:LTS
before 6.0+20160213-1ubuntu1+esm4, plus listed versions
5.9+20150516-2ubuntu16.0+20151024-2ubuntu16.0+20151024-2ubuntu26.0+20160213-1ubuntu16.0+20160213-1ubuntu1+esm16.0+20160213-1ubuntu1+esm26.0+20160213-1ubuntu1+esm3
6.0+20160213-1ubuntu1+esm4
ncurses
Ubuntu:Pro:18.04:LTS
before 6.1-1ubuntu1.18.04.1+esm1, plus listed versions
6.0+20160625-1ubuntu16.0+20171125-1ubuntu16.1-1ubuntu16.1-1ubuntu1.18.046.1-1ubuntu1.18.04.1
6.1-1ubuntu1.18.04.1+esm1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-19189 is a medium vulnerability (CVSS 6.5) in Invisible-island Ncurses, published August 22, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.29%, the 83rd percentile. Fixed in ncurses 6.1+20191019-1.

References

Show 10 moreShow less
MoveEnter Open