Every CVE Search/ Get API key

CVE-2020-19858

Platinum Upnp SDK through 1.2.0 has a directory traversal vulnerability. The attack could remote...

7.5 HighFix available

Platinum Upnp SDK through 1.2.0 has a directory traversal vulnerability. The attack could remote attack victim by sending http://ip:port/../privacy.avi URL to compromise a victim's privacy.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.71%Up 1.1 points since Jan 22, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Platinum Upnp SDK through 1.2.0 has a directory traversal vulnerability. The attack could remote attack victim by sending http://ip:port/../privacy.avi URL to compromise a victim's privacy.

Record
CVE-2020-19858
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Platinum Upnp SDK through 1.2.0 has a directory traversal vulnerability. The attack could remote attack victim by sending http://ip:port/../privacy.avi URL to compromise a victim's privacy.

Record
CVE-2020-19858
Updated
2026-11-02
EUVDEUVD-2020-11754 No score

Platinum Upnp SDK through 1.2.0 has a directory traversal vulnerability. The attack could remote attack victim by sending http://ip:port/../privacy.avi URL to compromise a victim's privacy.

Record
EUVD-2020-11754
Updated
2026-11-03
GitHub AdvisoriesGHSA-38xv-grg9-f228 No score

Platinum Upnp SDK through 1.2.0 has a directory traversal vulnerability. The attack could remote...

Platinum Upnp SDK through 1.2.0 has a directory traversal vulnerability. The attack could remote attack victim by sending http://ip:port/../privacy.avi URL to compromise a victim's privacy.

Record
GHSA-38xv-grg9-f228
Weakness
CWE-22
Updated
2026-11-02
OSV 7.5

Platinum Upnp SDK through 1.2.0 has a directory traversal vulnerability. The attack could remote attack victim by sending http://ip:port/../privacy.avi URL to compromise a victim's privacy.

Record
CVE-2020-19858
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2020-19858 7.5

Platinum Upnp SDK through 1.2.0 has a directory traversal vulnerability. The attack could remote attack victim by sending http://ip:port/../privacy.avi URL to compromise a victim's privacy.

Record
UBUNTU-CVE-2020-19858
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUSN-7266-1 No score

digikam vulnerabilities

Zinuo Han and Ao Wang discovered that the Android DNG SDK, vendored in digiKam, did not correctly parse certain files. An attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2017-0691)

It was discovered that Platinum Upnp SDK, vendored in digiKam, was vulnerable to a path traversal attack. An attacker could possibly use this issue to leak sensitive information. This issue only affected Ubuntu 20.04 LTS. (CVE-2020-19858)

It was discovered that LibRaw, vendored in digiKam, did not correctly handle certain memory operations. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to leak sensitive information. This issue only affected Ubuntu 20.04 LTS. (CVE-2020-22628)

It was discovered that LibRaw, vendored in digiKam, did not correctly handle certain memory operations. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-35530, CVE-2020-35531, CVE-2020-35532, CVE-2020-35533)

It was discovered that LibRaw, vendored in digiKam, did not correctly handle certain memory operations. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 20.04 LTS. (CVE-2021-32142)

It was discovered that LibRaw, vendored in digiKam, did not correctly handle certain memory operations. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2023-1729)

Record
USN-7266-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kodi
Ubuntu:16.04:LTS
All versions, plus listed versions
15.1+dfsg1-315.2+dfsg1-1build115.2+dfsg1-315.2+dfsg1-3ubuntu115.2+dfsg1-3ubuntu1.1
None known
kodi
Ubuntu:18.04:LTS
All versions, plus listed versions
2:17.3+dfsg1-32:17.3+dfsg1-3build12:17.3+dfsg1-52:17.3+dfsg1-5build12:17.3+dfsg1-5build22:17.6+dfsg1-12:17.6+dfsg1-1build12:17.6+dfsg1-1ubuntu1
None known
digikam
Ubuntu:Pro:20.04:LTS
before 4:6.4.0+dfsg-3ubuntu0.1~esm1, plus listed versions
4:5.9.0-1ubuntu44:6.4.0+dfsg-34:6.4.0+dfsg-3build1
4:6.4.0+dfsg-3ubuntu0.1~esm1
kodi
Ubuntu:20.04:LTS
All versions, plus listed versions
2:17.6+dfsg1-4ubuntu42:17.6+dfsg1-4ubuntu92:17.6+dfsg1-4ubuntu102:18.5+dfsg1-0ubuntu32:18.6+dfsg1-2ubuntu1
None known
kodi
Ubuntu:22.04:LTS
All versions, plus listed versions
2:19.1+dfsg2-22:19.3+dfsg1-12:19.3+dfsg1-1build22:19.3+dfsg1-1build32:19.3+dfsg1-1build42:19.3+dfsg1-1build52:19.4+dfsg1-2
None known
kodi
Ubuntu:24.04:LTS
All versions, plus listed versions
2:20.2+dfsg-42:20.2+dfsg-4build12:20.2+dfsg-4build22:20.2+dfsg-4ubuntu12:20.3+dfsg-12:20.4+dfsg-12:20.5+dfsg-1build22:20.5+dfsg-1ubuntu1
None known
kodi
Ubuntu:25.10
All versions, plus listed versions
2:21.2+dfsg-1build22:21.2+dfsg-42:21.2+dfsg-4build12:21.2+dfsg-4build2
None known
kodi
Ubuntu:26.10
All versions, plus listed versions
2:21.3+dfsg-1ubuntu12:21.3+dfsg-1.2
None known
kodi
Ubuntu:26.04:LTS
All versions, plus listed versions
2:21.2+dfsg-4build22:21.2+dfsg-4build32:21.2+dfsg-52:21.3+dfsg-12:21.3+dfsg-1build12:21.3+dfsg-1ubuntu1
None known
digikam
Ubuntu:Pro:16.04:LTS
From an advisory covering 9 CVEs
before 4:4.12.0-0ubuntu7+esm1, plus listed versions
4:4.12.0-0ubuntu54:4.12.0-0ubuntu64:4.12.0-0ubuntu7
4:4.12.0-0ubuntu7+esm1
digikam
Ubuntu:Pro:18.04:LTS
From an advisory covering 9 CVEs
before 4:5.6.0-0ubuntu10+esm1, plus listed versions
4:5.6.0-0ubuntu24:5.6.0-0ubuntu34:5.6.0-0ubuntu44:5.6.0-0ubuntu74:5.6.0-0ubuntu84:5.6.0-0ubuntu94:5.6.0-0ubuntu10
4:5.6.0-0ubuntu10+esm1
digikam
Ubuntu:Pro:20.04:LTS
From an advisory covering 9 CVEs
before 4:6.4.0+dfsg-3ubuntu0.1~esm1, plus listed versions
4:5.9.0-1ubuntu44:6.4.0+dfsg-34:6.4.0+dfsg-3build1
4:6.4.0+dfsg-3ubuntu0.1~esm1
digikam
Ubuntu:Pro:22.04:LTS
From an advisory covering 9 CVEs
before 4:7.5.0-3ubuntu0.1~esm1, plus listed versions
4:7.1.0-24:7.1.0-2ubuntu14:7.4.0-0ubuntu14:7.5.0-0ubuntu14:7.5.0-3fakesync1
4:7.5.0-3ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-19858 is a high vulnerability (CVSS 7.5) in Plutinosoft Platinum, published January 21, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.71%, the 77th percentile. Fixed in digikam 4:6.4.0+dfsg-3ubuntu0.1~esm1.

References

Show 9 moreShow less
MoveEnter Open