CVE-2020-2023
Kata Containers - Containers have access to the guest root filesystem device
Kata Containers doesn't restrict containers from accessing the guest's root filesystem device. Malicious containers can exploit this to gain code execution on the guest and masquerade as the kata-agent. This issue affects Kata Containers 1.11 versions earlier than 1.11.1; Kata Containers 1.10 versions earlier than 1.10.5; and Kata Containers 1.9 and earlier versions.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
3.8
Kata Containers - Containers have access to the guest root filesystem device
Kata Containers doesn't restrict containers from accessing the guest's root filesystem device. Malicious containers can exploit this to gain code execution on the guest and masquerade as the kata-agent. This issue affects Kata Containers 1.11 versions earlier than 1.11.1; Kata Containers 1.10 versions earlier than 1.10.5; and Kata Containers 1.9 and earlier versions.
- Record
CVE-2020-2023- CVSS 3.1
- 3.8 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N - Weakness
- CWE-250
- Updated
- 2026-11-02
EUVDEUVD-2022-0858
3.8
Kata Containers doesn't restrict containers from accessing the guest's root filesystem device. Malicious containers can exploit this to gain code execution on the guest and masquerade as the kata-agent. This issue affects Kata Containers 1.11 versions earlier than 1.11.1; Kata Containers 1.10 versions earlier than 1.10.5; and Kata Containers 1.9 and earlier versions.
- Record
EUVD-2022-0858- CVSS 3.1
- 3.8 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6978-vg2j-cc9q
9.8
Improper Privilege Management and Execution with Unnecessary Privileges in Kata Containers
Kata Containers doesn't restrict containers from accessing the guest's root filesystem device. Malicious containers can exploit this to gain code execution on the guest and masquerade as the kata-agent. This issue affects Kata Containers 1.11 versions earlier than 1.11.1; Kata Containers 1.10 versions earlier than 1.10.5; and Kata Containers 1.9 and earlier versions.
- Record
GHSA-6978-vg2j-cc9q- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-250, CWE-269
- Updated
- 2026-11-02
NVD
3.8
Kata Containers doesn't restrict containers from accessing the guest's root filesystem device. Malicious containers can exploit this to gain code execution on the guest and masquerade as the kata-agent. This issue affects Kata Containers 1.11 versions earlier than 1.11.1; Kata Containers 1.10 versions earlier than 1.10.5; and Kata Containers 1.9 and earlier versions.
- Record
CVE-2020-2023- CVSS 3.1
- 3.8 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N - CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L - CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-250
- Updated
- 2026-11-02
OSV
6.3
Kata Containers doesn't restrict containers from accessing the guest's root filesystem device. Malicious containers can exploit this to gain code execution on the guest and masquerade as the kata-agent. This issue affects Kata Containers 1.11 versions earlier than 1.11.1; Kata Containers 1.10 versions earlier than 1.10.5; and Kata Containers 1.9 and earlier versions.
- Record
CVE-2020-2023- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L - Updated
- 2026-11-02
OSVGHSA-6978-vg2j-cc9q
9.8
Improper Privilege Management and Execution with Unnecessary Privileges in Kata Containers
Kata Containers doesn't restrict containers from accessing the guest's root filesystem device. Malicious containers can exploit this to gain code execution on the guest and masquerade as the kata-agent. This issue affects Kata Containers 1.11 versions earlier than 1.11.1; Kata Containers 1.10 versions earlier than 1.10.5; and Kata Containers 1.9 and earlier versions.
- Record
GHSA-6978-vg2j-cc9q- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-250, CWE-269
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/kata-containers/agentGo |
through 1.9 | 1.9.1 |
github.com/kata-containers/agentGo |
1.10.0 up to 1.10.5 | 1.10.5 |
github.com/kata-containers/agentGo |
1.11.0 up to 1.11.1 | 1.11.1 |
github.com/kata-containers/runtimeGo |
through 1.9 | 1.9.1 |
github.com/kata-containers/runtimeGo |
1.10.0 up to 1.10.5 | 1.10.5 |
github.com/kata-containers/runtimeGo |
1.11.0 up to 1.11.1 | 1.11.1 |
github.com/kata-containers/agentGo |
before 1.9.1 | 1.9.1 |
github.com/kata-containers/runtimeGo |
before 1.9.1 | 1.9.1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | ssst0n3/kata-cve-2020-2023-poc | 2023-05-08 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-2023 is a low vulnerability (CVSS 3.8) in Kata Containers Containers, published June 10, 2020. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 66th percentile. Fixed in github.com/kata-containers/agent 1.9.1.