CVE-2020-20740
PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in...
PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in pdf_get_version().
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in pdf_get_version().
- Record
CVE-2020-20740- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in pdf_get_version().
- Record
CVE-2020-20740- Updated
- 2026-11-02
EUVDEUVD-2020-13520 No score
PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in pdf_get_version().
- Record
EUVD-2020-13520- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x486-4h5g-3687 No score
PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in...
PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in pdf_get_version().
- Record
GHSA-x486-4h5g-3687- Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
7.8
PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in pdf_get_version().
- Record
CVE-2020-20740- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-20740
7.8
PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in pdf_get_version().
- Record
DEBIAN-CVE-2020-20740- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-20740
7.8
PDFResurrect before 0.20 lack of header validation checks causes heap-buffer-overflow in pdf_get_version().
- Record
UBUNTU-CVE-2020-20740- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2020-0449 No score
Updated pdfresurrect package fixes security vulnerability
In PDFResurrect before 0.20, lack of header validation checks causes a heap-buffer-overflow in pdf_get_version() (CVE-2020-20740).
- Record
MGASA-2020-0449- Updated
- 2026-11-02
OSVUSN-5282-1 No score
pdfresurrect vulnerabilities
It was discovered that PDFResurrect was incorrectly handling corrupted PDF files. An attacker could possibly use this issue to cause a buffer overflow, resulting in a denial of service, or arbitrary code execution. This issue only affected Ubuntu 16.04 ESM and Ubuntu 18.04 ESM. (CVE-2019-14267)
It was discovered that PDFResurrect incorrectly handled memory when loading PDF pages. An attacker could possibly use this issue to cause a heap buffer overflow, resulting in a denial of service, or arbitrary code execution. This issue only affected Ubuntu 16.04 ESM and Ubuntu 18.04 ESM. (CVE-2019-14934)
It was discovered that PDFResurrect was incorrectly validating header data in input PDF files. An attacker could possibly use this issue to cause a heap buffer overflow, resulting in a denial of service, or arbitrary code execution. This issue only affected Ubuntu 16.04 ESM, Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2020-20740)
Carter Yagemann discovered that PDFResurrect incorrectly handled certain memory operations during PDF summary generation. An attacker could use this to cause out-of-bounds writes, resulting in a denial of service (system crash) or arbitrary code execution. This issue only affected Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2020-9549)
It was discovered that PDFResurrect was incorrectly processing data when performing trailer search operations. An attacker could possibly use this issue to cause an infinite loop, resulting in a denial of service. (CVE-2021-3508)
- Record
USN-5282-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pdfresurrectDebian:12 |
before 0.21-1 | 0.21-1 |
pdfresurrectDebian:13 |
before 0.21-1 | 0.21-1 |
pdfresurrectDebian:14 |
before 0.21-1 | 0.21-1 |
pdfresurrectDebian:9 From an advisory covering 2 CVEs |
before 0.12-6+deb9u1, plus listed versions 0.12-6 |
0.12-6+deb9u1 |
pdfresurrectMageia:7 |
before 0.21-1.mga7 | 0.21-1.mga7 |
pdfresurrectUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 0.12-10.12-20.12-40.12-4ubuntu0.1~esm1 |
None known |
pdfresurrectUbuntu:Pro:16.04:LTS |
before 0.12-6ubuntu0.2+esm1, plus listed versions 0.12-50.12-60.12-6ubuntu0.10.12-6ubuntu0.2 |
0.12-6ubuntu0.2+esm1 |
pdfresurrectUbuntu:Pro:18.04:LTS |
before 0.14-1ubuntu0.1~esm1, plus listed versions 0.12-60.14-1 |
0.14-1ubuntu0.1~esm1 |
pdfresurrectUbuntu:Pro:20.04:LTS |
before 0.19-1ubuntu0.1~esm1, plus listed versions 0.18-20.19-1 |
0.19-1ubuntu0.1~esm1 |
pdfresurrectUbuntu:Pro:16.04:LTS From an advisory covering 5 CVEs |
before 0.12-6ubuntu0.2+esm1, plus listed versions 0.12-50.12-60.12-6ubuntu0.10.12-6ubuntu0.2 |
0.12-6ubuntu0.2+esm1 |
pdfresurrectUbuntu:Pro:18.04:LTS From an advisory covering 5 CVEs |
before 0.14-1ubuntu0.1~esm1, plus listed versions 0.12-60.14-1 |
0.14-1ubuntu0.1~esm1 |
pdfresurrectUbuntu:Pro:20.04:LTS From an advisory covering 5 CVEs |
before 0.19-1ubuntu0.1~esm1, plus listed versions 0.18-20.19-1 |
0.19-1ubuntu0.1~esm1 |
pdfresurrectUbuntu:Pro:22.04:LTS From an advisory covering 5 CVEs |
before 0.22-2ubuntu0.1~esm1, plus listed versions 0.22-10.22-2 |
0.22-2ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-20740 is a high vulnerability (CVSS 7.8) in Pdfresurrect Project Pdfresurrect, published November 20, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 67th percentile. Fixed in pdfresurrect 0.21-1.
References
github.com/enferex/pdfresurrect/issues/14
github.com/enferex/pdfresurrect/commit/1b422459f07353adce2878806d5247d9e91fb397
lists.debian.org/debian-lts-announce/2020/12/msg00002.html
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZOIEVFM3SIMAEOFJKKMYH2TLZ7PXLSUD
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JMEEEPBBGER5LPABBRVZLMCC6Z24RBXW
nvd.nist.gov/vuln/detail/CVE-2020-20740
Show 15 moreShow less
lists.fedoraproject.org/archives/list/[email protected]/message/JMEEEPBBGER5LPABBRVZLMCC6Z24RBXW
lists.fedoraproject.org/archives/list/[email protected]/message/ZOIEVFM3SIMAEOFJKKMYH2TLZ7PXLSUD
github.com/advisories/GHSA-x486-4h5g-3687
security-tracker.debian.org/tracker/CVE-2020-20740
advisories.mageia.org/MGASA-2020-0449.html
bugs.mageia.org/show_bug.cgi?id=27704
debian.org/lts/security/2020/dla-2475
lists.fedoraproject.org/archives/list/[email protected]/thread/JMEEEPBBGER5LPABBRVZLMCC6Z24RBXW
ubuntu.com/security/CVE-2020-20740
ubuntu.com/security/notices/USN-5282-1
cve.org/CVERecord?id=CVE-2020-20740
ubuntu.com/security/CVE-2019-14267
ubuntu.com/security/CVE-2019-14934
ubuntu.com/security/CVE-2020-9549
ubuntu.com/security/CVE-2021-3508