Every CVE Search/ Get API key

CVE-2020-2111

Subversion Plugin stored XSS vulnerability

5.4 MediumFix available

Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.92%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.4

Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability.

Record
CVE-2020-2111
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability.

Record
CVE-2020-2111
Updated
2026-11-02
EUVDEUVD-2022-5703 No score

Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability.

Record
EUVD-2022-5703
Updated
2026-11-03
GitHub AdvisoriesGHSA-x3pr-fcgm-wjgc 5.4

Subversion Plugin stored XSS vulnerability

Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability. Subversion Plugin 2.13.1 escapes the affected part of the error message.

Record
GHSA-x3pr-fcgm-wjgc
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability.

Record
CVE-2020-2111
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-x3pr-fcgm-wjgc 5.4

Subversion Plugin stored XSS vulnerability

Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability. Subversion Plugin 2.13.1 escapes the affected part of the error message.

Record
GHSA-x3pr-fcgm-wjgc
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVRHSA-2020:2478 8.8

Red Hat Security Advisory: OpenShift Container Platform 3.11 jenkins-2-plugins security update

Record
RHSA-2020:2478
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2020:2737 8.8

Red Hat Security Advisory: OpenShift Container Platform 4.4.z jenkins-2-plugins security update

Record
RHSA-2020:2737
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2020:3616 8.8

Red Hat Security Advisory: OpenShift Container Platform 4.3.35 jenkins-2-plugins security update

Record
RHSA-2020:3616
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.jenkins-ci.plugins:subversion
Maven
before 2.13.1
2.13.1
org.jenkins-ci.plugins:subversion
Maven
before 2.13.1, plus listed versions
1.241.251.261.281.29
Show 45 moreShow less
1.301.311.321.331.341.351.361.371.381.391.401.411.421.431.441.451.481.501.511.531.542.02.0-alpha-12.0-beta-12.12.102.10.12.10.22.10.32.10.42.10.52.10.62.11.02.11.12.12.02.12.12.12.22.13.02.22.32.42.4.12.4.22.4.32.4.4
2.13.1
jenkins-2-plugins
Red Hat:openshift:3.11::el7
From an advisory covering 8 CVEs
before 0:3.11.1591354111-1.el7
0:3.11.1591354111-1.el7
jenkins-2-plugins
Red Hat:openshift:4.4::el7
From an advisory covering 7 CVEs
before 0:4.4.1592817009-1.el7
0:4.4.1592817009-1.el7
jenkins-2-plugins
Red Hat:openshift:4.3::el7
From an advisory covering 7 CVEs
before 0:4.3.1597915133-1.el7
0:4.3.1597915133-1.el7

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-2111 is a medium vulnerability (CVSS 5.4) in Jenkins Subversion, published February 12, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.92%, the 60th percentile. Fixed in org.jenkins-ci.plugins:subversion 2.13.1.

References

Show 41 moreShow less
This page doesn't list everything

Left out here: 19 versions. The JSON record has them.

MoveEnter Open