CVE-2020-21514
Fluent Fluentd and Fluent-ui use default password
An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated privileges and execute arbitrary code due to a default password.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated privileges and execute arbitrary code due to a default password.
- Record
CVE-2020-21514- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-276
- Updated
- 2026-11-02
CVE List
8.8
An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated privileges and execute arbitrary code due to a default password.
- Record
CVE-2020-21514- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-276
- Updated
- 2026-11-02
EUVDEUVD-2023-1414
8.8
An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated privileges and execute arbitrary code due to a default password.
- Record
EUVD-2023-1414- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-wrxf-x8rm-6ggg
8.8
Fluent Fluentd and Fluent-ui use default password
An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated privileges and execute arbitrary code due to a default password.
- Record
GHSA-wrxf-x8rm-6ggg- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-276
- Updated
- 2026-11-02
OSV
8.8
An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated privileges and execute arbitrary code due to a default password.
- Record
CVE-2020-21514- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-wrxf-x8rm-6ggg
8.8
Fluent Fluentd and Fluent-ui use default password
An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated privileges and execute arbitrary code due to a default password.
- Record
GHSA-wrxf-x8rm-6ggg- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-276
- Updated
- 2026-11-02
OSVBIT-fluentd-2020-21514 No score
An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated privileges and execute arbitrary code due to a default password.
- Record
BIT-fluentd-2020-21514- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fluentd-uiRubyGems |
through 1.2.2 | None known |
fluentdBitnami |
1.8.0 up to 1.8.1 | 1.8.1 |
fluentd-uiRubyGems |
through 1.2.2, plus listed versions 0.1.00.1.10.1.20.1.30.1.4 Show 37 moreShow less0.2.00.3.00.3.10.3.100.3.110.3.120.3.130.3.140.3.150.3.160.3.170.3.180.3.190.3.20.3.200.3.210.3.30.3.50.3.60.3.70.3.80.3.90.4.00.4.10.4.20.4.30.4.40.4.51.0.01.0.0.alpha.11.0.0.alpha.21.0.0.alpha.31.0.0.beta.11.0.11.1.01.2.01.2.1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-21514 is a high vulnerability (CVSS 8.8) in Fluentd, published April 4, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.79%, the 56th percentile. Fixed in fluentd 1.8.1.