CVE-2020-21606
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which...
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which can be exploited via a crafted a file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which can be exploited via a crafted a file.
- Record
CVE-2020-21606- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which can be exploited via a crafted a file.
- Record
CVE-2020-21606- Updated
- 2026-11-02
EUVDEUVD-2020-14374 No score
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which can be exploited via a crafted a file.
- Record
EUVD-2020-14374- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4492-fqfw-jf8g
6.5
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which...
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which can be exploited via a crafted a file.
- Record
GHSA-4492-fqfw-jf8g- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSVALPINE-CVE-2020-21606
6.5
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which can be exploited via a crafted a file.
- Record
ALPINE-CVE-2020-21606- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
6.5
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which can be exploited via a crafted a file.
- Record
CVE-2020-21606- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2020-21606
6.5
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which can be exploited via a crafted a file.
- Record
DEBIAN-CVE-2020-21606- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-21606
6.5
libde265 v1.0.4 contains a heap buffer overflow fault in the put_epel_16_fallback function, which can be exploited via a crafted a file.
- Record
UBUNTU-CVE-2020-21606- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2023-0093 No score
Updated libde265 packages fix security vulnerability
libde265 has been updated to version 1.0.11 to fix many security issues.
- Record
MGASA-2023-0093- Updated
- 2026-11-02
OSVUSN-6617-1 No score
libde265 vulnerabilities
It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2020-21594)
It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2020-21595, CVE-2020-21596, CVE-2020-21599, CVE-2020-21600, CVE-2020-21601, CVE-2020-21602, CVE-2020-21603, CVE-2020-21604, CVE-2020-21605)
It was discovered that libde265 did not properly manage memory. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 20.04 LTS. (CVE-2020-21597, CVE-2020-21598, CVE-2020-21606, CVE-2021-36408)
- Record
USN-6617-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libde265Alpine:v3.14 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.15 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.16 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.17 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.18 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.19 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.20 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.21 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.22 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.23 |
before 1.0.11-r0 | 1.0.11-r0 |
Show 12 moreShow less
| Package | Affected | Fixed |
|---|---|---|
libde265Alpine:v3.24 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Debian:12 |
before 1.0.9-1 | 1.0.9-1 |
libde265Debian:13 |
before 1.0.9-1 | 1.0.9-1 |
libde265Debian:14 |
before 1.0.9-1 | 1.0.9-1 |
libde265Debian:10 From an advisory covering 16 CVEs |
before 1.0.3-1+deb10u1, plus listed versions 1.0.3-1 |
1.0.3-1+deb10u1 |
libde265Debian:11 From an advisory covering 46 CVEs |
before 1.0.11-0+deb11u1, plus listed versions 1.0.8-11.0.8-1.11.0.9-11.0.9-1.1 |
1.0.11-0+deb11u1 |
libde265Mageia:8 From an advisory covering 46 CVEs |
before 1.0.11-1.mga8 | 1.0.11-1.mga8 |
libde265Mageia:8 From an advisory covering 46 CVEs |
before 1.0.11-1.mga8.tainted | 1.0.11-1.mga8.tainted |
libde265Ubuntu:20.04:LTS |
before 1.0.4-1ubuntu0.1, plus listed versions 1.0.3-1build11.0.4-11.0.4-1build1 |
1.0.4-1ubuntu0.1 |
libde265Ubuntu:Pro:16.04:LTS From an advisory covering 14 CVEs |
before 1.0.2-2ubuntu0.16.04.1~esm1, plus listed versions 1.0.2-1build11.0.2-2 |
1.0.2-2ubuntu0.16.04.1~esm1 |
libde265Ubuntu:Pro:18.04:LTS From an advisory covering 14 CVEs |
before 1.0.2-2ubuntu0.18.04.1~esm1, plus listed versions 1.0.2-2build1 |
1.0.2-2ubuntu0.18.04.1~esm1 |
libde265Ubuntu:20.04:LTS From an advisory covering 14 CVEs |
before 1.0.4-1ubuntu0.1, plus listed versions 1.0.3-1build11.0.4-11.0.4-1build1 |
1.0.4-1ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-21606 is a medium vulnerability (CVSS 6.5) in Struktur Libde265, published September 16, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.10%, the 65th percentile. Fixed in libde265 1.0.11-r0.
References
github.com/strukturag/libde265/issues/232
debian.org/security/2023/dsa-5346
nvd.nist.gov/vuln/detail/CVE-2020-21606
github.com/advisories/GHSA-4492-fqfw-jf8g
security.alpinelinux.org/vuln/CVE-2020-21606
security-tracker.debian.org/tracker/CVE-2020-21606
Show 21 moreShow less
advisories.mageia.org/MGASA-2023-0093.html
bugs.mageia.org/show_bug.cgi?id=31289
debian.org/lts/security/2022/dla-3240
debian.org/lts/security/2023/dla-3280
debian.org/lts/security/2023/dla-3352
ubuntu.com/security/CVE-2020-21606
ubuntu.com/security/notices/USN-6617-1
cve.org/CVERecord?id=CVE-2020-21606
ubuntu.com/security/CVE-2020-21594
ubuntu.com/security/CVE-2020-21595
ubuntu.com/security/CVE-2020-21596
ubuntu.com/security/CVE-2020-21597
ubuntu.com/security/CVE-2020-21598
ubuntu.com/security/CVE-2020-21599
ubuntu.com/security/CVE-2020-21600
ubuntu.com/security/CVE-2020-21601
ubuntu.com/security/CVE-2020-21602
ubuntu.com/security/CVE-2020-21603
ubuntu.com/security/CVE-2020-21604
ubuntu.com/security/CVE-2020-21605
ubuntu.com/security/CVE-2021-36408