CVE-2020-21890
Buffer Overflow vulnerability in clj_media_size function in devices/gdevclj.c in Artifex...
Buffer Overflow vulnerability in clj_media_size function in devices/gdevclj.c in Artifex Ghostscript 9.50 allows remote attackers to cause a denial of service or other unspecified impact(s) via opening of crafted PDF document.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Buffer Overflow vulnerability in clj_media_size function in devices/gdevclj.c in Artifex Ghostscript 9.50 allows remote attackers to cause a denial of service or other unspecified impact(s) via opening of crafted PDF document.
- Record
CVE-2020-21890- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
Buffer Overflow vulnerability in clj_media_size function in devices/gdevclj.c in Artifex Ghostscript 9.50 allows remote attackers to cause a denial of service or other unspecified impact(s) via opening of crafted PDF document.
- Record
CVE-2020-21890- Updated
- 2026-11-02
EUVDEUVD-2020-14656 No score
Buffer Overflow vulnerability in clj_media_size function in devices/gdevclj.c in Artifex Ghostscript 9.50 allows remote attackers to cause a denial of service or other unspecified impact(s) via opening of crafted PDF document.
- Record
EUVD-2020-14656- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-44hq-r6f6-m9g4
7.8
Buffer Overflow vulnerability in clj_media_size function in devices/gdevclj.c in Artifex...
Buffer Overflow vulnerability in clj_media_size function in devices/gdevclj.c in Artifex Ghostscript 9.50 allows remote attackers to cause a denial of service or other unspecified impact(s) via opening of crafted PDF document.
- Record
GHSA-44hq-r6f6-m9g4- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
7.8
Buffer Overflow vulnerability in clj_media_size function in devices/gdevclj.c in Artifex Ghostscript 9.50 allows remote attackers to cause a denial of service or other unspecified impact(s) via opening of crafted PDF document.
- Record
CVE-2020-21890- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-21890
7.8
Buffer Overflow vulnerability in clj_media_size function in devices/gdevclj.c in Artifex Ghostscript 9.50 allows remote attackers to cause a denial of service or other unspecified impact(s) via opening of crafted PDF document.
- Record
DEBIAN-CVE-2020-21890- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-21890
7.8
Buffer Overflow vulnerability in clj_media_size function in devices/gdevclj.c in Artifex Ghostscript 9.50 allows remote attackers to cause a denial of service or other unspecified impact(s) via opening of crafted PDF document.
- Record
UBUNTU-CVE-2020-21890- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-6364-1 No score
ghostscript vulnerabilities
It was discovered that Ghostscript incorrectly handled certain PDF files. An attacker could possibly use this issue to cause a denial of service. (CVE-2020-21710)
It was discovered that Ghostscript incorrectly handled certain PDF files. An attacker could possibly use this issue to cause a denial of service, or possibly execute arbitrary code. (CVE-2020-21890)
- Record
USN-6364-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ghostscriptDebian:12 |
before 9.51~dfsg-1 | 9.51~dfsg-1 |
ghostscriptDebian:13 |
before 9.51~dfsg-1 | 9.51~dfsg-1 |
ghostscriptDebian:14 |
before 9.51~dfsg-1 | 9.51~dfsg-1 |
ghostscriptDebian:10 |
before 9.27~dfsg-2+deb10u9, plus listed versions 9.27~dfsg-29.27~dfsg-2+deb10u19.27~dfsg-2+deb10u29.27~dfsg-2+deb10u39.27~dfsg-2+deb10u4 Show 4 moreShow less9.27~dfsg-2+deb10u59.27~dfsg-2+deb10u69.27~dfsg-2+deb10u79.27~dfsg-2+deb10u8 |
9.27~dfsg-2+deb10u9 |
ghostscriptUbuntu:Pro:16.04:LTS |
before 9.26~dfsg+0-0ubuntu0.16.04.14+esm7, plus listed versions 9.16~dfsg~0-0ubuntu39.16~dfsg~0-0ubuntu49.18~dfsg~0-0ubuntu19.18~dfsg~0-0ubuntu29.18~dfsg~0-0ubuntu2.2 Show 28 moreShow less9.18~dfsg~0-0ubuntu2.39.18~dfsg~0-0ubuntu2.49.18~dfsg~0-0ubuntu2.69.18~dfsg~0-0ubuntu2.79.18~dfsg~0-0ubuntu2.89.18~dfsg~0-0ubuntu2.99.25~dfsg+1-0ubuntu0.16.04.19.25~dfsg+1-0ubuntu0.16.04.29.25~dfsg+1-0ubuntu0.16.04.39.26~dfsg+0-0ubuntu0.16.04.19.26~dfsg+0-0ubuntu0.16.04.39.26~dfsg+0-0ubuntu0.16.04.49.26~dfsg+0-0ubuntu0.16.04.59.26~dfsg+0-0ubuntu0.16.04.69.26~dfsg+0-0ubuntu0.16.04.79.26~dfsg+0-0ubuntu0.16.04.89.26~dfsg+0-0ubuntu0.16.04.99.26~dfsg+0-0ubuntu0.16.04.109.26~dfsg+0-0ubuntu0.16.04.119.26~dfsg+0-0ubuntu0.16.04.129.26~dfsg+0-0ubuntu0.16.04.139.26~dfsg+0-0ubuntu0.16.04.149.26~dfsg+0-0ubuntu0.16.04.14+esm19.26~dfsg+0-0ubuntu0.16.04.14+esm29.26~dfsg+0-0ubuntu0.16.04.14+esm39.26~dfsg+0-0ubuntu0.16.04.14+esm49.26~dfsg+0-0ubuntu0.16.04.14+esm59.26~dfsg+0-0ubuntu0.16.04.14+esm6 |
9.26~dfsg+0-0ubuntu0.16.04.14+esm7 |
ghostscriptUbuntu:Pro:18.04:LTS |
before 9.26~dfsg+0-0ubuntu0.18.04.18+esm2, plus listed versions 9.21~dfsg+1-0ubuntu39.22~dfsg+1-0ubuntu19.22~dfsg+1-0ubuntu1.19.22~dfsg+1-0ubuntu1.29.25~dfsg+1-0ubuntu0.18.04.1 Show 19 moreShow less9.25~dfsg+1-0ubuntu0.18.04.29.26~dfsg+0-0ubuntu0.18.04.19.26~dfsg+0-0ubuntu0.18.04.39.26~dfsg+0-0ubuntu0.18.04.49.26~dfsg+0-0ubuntu0.18.04.59.26~dfsg+0-0ubuntu0.18.04.69.26~dfsg+0-0ubuntu0.18.04.79.26~dfsg+0-0ubuntu0.18.04.89.26~dfsg+0-0ubuntu0.18.04.99.26~dfsg+0-0ubuntu0.18.04.109.26~dfsg+0-0ubuntu0.18.04.119.26~dfsg+0-0ubuntu0.18.04.129.26~dfsg+0-0ubuntu0.18.04.139.26~dfsg+0-0ubuntu0.18.04.149.26~dfsg+0-0ubuntu0.18.04.159.26~dfsg+0-0ubuntu0.18.04.169.26~dfsg+0-0ubuntu0.18.04.179.26~dfsg+0-0ubuntu0.18.04.189.26~dfsg+0-0ubuntu0.18.04.18+esm1 |
9.26~dfsg+0-0ubuntu0.18.04.18+esm2 |
ghostscriptUbuntu:20.04:LTS |
before 9.50~dfsg-5ubuntu4.10, plus listed versions 9.27~dfsg+0-0ubuntu39.27~dfsg+0-0ubuntu49.50~dfsg-5ubuntu19.50~dfsg-5ubuntu29.50~dfsg-5ubuntu3 Show 10 moreShow less9.50~dfsg-5ubuntu49.50~dfsg-5ubuntu4.19.50~dfsg-5ubuntu4.29.50~dfsg-5ubuntu4.39.50~dfsg-5ubuntu4.49.50~dfsg-5ubuntu4.59.50~dfsg-5ubuntu4.69.50~dfsg-5ubuntu4.79.50~dfsg-5ubuntu4.89.50~dfsg-5ubuntu4.9 |
9.50~dfsg-5ubuntu4.10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-21890 is a high vulnerability (CVSS 7.8) in Artifex Ghostscript, published August 22, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.81%, the 56th percentile. Fixed in ghostscript 9.51~dfsg-1.
References
bugs.ghostscript.com/show_bug.cgi?id=701846
lists.debian.org/debian-lts-announce/2023/09/msg00029.html
nvd.nist.gov/vuln/detail/CVE-2020-21890
github.com/advisories/GHSA-44hq-r6f6-m9g4
security-tracker.debian.org/tracker/CVE-2020-21890
ubuntu.com/security/CVE-2020-21890
ubuntu.com/security/notices/USN-6364-1
cve.org/CVERecord?id=CVE-2020-21890
ubuntu.com/security/CVE-2020-21710