Every CVE Search/ Get API key

CVE-2020-2228

Improper authorization of users and groups with the same base name in Jenkins GitLab Authentication Plugin

8.8 HighFix available

Jenkins Gitlab Authentication Plugin 1.5 and earlier does not perform group authorization checks properly, resulting in a privilege escalation vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.43%Up 0.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Jenkins Gitlab Authentication Plugin 1.5 and earlier does not perform group authorization checks properly, resulting in a privilege escalation vulnerability.

Record
CVE-2020-2228
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-863
Updated
2026-11-02
CVE List No score

Jenkins Gitlab Authentication Plugin 1.5 and earlier does not perform group authorization checks properly, resulting in a privilege escalation vulnerability.

Record
CVE-2020-2228
Updated
2026-11-02
EUVDEUVD-2022-5014 No score

Jenkins Gitlab Authentication Plugin 1.5 and earlier does not perform group authorization checks properly, resulting in a privilege escalation vulnerability.

Record
EUVD-2022-5014
Updated
2026-11-03
GitHub AdvisoriesGHSA-qq38-mxpq-rrpj 8.1

Improper authorization of users and groups with the same base name in Jenkins GitLab Authentication Plugin

GitLab Authentication Plugin 1.5 and earlier does not differentiate between user names and hierarchical group names when performing authorization. This allows an attacker with permissions to create groups in GitLab to gain the privileges granted to another user or group.

GitLab Authentication Plugin 1.6 performs user name and group name authorization checks using the appropriate GitLab APIs.

Record
GHSA-qq38-mxpq-rrpj
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
OSV 8.8

Jenkins Gitlab Authentication Plugin 1.5 and earlier does not perform group authorization checks properly, resulting in a privilege escalation vulnerability.

Record
CVE-2020-2228
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-qq38-mxpq-rrpj 8.1

Improper authorization of users and groups with the same base name in Jenkins GitLab Authentication Plugin

GitLab Authentication Plugin 1.5 and earlier does not differentiate between user names and hierarchical group names when performing authorization. This allows an attacker with permissions to create groups in GitLab to gain the privileges granted to another user or group.

GitLab Authentication Plugin 1.6 performs user name and group name authorization checks using the appropriate GitLab APIs.

Record
GHSA-qq38-mxpq-rrpj
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.jenkins-ci.plugins:gitlab-oauth
Maven
through 1.5
1.6
org.jenkins-ci.plugins:gitlab-oauth
Maven
before 1.6, plus listed versions
1.0.31.0.41.0.51.0.61.0.7
Show 7 moreShow less
1.0.81.0.91.11.21.31.41.5
1.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-2228 is a high vulnerability (CVSS 8.8) in Jenkins Gitlab Authentication, published July 15, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.43%, the 73rd percentile. Fixed in org.jenkins-ci.plugins:gitlab-oauth 1.6.

References

MoveEnter Open