CVE-2020-22452
phpmyadmin contains SQL Injection vulnerability
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
- Record
CVE-2020-22452- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List
9.8
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
- Record
CVE-2020-22452- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
EUVDEUVD-2023-0523
9.8
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
- Record
EUVD-2023-0523- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-prcg-mc23-hgjh
9.8
phpmyadmin contains SQL Injection vulnerability
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.0.2 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
- Record
GHSA-prcg-mc23-hgjh- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
9.8
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
- Record
CVE-2020-22452- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-22452
9.8
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
- Record
DEBIAN-CVE-2020-22452- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-prcg-mc23-hgjh
9.8
phpmyadmin contains SQL Injection vulnerability
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.0.2 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
- Record
GHSA-prcg-mc23-hgjh- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-22452
9.8
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
- Record
UBUNTU-CVE-2020-22452- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBIT-phpmyadmin-2020-22452 No score
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
- Record
BIT-phpmyadmin-2020-22452- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpmyadmin/phpmyadminPackagist |
5.0.0 up to 5.0.2 | 5.0.2 |
phpmyadminBitnami |
5.0.0 up to 5.2.0 | 5.2.0 |
phpmyadminDebian:12 |
before 4:5.0.4+dfsg1-1 | 4:5.0.4+dfsg1-1 |
phpmyadminDebian:13 |
before 4:5.0.4+dfsg1-1 | 4:5.0.4+dfsg1-1 |
phpmyadminDebian:14 |
before 4:5.0.4+dfsg1-1 | 4:5.0.4+dfsg1-1 |
phpmyadmin/phpmyadminPackagist |
5.0.0 up to 5.0.2, plus listed versions 5.0.0.15.0.1 |
5.0.2 |
phpmyadminUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 4:4.0.6-14:4.0.8-14:4.0.9-14:4.0.10-14:4.0.10-1ubuntu0.1 Show 4 moreShow less4:4.0.10-1ubuntu0.1+esm14:4.0.10-1ubuntu0.1+esm24:4.0.10-1ubuntu0.1+esm34:4.0.10-1ubuntu0.1+esm4 |
None known |
phpmyadminUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 4:4.4.13.1-14:4.5.0.2-24:4.5.1-14:4.5.1-24:4.5.1-3 Show 13 moreShow less4:4.5.2-14:4.5.2-24:4.5.3.1-14:4.5.4-14:4.5.4.1-24:4.5.4.1-2ubuntu14:4.5.4.1-2ubuntu24:4.5.4.1-2ubuntu2.14:4.5.4.1-2ubuntu2.1+esm24:4.5.4.1-2ubuntu2.1+esm34:4.5.4.1-2ubuntu2.1+esm44:4.5.4.1-2ubuntu2.1+esm54:4.5.4.1-2ubuntu2.1+esm6 |
None known |
phpmyadminUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 4:4.6.6-54:4.6.6-5ubuntu0.2+esm14:4.6.6-5ubuntu0.2+esm24:4.6.6-5ubuntu0.54:4.6.6-5ubuntu0.5+esm1 |
None known |
phpmyadminUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 4:4.9.1+dfsg1-24:4.9.2+dfsg1-14:4.9.5+dfsg1-1ubuntu14:4.9.5+dfsg1-24:4.9.5+dfsg1-2ubuntu0.1~esm1 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
phpmyadminUbuntu:22.04:LTS |
All versions, plus listed versions 4:5.0.4+dfsg2-2ubuntu54:5.1.1+dfsg1-5ubuntu1 |
None known |
phpmyadminUbuntu:24.04:LTS |
All versions, plus listed versions 4:5.2.1+dfsg-1ubuntu14:5.2.1+dfsg-2ubuntu14:5.2.1+dfsg-2ubuntu24:5.2.1+dfsg-3 |
None known |
phpmyadminUbuntu:25.10 |
All versions, plus listed versions 4:5.2.2-really5.2.2+20250121+dfsg-14:5.2.2-really+dfsg-14:5.2.2-really+dfsg-2 |
None known |
phpmyadminUbuntu:26.10 |
All versions, plus listed versions 4:5.2.3+dfsg-14:5.2.4~dev~git20260809.e0909b211b+dfsg-1 |
None known |
phpmyadminUbuntu:26.04:LTS |
All versions, plus listed versions 4:5.2.2-really+dfsg-24:5.2.3+dfsg-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-22452 is a critical vulnerability (CVSS 9.8) in Phpmyadmin, published January 26, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.76%, the 78th percentile. Fixed in phpmyadmin/phpmyadmin 5.0.2.
References
github.com/phpmyadmin/phpmyadmin/issues/15898
github.com/phpmyadmin/phpmyadmin/pull/16004
github.com/phpmyadmin/phpmyadmin/blob/master/ChangeLog
nvd.nist.gov/vuln/detail/CVE-2020-22452
github.com/phpmyadmin/phpmyadmin/commit/bc982466f08ddccad4804ba928f84ff8e25107cb
github.com/advisories/GHSA-prcg-mc23-hgjh