CVE-2020-2280
CSRF vulnerability in Jenkins warnings Plugin allows remote code execution
A cross-site request forgery (CSRF) vulnerability in Jenkins Warnings Plugin 5.0.1 and earlier allows attackers to execute arbitrary code.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
A cross-site request forgery (CSRF) vulnerability in Jenkins Warnings Plugin 5.0.1 and earlier allows attackers to execute arbitrary code.
- Record
CVE-2020-2280- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
A cross-site request forgery (CSRF) vulnerability in Jenkins Warnings Plugin 5.0.1 and earlier allows attackers to execute arbitrary code.
- Record
CVE-2020-2280- Updated
- 2026-11-02
EUVDEUVD-2022-4890 No score
A cross-site request forgery (CSRF) vulnerability in Jenkins Warnings Plugin 5.0.1 and earlier allows attackers to execute arbitrary code.
- Record
EUVD-2022-4890- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q564-vvx8-9388
8.8
CSRF vulnerability in Jenkins warnings Plugin allows remote code execution
warnings Plugin 5.0.1 and earlier does not require POST requests for a form validation method intended for testing custom warnings parsers, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to execute arbitrary code.
warnings Plugin 5.0.2 requires POST requests for the affected form validation method.
This vulnerability was caused by an incomplete fix to SECURITY-1295.
- Record
GHSA-q564-vvx8-9388- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV
8.8
A cross-site request forgery (CSRF) vulnerability in Jenkins Warnings Plugin 5.0.1 and earlier allows attackers to execute arbitrary code.
- Record
CVE-2020-2280- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-q564-vvx8-9388
8.8
CSRF vulnerability in Jenkins warnings Plugin allows remote code execution
warnings Plugin 5.0.1 and earlier does not require POST requests for a form validation method intended for testing custom warnings parsers, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to execute arbitrary code.
warnings Plugin 5.0.2 requires POST requests for the affected form validation method.
This vulnerability was caused by an incomplete fix to SECURITY-1295.
- Record
GHSA-q564-vvx8-9388- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jvnet.hudson.plugins:warningsMaven |
through 5.0.1 | 5.0.2 |
org.jvnet.hudson.plugins:warningsMaven |
before 5.0.2, plus listed versions 1.01.11.101.111.12 Show 45 moreShow less1.131.141.151.161.171.181.191.21.201.211.221.231.241.251.261.271.281.291.31.41.51.61.71.81.92.02.12.102.112.122.132.142.22.32.42.52.62.72.82.93.03.13.103.113.12 |
5.0.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-2280 is a high vulnerability (CVSS 8.8) in Jenkins Warnings, published September 23, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in org.jvnet.hudson.plugins:warnings 5.0.2.
References
Left out here: 92 versions. The JSON record has them.