CVE-2020-24020
Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in libavfilter/dnn...
Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in libavfilter/dnn/dnn_backend_native_layer_pad.c due to a call to memcpy without length checks, which could let a remote malicious user execute arbitrary code.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in libavfilter/dnn/dnn_backend_native_layer_pad.c due to a call to memcpy without length checks, which could let a remote malicious user execute arbitrary code.
- Record
CVE-2020-24020- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List No score
Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in libavfilter/dnn/dnn_backend_native_layer_pad.c due to a call to memcpy without length checks, which could let a remote malicious user execute arbitrary code.
- Record
CVE-2020-24020- Updated
- 2026-11-02
EUVDEUVD-2020-16757 No score
Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in libavfilter/dnn/dnn_backend_native_layer_pad.c due to a call to memcpy without length checks, which could let a remote malicious user execute arbitrary code.
- Record
EUVD-2020-16757- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gxpf-25mm-vm27 No score
Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in libavfilter/dnn...
Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in libavfilter/dnn/dnn_backend_native_layer_pad.c due to a call to memcpy without length checks, which could let a remote malicious user execute arbitrary code.
- Record
GHSA-gxpf-25mm-vm27- Weakness
- CWE-120
- Updated
- 2026-11-02
OSVALPINE-CVE-2020-24020
8.8
Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in libavfilter/dnn/dnn_backend_native_layer_pad.c due to a call to memcpy without length checks, which could let a remote malicious user execute arbitrary code.
- Record
ALPINE-CVE-2020-24020- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSV
8.8
Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in libavfilter/dnn/dnn_backend_native_layer_pad.c due to a call to memcpy without length checks, which could let a remote malicious user execute arbitrary code.
- Record
CVE-2020-24020- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-07
OSVDEBIAN-CVE-2020-24020
8.8
Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in libavfilter/dnn/dnn_backend_native_layer_pad.c due to a call to memcpy without length checks, which could let a remote malicious user execute arbitrary code.
- Record
DEBIAN-CVE-2020-24020- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ffmpegAlpine:v3.14 |
before 4.4-r0 | 4.4-r0 |
ffmpegAlpine:v3.15 |
before 4.4-r0 | 4.4-r0 |
ffmpegAlpine:v3.16 |
before 4.4-r0 | 4.4-r0 |
ffmpegAlpine:v3.17 |
before 4.4-r0 | 4.4-r0 |
ffmpegAlpine:v3.18 |
before 4.4-r0 | 4.4-r0 |
ffmpegAlpine:v3.19 |
before 4.4-r0 | 4.4-r0 |
ffmpegAlpine:v3.20 |
before 4.4-r0 | 4.4-r0 |
ffmpegAlpine:v3.21 |
before 4.4-r0 | 4.4-r0 |
ffmpegAlpine:v3.22 |
before 4.4-r0 | 4.4-r0 |
ffmpegAlpine:v3.23 |
before 4.4-r0 | 4.4-r0 |
Show 11 moreShow less
| Package | Affected | Fixed |
|---|---|---|
ffmpegAlpine:v3.24 |
before 4.4-r0 | 4.4-r0 |
ffmpeg4Alpine:v3.16 |
before 4.4-r0 | 4.4-r0 |
ffmpeg4Alpine:v3.17 |
before 4.4-r0 | 4.4-r0 |
ffmpeg4Alpine:v3.18 |
before 4.4-r0 | 4.4-r0 |
ffmpeg4Alpine:v3.19 |
before 4.4-r0 | 4.4-r0 |
ffmpeg4Alpine:v3.20 |
before 4.4-r0 | 4.4-r0 |
ffmpeg4Alpine:v3.21 |
before 4.4-r0 | 4.4-r0 |
ffmpeg4Alpine:v3.22 |
before 4.4-r0 | 4.4-r0 |
ffmpegDebian:12 |
before 7:4.3.1-1 | 7:4.3.1-1 |
ffmpegDebian:13 |
before 7:4.3.1-1 | 7:4.3.1-1 |
ffmpegDebian:14 |
before 7:4.3.1-1 | 7:4.3.1-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| affected, aliases, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-24020 is a high vulnerability (CVSS 8.8) in Ffmpeg, published May 26, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.55%, the 75th percentile. Fixed in ffmpeg 4.4-r0.
References
trac.ffmpeg.org/ticket/8718
git.videolan.org?p=ffmpeg.git%3Ba=commitdiff%3Bh=584f396132aa19d21bb1e38ad9a5d428869290cb
nvd.nist.gov/vuln/detail/CVE-2020-24020
git.videolan.org?p=ffmpeg.git;a=commitdiff;h=584f396132aa19d21bb1e38ad9a5d428869290cb
github.com/advisories/GHSA-gxpf-25mm-vm27
security.alpinelinux.org/vuln/CVE-2020-24020
security-tracker.debian.org/tracker/CVE-2020-24020