Every CVE Search/ Get API key

CVE-2020-24342

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection...

7.8 HighFix available

CVE-2020-24342 is a high vulnerability (CVSS 7.8) in Lua, published August 13, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in lua 5.4.1.

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection mechanism wrongly calls luaD_callnoyield twice in a row.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.08%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection mechanism wrongly calls luaD_callnoyield twice in a row.

Record
CVE-2020-24342
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection mechanism wrongly calls luaD_callnoyield twice in a row.

Record
CVE-2020-24342
Updated
2026-11-02
EUVDEUVD-2020-17076 No score

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection mechanism wrongly calls luaD_callnoyield twice in a row.

Record
EUVD-2020-17076
Updated
2026-11-03
GitHub AdvisoriesGHSA-ggfm-9pxx-qx8r No score

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection...

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection mechanism wrongly calls luaD_callnoyield twice in a row.

Record
GHSA-ggfm-9pxx-qx8r
Weakness
CWE-119
Updated
2026-11-02
OSVBELL-CVE-2020-24342 7.8

CVE-2020-24342 does not affect BellSoft software

Record
BELL-CVE-2020-24342
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 7.8

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection mechanism wrongly calls luaD_callnoyield twice in a row.

Record
CVE-2020-24342
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2020-24342 7.8

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection mechanism wrongly calls luaD_callnoyield twice in a row.

Record
DEBIAN-CVE-2020-24342
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-lua-2020-24342 No score

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection mechanism wrongly calls luaD_callnoyield twice in a row.

Record
BIT-lua-2020-24342
Updated
2026-11-02
OSVopenSUSE-SU-2024:11029-1 No score

liblua5_4-5-32bit-5.4.3-4.2 on GA media

These are all security issues fixed in the liblua5_4-5-32bit-5.4.3-4.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11029-1
Updated
2026-11-02
OSVopenSUSE-SU-2025:15401-1 No score

liblua5_5-5-5.5.0~beta1-1.1 on GA media

These are all security issues fixed in the liblua5_5-5-5.5.0~beta1-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15401-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lua
Bitnami
5.4.0 up to 5.4.1
5.4.1
lua5.4
Debian:12
before 5.4.1-1
5.4.1-1
lua5.4
Debian:13
before 5.4.1-1
5.4.1-1
lua5.4
Debian:14
before 5.4.1-1
5.4.1-1
lua55
openSUSE:Tumbleweed
before 5.5.0~beta1-1.1
5.5.0~beta1-1.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 11 moreShow less
MoveEnter Open