CVE-2020-24379
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
- Record
CVE-2020-24379- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-611
- Updated
- 2026-11-02
CVE List No score
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
- Record
CVE-2020-24379- Updated
- 2026-11-02
EUVDEUVD-2020-17111 No score
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
- Record
EUVD-2020-17111- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xq76-5h8q-6j3h
9.8
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
- Record
GHSA-xq76-5h8q-6j3h- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-611
- Updated
- 2026-11-02
OSV
9.8
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
- Record
CVE-2020-24379- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-24379
9.8
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
- Record
DEBIAN-CVE-2020-24379- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-24379
9.8
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
- Record
UBUNTU-CVE-2020-24379- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-04
OSVUSN-4569-1 No score
yaws vulnerabilities
It was discovered that Yaws did not properly sanitize XML input. A remote attacker could use this vulnerability to execute an XML External Entity (XXE) injection attack. (CVE-2020-24379)
It was discovered that Yaws mishandled certain input when running CGI scripts. A remote attacker could use this vulnerability to execute arbitrary commands. (CVE-2020-24916)
- Record
USN-4569-1- Updated
- 2026-11-02
OSVUSN-8995-1 No score
yaws vulnerabilities
It was discovered that Yaws did not properly sanitize XML input in its WebDAV implementation. A remote attacker could possibly use this issue to perform XML external entity injection attacks. (CVE-2020-24379)
It was discovered that Yaws mishandled certain input when running CGI scripts. A remote attacker could possibly use this issue to execute arbitrary commands. (CVE-2020-24916)
- Record
USN-8995-1- Updated
- 2026-11-04
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
yawsDebian:12 |
before 2.0.8+dfsg-1 | 2.0.8+dfsg-1 |
yawsDebian:13 |
before 2.0.8+dfsg-1 | 2.0.8+dfsg-1 |
yawsDebian:14 |
before 2.0.8+dfsg-1 | 2.0.8+dfsg-1 |
yawsDebian:9 From an advisory covering 2 CVEs |
before 2.0.4+dfsg-1+deb9u1, plus listed versions 2.0.4+dfsg-1 |
2.0.4+dfsg-1+deb9u1 |
yawsDebian:10 From an advisory covering 2 CVEs |
before 2.0.6+dfsg-1+deb10u1, plus listed versions 2.0.6+dfsg-1 |
2.0.6+dfsg-1+deb10u1 |
yawsUbuntu:Pro:16.04:LTS |
before 2.0.2-1ubuntu0.1~esm1, plus listed versions 1.98-51.99-11.99-22.0.2-1 |
2.0.2-1ubuntu0.1~esm1 |
yawsUbuntu:18.04:LTS |
before 2.0.4+dfsg-2ubuntu0.1, plus listed versions 2.0.4+dfsg-2 |
2.0.4+dfsg-2ubuntu0.1 |
yawsUbuntu:Pro:20.04:LTS |
before 2.0.7+dfsg-1ubuntu0.1~esm1, plus listed versions 2.0.6+dfsg-12.0.6+dfsg-32.0.7+dfsg-1 |
2.0.7+dfsg-1ubuntu0.1~esm1 |
yawsUbuntu:18.04:LTS From an advisory covering 2 CVEs |
before 2.0.4+dfsg-2ubuntu0.1, plus listed versions 2.0.4+dfsg-2 |
2.0.4+dfsg-2ubuntu0.1 |
yawsUbuntu:Pro:16.04:LTS From an advisory covering 2 CVEs |
before 2.0.2-1ubuntu0.1~esm1, plus listed versions 1.98-51.99-11.99-22.0.2-1 |
2.0.2-1ubuntu0.1~esm1 |
yawsUbuntu:Pro:20.04:LTS From an advisory covering 2 CVEs |
before 2.0.7+dfsg-1ubuntu0.1~esm1, plus listed versions 2.0.6+dfsg-12.0.6+dfsg-32.0.7+dfsg-1 |
2.0.7+dfsg-1ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| affected, aliases, references | OSV | |
| affected, facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-24379 is a critical vulnerability (CVSS 9.8) in Yaws, published September 9, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.35%, the 88th percentile. Fixed in yaws 2.0.8+dfsg-1.
References
github.com/erlyaws/yaws/commits/master
packetstormsecurity.com/files/159106/Yaws-2.0.7-XML-Injection-Command-Injection.html
vuln.be/post/yaws-xxe-and-shell-injections
github.com/vulnbe/poc-yaws-dav-xxe
lists.debian.org/debian-lts-announce/2020/09/msg00022.html
usn.ubuntu.com/4569-1
Show 10 moreShow less
debian.org/security/2020/dsa-4773
nvd.nist.gov/vuln/detail/CVE-2020-24379
github.com/advisories/GHSA-xq76-5h8q-6j3h
security-tracker.debian.org/tracker/CVE-2020-24379
ubuntu.com/security/CVE-2020-24379
github.com/erlyaws/yaws/commit/05a06345012598f5da55dbb4d041c8dc26e88e6c
ubuntu.com/security/notices/USN-4569-1
cve.org/CVERecord?id=CVE-2020-24379
ubuntu.com/security/notices/USN-8995-1
ubuntu.com/security/CVE-2020-24916