Every CVE Search/ Get API key

CVE-2020-24661

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP...

5.9 MediumFix available

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP services using invalid TLS certificates (e.g., self-signed certificates) when the client system is not configured to use a system-provided PKCS#11 store. This allows a meddler in the middle to present a different invalid certificate to intercept incoming and outgoing mail.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.92%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.9

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP services using invalid TLS certificates (e.g., self-signed certificates) when the client system is not configured to use a system-provided PKCS#11 store. This allows a meddler in the middle to present a different invalid certificate to intercept incoming and outgoing mail.

Record
CVE-2020-24661
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:P/I:N/A:N
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP services using invalid TLS certificates (e.g., self-signed certificates) when the client system is not configured to use a system-provided PKCS#11 store. This allows a meddler in the middle to present a different invalid certificate to intercept incoming and outgoing mail.

Record
CVE-2020-24661
Updated
2026-11-02
EUVDEUVD-2020-17375 No score

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP services using invalid TLS certificates (e.g., self-signed certificates) when the client system is not configured to use a system-provided PKCS#11 store. This allows a meddler in the middle to present a different invalid certificate to intercept incoming and outgoing mail.

Record
EUVD-2020-17375
Updated
2026-11-03
GitHub AdvisoriesGHSA-9q4r-jrvx-7p2q 5.9

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP...

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP services using invalid TLS certificates (e.g., self-signed certificates) when the client system is not configured to use a system-provided PKCS#11 store. This allows a meddler in the middle to present a different invalid certificate to intercept incoming and outgoing mail.

Record
GHSA-9q4r-jrvx-7p2q
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-295
Updated
2026-11-02
OSVALPINE-CVE-2020-24661 5.9

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP services using invalid TLS certificates (e.g., self-signed certificates) when the client system is not configured to use a system-provided PKCS#11 store. This allows a meddler in the middle to present a different invalid certificate to intercept incoming and outgoing mail.

Record
ALPINE-CVE-2020-24661
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-03
OSV 5.9

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP services using invalid TLS certificates (e.g., self-signed certificates) when the client system is not configured to use a system-provided PKCS#11 store. This allows a meddler in the middle to present a different invalid certificate to intercept incoming and outgoing mail.

Record
CVE-2020-24661
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2020-24661 5.9

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP services using invalid TLS certificates (e.g., self-signed certificates) when the client system is not configured to use a system-provided PKCS#11 store. This allows a meddler in the middle to present a different invalid certificate to intercept incoming and outgoing mail.

Record
DEBIAN-CVE-2020-24661
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2020-24661 5.9

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP services using invalid TLS certificates (e.g., self-signed certificates) when the client system is not configured to use a system-provided PKCS#11 store. This allows a meddler in the middle to present a different invalid certificate to intercept incoming and outgoing mail.

Record
UBUNTU-CVE-2020-24661
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVMGASA-2020-0390 No score

Updated geary package fixes a security vulnerability

GNOME Geary before 3.36.3 mishandles pinned TLS certificate verification for IMAP and SMTP services using invalid TLS certificates (e.g., self-signed certificates) when the client system is not configured to use a system-provided PKCS#11 store. This allows a meddler in the middle to present a different invalid certificate to intercept incoming and outgoing mail. (CVE-2020-24661)

Record
MGASA-2020-0390
Updated
2026-11-02
OSVopenSUSE-SU-2024:10781-1 No score

geary-40.0-1.4 on GA media

These are all security issues fixed in the geary-40.0-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10781-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
geary
Alpine:v3.12
before 3.36.2-r1
3.36.2-r1
geary
Alpine:v3.13
before 3.37.91-r0
3.37.91-r0
geary
Alpine:v3.14
before 3.37.91-r0
3.37.91-r0
geary
Alpine:v3.15
before 3.37.91-r0
3.37.91-r0
geary
Alpine:v3.16
before 3.37.91-r0
3.37.91-r0
geary
Alpine:v3.17
before 3.37.91-r0
3.37.91-r0
geary
Alpine:v3.18
before 3.37.91-r0
3.37.91-r0
geary
Alpine:v3.19
before 3.37.91-r0
3.37.91-r0
geary
Alpine:v3.20
before 3.37.91-r0
3.37.91-r0
geary
Alpine:v3.21
before 3.37.91-r0
3.37.91-r0
Show 11 moreShow less
Affected packages
PackageAffectedFixed
geary
Alpine:v3.22
before 3.37.91-r0
3.37.91-r0
geary
Alpine:v3.23
before 3.37.91-r0
3.37.91-r0
geary
Alpine:v3.24
before 3.37.91-r0
3.37.91-r0
geary
Debian:12
before 3.38.0.1-1
3.38.0.1-1
geary
Debian:13
before 3.38.0.1-1
3.38.0.1-1
geary
Debian:14
before 3.38.0.1-1
3.38.0.1-1
geary
Mageia:7
before 3.32.1-1.1.mga7
3.32.1-1.1.mga7
geary
Ubuntu:16.04:LTS
All versions, plus listed versions
0.10.0-1ubuntu1
None known
geary
Ubuntu:18.04:LTS
All versions, plus listed versions
0.12.0-0ubuntu10.12.0-1ubuntu10.12.4-4~ubuntu18.04.3
None known
geary
Ubuntu:20.04:LTS
All versions, plus listed versions
3.32.0-1ubuntu13.34.1-43.34.2-13.36.0-23.36.1-1
None known
geary
openSUSE:Tumbleweed
before 40.0-1.4
40.0-1.4

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-24661 is a medium vulnerability (CVSS 5.9) in Gnome Geary, published August 26, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.92%, the 60th percentile. Fixed in geary 3.36.2-r1.

References

Show 11 moreShow less
MoveEnter Open