Every CVE Search/ Get API key

CVE-2020-24741

An issue has been fixed in Qt versions 5.14.1 and 5.12.7 where QLibrary attempts to load plugins...

7.8 HighFix availableRejected

DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2020-0570. Reason: This candidate is a duplicate of CVE-2020-0570. A typo caused the wrong ID to be used. Notes: All CVE users should reference CVE-2020-0570 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

What each source reports

OSV Score usedUBUNTU-CVE-2020-24741 7.8

** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2020-0570. Reason: This candidate is a duplicate of CVE-2020-0570. A typo caused the wrong ID to be used. Notes: All CVE users should reference CVE-2020-0570 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage.

Record
UBUNTU-CVE-2020-24741
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
CVE List No score

DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2020-0570. Reason: This candidate is a duplicate of CVE-2020-0570. A typo caused the wrong ID to be used. Notes: All CVE users should reference CVE-2020-0570 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

Record
CVE-2020-24741
Updated
2026-11-02
EUVDEUVD-2020-17452 No score

DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2020-0570. Reason: This candidate is a duplicate of CVE-2020-0570. A typo caused the wrong ID to be used. Notes: All CVE users should reference CVE-2020-0570 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

Record
EUVD-2020-17452
Updated
2026-11-03
GitHub AdvisoriesGHSA-j6vg-fh5g-5g73 No score

An issue has been fixed in Qt versions 5.14.1 and 5.12.7 where QLibrary attempts to load plugins...

An issue has been fixed in Qt versions 5.14.1 and 5.12.7 where QLibrary attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.

Record
GHSA-j6vg-fh5g-5g73
Updated
2026-11-02
NVD No score

Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2020-0570. Reason: This candidate is a duplicate of CVE-2020-0570. A typo caused the wrong ID to be used. Notes: All CVE users should reference CVE-2020-0570 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

Record
CVE-2020-24741
Updated
2026-11-02
OSVMGASA-2021-0510 No score

Updated qt4 packages fix security vulnerability

CVE-2020-24741, Do not attempt to load a library relative to $PWD

Record
MGASA-2021-0510
Updated
2026-11-02
OSVSUSE-SU-2021:3268-1 No score

Security update for libqt5-qtbase

This update for libqt5-qtbase fixes the following issues:

  • CVE-2020-24741: Fixed a bug that allowed QLibrary to load libraries relative to CWD which could result in arbitrary code execution. (bsc#1189408)
Record
SUSE-SU-2021:3268-1
Updated
2026-11-02
OSVSUSE-SU-2021:3269-1 No score

Security update for libqt5-qtbase

This update for libqt5-qtbase fixes the following issues:

  • CVE-2020-24741: Fixed a bug that allowed QLibrary to load libraries relative to CWD which could result in arbitrary code execution. (bsc#1189408)
Record
SUSE-SU-2021:3269-1
Updated
2026-11-02
OSVSUSE-SU-2023:2816-1 No score

Security update for libqt5-qtbase

This update for libqt5-qtbase fixes the following issues:

  • CVE-2020-24741: Fixed a bug that allow QLibrary to load libraries relative to CWD which could result in arbitrary code execution (bsc#1189408).
  • CVE-2023-32763: Fixed buffer overflow in QTextLayout (bsc#1211798).
Record
SUSE-SU-2023:2816-1
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
qt4
Mageia:8
before 4.8.7-35.2.mga8
4.8.7-35.2.mga8
libqt5-qtbase
SUSE:Linux Enterprise Server 12 SP2-BCL
before 5.6.1-17.21.3
5.6.1-17.21.3
libqt5-qtbase
SUSE:Linux Enterprise High Performance Computing 15-ESPOS
before 5.9.4-8.29.1
5.9.4-8.29.1
libqt5-qtbase
SUSE:Linux Enterprise High Performance Computing 15-LTSS
before 5.9.4-8.29.1
5.9.4-8.29.1
libqt5-qtbase
SUSE:Linux Enterprise Server 15-LTSS
before 5.9.4-8.29.1
5.9.4-8.29.1
libqt5-qtbase
SUSE:Linux Enterprise Server for SAP Applications 15
before 5.9.4-8.29.1
5.9.4-8.29.1
libqt5-qtbase
SUSE:OpenStack Cloud 9
From an advisory covering 2 CVEs
before 5.6.2-6.33.1
5.6.2-6.33.1
libqt5-qtbase
SUSE:OpenStack Cloud Crowbar 9
From an advisory covering 2 CVEs
before 5.6.2-6.33.1
5.6.2-6.33.1
libqt5-qtbase
SUSE:Linux Enterprise Server for SAP Applications 12 SP4
From an advisory covering 2 CVEs
before 5.6.2-6.33.1
5.6.2-6.33.1
libqt5-qtbase
SUSE:Linux Enterprise Software Development Kit 12 SP5
From an advisory covering 2 CVEs
before 5.6.2-6.33.1
5.6.2-6.33.1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
libqt5-qtbase
SUSE:Linux Enterprise Server 12 SP4-ESPOS
From an advisory covering 2 CVEs
before 5.6.2-6.33.1
5.6.2-6.33.1
libqt5-qtbase
SUSE:Linux Enterprise Server 12 SP4-LTSS
From an advisory covering 2 CVEs
before 5.6.2-6.33.1
5.6.2-6.33.1
libqt5-qtbase
SUSE:Linux Enterprise Server 12 SP5
From an advisory covering 2 CVEs
before 5.6.2-6.33.1
5.6.2-6.33.1
libqt5-qtbase
SUSE:Linux Enterprise Server for SAP Applications 12 SP5
From an advisory covering 2 CVEs
before 5.6.2-6.33.1
5.6.2-6.33.1

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-24741 has been rejected by its source and should not be treated as a live vulnerability, published August 9, 2021. Fixed in qt4 4.8.7-35.2.mga8.

References

Show 10 moreShow less
MoveEnter Open