CVE-2020-24899
Nagios XI 5.7.2 is affected by a remote code execution (RCE) vulnerability. An authenticated user...
Nagios XI 5.7.2 is affected by a remote code execution (RCE) vulnerability. An authenticated user can inject additional commands into normal webapp query.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Nagios XI 5.7.2 is affected by a remote code execution (RCE) vulnerability. An authenticated user can inject additional commands into normal webapp query.
- Record
CVE-2020-24899- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List No score
Nagios XI 5.7.2 is affected by a remote code execution (RCE) vulnerability. An authenticated user can inject additional commands into normal webapp query.
- Record
CVE-2020-24899- Updated
- 2026-11-02
EUVDEUVD-2020-17607 No score
Nagios XI 5.7.2 is affected by a remote code execution (RCE) vulnerability. An authenticated user can inject additional commands into normal webapp query.
- Record
EUVD-2020-17607- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q392-xrmp-p8f6 No score
Nagios XI 5.7.2 is affected by a remote code execution (RCE) vulnerability. An authenticated user...
Nagios XI 5.7.2 is affected by a remote code execution (RCE) vulnerability. An authenticated user can inject additional commands into normal webapp query.
- Record
GHSA-q392-xrmp-p8f6- Weakness
- CWE-77
- Updated
- 2026-11-02
OSVALPINE-CVE-2020-24899
8.8
Nagios XI 5.7.2 is affected by a remote code execution (RCE) vulnerability. An authenticated user can inject additional commands into normal webapp query.
- Record
ALPINE-CVE-2020-24899- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
librawAlpine:v3.13 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.14 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.15 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.16 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.17 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.18 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.19 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.20 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.21 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.22 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.23 |
before 0.20.0-r0 | 0.20.0-r0 |
librawAlpine:v3.24 |
before 0.20.0-r0 | 0.20.0-r0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, facts, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-24899 is a high vulnerability (CVSS 8.8) in Nagios Xi, published February 15, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 16.6%, the 97th percentile. Fixed in libraw 0.20.0-r0.