Every CVE Search/ Get API key

CVE-2020-24916

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

9.8 CriticalFix available

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

17.4%Up 15.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

Record
CVE-2020-24916
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-78
Updated
2026-11-02
CVE List No score

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

Record
CVE-2020-24916
Updated
2026-11-02
EUVDEUVD-2020-17621 No score

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

Record
EUVD-2020-17621
Updated
2026-11-03
GitHub AdvisoriesGHSA-962f-382j-8f7x 9.8

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

Record
GHSA-962f-382j-8f7x
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
OSV 9.8

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

Record
CVE-2020-24916
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-24916 9.8

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

Record
DEBIAN-CVE-2020-24916
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-24916 9.8

CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.

Record
UBUNTU-CVE-2020-24916
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-04
OSVUSN-4569-1 No score

yaws vulnerabilities

It was discovered that Yaws did not properly sanitize XML input. A remote attacker could use this vulnerability to execute an XML External Entity (XXE) injection attack. (CVE-2020-24379)

It was discovered that Yaws mishandled certain input when running CGI scripts. A remote attacker could use this vulnerability to execute arbitrary commands. (CVE-2020-24916)

Record
USN-4569-1
Updated
2026-11-02
OSVUSN-8995-1 No score

yaws vulnerabilities

It was discovered that Yaws did not properly sanitize XML input in its WebDAV implementation. A remote attacker could possibly use this issue to perform XML external entity injection attacks. (CVE-2020-24379)

It was discovered that Yaws mishandled certain input when running CGI scripts. A remote attacker could possibly use this issue to execute arbitrary commands. (CVE-2020-24916)

Record
USN-8995-1
Updated
2026-11-04

Affected products

Affected packages

Affected packages
PackageAffectedFixed
yaws
Debian:12
before 2.0.8+dfsg-1
2.0.8+dfsg-1
yaws
Debian:13
before 2.0.8+dfsg-1
2.0.8+dfsg-1
yaws
Debian:14
before 2.0.8+dfsg-1
2.0.8+dfsg-1
yaws
Debian:9
From an advisory covering 2 CVEs
before 2.0.4+dfsg-1+deb9u1, plus listed versions
2.0.4+dfsg-1
2.0.4+dfsg-1+deb9u1
yaws
Debian:10
From an advisory covering 2 CVEs
before 2.0.6+dfsg-1+deb10u1, plus listed versions
2.0.6+dfsg-1
2.0.6+dfsg-1+deb10u1
yaws
Ubuntu:Pro:16.04:LTS
before 2.0.2-1ubuntu0.1~esm1, plus listed versions
1.98-51.99-11.99-22.0.2-1
2.0.2-1ubuntu0.1~esm1
yaws
Ubuntu:18.04:LTS
before 2.0.4+dfsg-2ubuntu0.1, plus listed versions
2.0.4+dfsg-2
2.0.4+dfsg-2ubuntu0.1
yaws
Ubuntu:Pro:20.04:LTS
before 2.0.7+dfsg-1ubuntu0.1~esm1, plus listed versions
2.0.6+dfsg-12.0.6+dfsg-32.0.7+dfsg-1
2.0.7+dfsg-1ubuntu0.1~esm1
yaws
Ubuntu:18.04:LTS
From an advisory covering 2 CVEs
before 2.0.4+dfsg-2ubuntu0.1, plus listed versions
2.0.4+dfsg-2
2.0.4+dfsg-2ubuntu0.1
yaws
Ubuntu:Pro:16.04:LTS
From an advisory covering 2 CVEs
before 2.0.2-1ubuntu0.1~esm1, plus listed versions
1.98-51.99-11.99-22.0.2-1
2.0.2-1ubuntu0.1~esm1
yaws
Ubuntu:Pro:20.04:LTS
From an advisory covering 2 CVEs
before 2.0.7+dfsg-1ubuntu0.1~esm1, plus listed versions
2.0.6+dfsg-12.0.6+dfsg-32.0.7+dfsg-1
2.0.7+dfsg-1ubuntu0.1~esm1

History

History
RecordedChangedSources
affected
affected, aliases, referencesOSV
affected, factsOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-24916 is a critical vulnerability (CVSS 9.8) in Yaws, published September 9, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 17.4%, the 97th percentile. Fixed in yaws 2.0.8+dfsg-1.

References

Show 10 moreShow less
MoveEnter Open