Every CVE Search/ Get API key

CVE-2020-25125

GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or...

7.8 HighFix available

GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or possibly unspecified other impact, when a victim imports an attacker's OpenPGP key, and this key has AEAD preferences. The overflow is caused by a g10/key-check.c error. NOTE: GnuPG 2.3.x is unaffected. GnuPG 2.2.23 is a fixed version.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.28%Down 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or possibly unspecified other impact, when a victim imports an attacker's OpenPGP key, and this key has AEAD preferences. The overflow is caused by a g10/key-check.c error. NOTE: GnuPG 2.3.x is unaffected. GnuPG 2.2.23 is a fixed version.

Record
CVE-2020-25125
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or possibly unspecified other impact, when a victim imports an attacker's OpenPGP key, and this key has AEAD preferences. The overflow is caused by a g10/key-check.c error. NOTE: GnuPG 2.3.x is unaffected. GnuPG 2.2.23 is a fixed version.

Record
CVE-2020-25125
Updated
2026-11-02
EUVDEUVD-2020-17816 No score

GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or possibly unspecified other impact, when a victim imports an attacker's OpenPGP key, and this key has AEAD preferences. The overflow is caused by a g10/key-check.c error. NOTE: GnuPG 2.3.x is unaffected. GnuPG 2.2.23 is a fixed version.

Record
EUVD-2020-17816
Updated
2026-11-03
GitHub AdvisoriesGHSA-g8h3-hp92-c5qx No score

GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or...

GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or possibly unspecified other impact, when a victim imports an attacker's OpenPGP key, and this key has AEAD preferences. The overflow is caused by a g10/key-check.c error. NOTE: GnuPG 2.3.x is unaffected. GnuPG 2.2.23 is a fixed version.

Record
GHSA-g8h3-hp92-c5qx
Updated
2026-11-02
OSVALPINE-CVE-2020-25125 7.8

GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or possibly unspecified other impact, when a victim imports an attacker's OpenPGP key, and this key has AEAD preferences. The overflow is caused by a g10/key-check.c error. NOTE: GnuPG 2.3.x is unaffected. GnuPG 2.2.23 is a fixed version.

Record
ALPINE-CVE-2020-25125
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBELL-CVE-2020-25125 7.8

CVE-2020-25125 does not affect BellSoft software

Record
BELL-CVE-2020-25125
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 7.8

GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or possibly unspecified other impact, when a victim imports an attacker's OpenPGP key, and this key has AEAD preferences. The overflow is caused by a g10/key-check.c error. NOTE: GnuPG 2.3.x is unaffected. GnuPG 2.2.23 is a fixed version.

Record
CVE-2020-25125
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:10815-1 No score

dirmngr-2.2.27-2.4 on GA media

These are all security issues fixed in the dirmngr-2.2.27-2.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10815-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnupg
Alpine:v3.12
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.13
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.14
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.15
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.16
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.17
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.18
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.19
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.20
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.21
before 2.2.23-r0
2.2.23-r0
Show 4 moreShow less
Affected packages
PackageAffectedFixed
gnupg
Alpine:v3.22
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.23
before 2.2.23-r0
2.2.23-r0
gnupg
Alpine:v3.24
before 2.2.23-r0
2.2.23-r0
gpg2
openSUSE:Tumbleweed
From an advisory covering 8 CVEs
before 2.2.27-2.4
2.2.27-2.4

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-25125 is a high vulnerability (CVSS 7.8) in Gnupg, published September 3, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.28%, the 70th percentile. Fixed in gnupg 2.2.23-r0.

References

Show 12 moreShow less
MoveEnter Open