Every CVE Search/ Get API key

CVE-2020-25559

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in...

7.8 HighFix available

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in context-dependent arbitrary code execution.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.57%Up 0.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in context-dependent arbitrary code execution.

Record
CVE-2020-25559
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-415
Updated
2026-11-02
CVE List No score

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in context-dependent arbitrary code execution.

Record
CVE-2020-25559
Updated
2026-11-02
EUVDEUVD-2020-18243 No score

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in context-dependent arbitrary code execution.

Record
EUVD-2020-18243
Updated
2026-11-03
GitHub AdvisoriesGHSA-v6mq-89c8-6ff4 7.8

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in...

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in context-dependent arbitrary code execution.

Record
GHSA-v6mq-89c8-6ff4
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-415
Updated
2026-11-02
OSV 7.8

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in context-dependent arbitrary code execution.

Record
CVE-2020-25559
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-25559 7.8

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in context-dependent arbitrary code execution.

Record
DEBIAN-CVE-2020-25559
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVUBUNTU-CVE-2020-25559 7.8

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in context-dependent arbitrary code execution.

Record
UBUNTU-CVE-2020-25559
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2021-0127 No score

Updated gnuplot packages fix a security vulnerability

Double free when executing print_set_output() (CVE-2020-25559).

Additionally, a missing require for gnuplot has been added to gnuplot-qt package.

Record
MGASA-2021-0127
Updated
2026-11-02
OSVopenSUSE-SU-2021:0345-1 No score

Security update for gnuplot

This update for gnuplot fixes the following issues:

  • CVE-2020-25559: Fixed double free when executing print_set_output() (bsc#1176689).

This update was imported from the SUSE:SLE-15:Update update project.

Record
openSUSE-SU-2021:0345-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10800-1 No score

gnuplot-5.4.2-1.3 on GA media

These are all security issues fixed in the gnuplot-5.4.2-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10800-1
Updated
2026-11-02
OSVSUSE-SU-2021:0549-1 No score

Security update for gnuplot

This update for gnuplot fixes the following issues:

  • CVE-2020-25559: Fixed double free when executing print_set_output() (bsc#1176689).
Record
SUSE-SU-2021:0549-1
Updated
2026-11-02
OSVUSN-7589-1 No score

gnuplot vulnerabilities

Tim Blazytko, Cornelius Aschermann, Sergej Schumilo, and Nils Bars discovered that Gnuplot had several memory-related issues. An attacker could possibly use these issues to cause Gnuplot to experience a buffer overflow, resulting in a denial of service or arbitrary code execution. These issues only affected Ubuntu 14.04 LTS and Ubuntu 18.04 LTS. (CVE-2018-19490, CVE-2018-19491, CVE-2018-19492)

It was discovered that Gnuplot could write out-of-bounds due to the use of strncpy(). An attacker could possibly use this issue to enable the execution of arbitrary code. This issue only affected Ubuntu 20.04 LTS. (CVE-2020-25412)

It was discovered that Gnuplot incorrectly freed memory when executing print_set_output(). An attacker could possibly use this issue to enable the execution of arbitrary code. (CVE-2020-25559)

It was discovered that Gnuplot's plotrequest() function contained a buffer overflow. An attacker could possibly use this issue to cause Gnuplot to crash, resulting in a denial of service or arbitrary code execution. (CVE-2020-25969)

It was discovered that Gnuplot's boundary3d() function could be made to divide by zero. An attacker could possibly use this issue to cause Gnuplot to crash, resulting in a denial of service. (CVE-2021-44917)

Record
USN-7589-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnuplot
Debian:12
All versions, plus listed versions
5.4.4+dfsg1-26.0.0+dfsg1-16.0.0+dfsg1-26.0.0+dfsg1-36.0.2+dfsg1-1
Show 4 moreShow less
6.0.2+dfsg1-26.0.3+dfsg1-16.0.3+dfsg1-1~exp16.0.3+dfsg1-1~exp2
None known
gnuplot
Debian:13
before 6.0.0+dfsg1-1
6.0.0+dfsg1-1
gnuplot
Debian:14
before 6.0.0+dfsg1-1
6.0.0+dfsg1-1
gnuplot
Mageia:7
before 5.2.2-5.2.mga7
5.2.2-5.2.mga7
gnuplot
SUSE:Linux Enterprise Module for Server Applications 15 SP2
before 5.2.2-3.6.1
5.2.2-3.6.1
gnuplot
Ubuntu:Pro:14.04:LTS
before 4.6.4-2ubuntu0.1~esm1, plus listed versions
4.6.3-24.6.4-14.6.4-2
4.6.4-2ubuntu0.1~esm1
gnuplot
Ubuntu:Pro:16.04:LTS
before 4.6.6-3ubuntu0.1+esm1, plus listed versions
4.6.6-24.6.6-34.6.6-3ubuntu0.1
4.6.6-3ubuntu0.1+esm1
gnuplot
Ubuntu:Pro:18.04:LTS
before 5.2.2+dfsg1-2ubuntu1+esm1, plus listed versions
5.0.7+dfsg1-15.2.2+dfsg1-25.2.2+dfsg1-2ubuntu1
5.2.2+dfsg1-2ubuntu1+esm1
gnuplot
Ubuntu:Pro:20.04:LTS
before 5.2.8+dfsg1-2ubuntu0.1~esm1, plus listed versions
5.2.6+dfsg1-25.2.7+dfsg1-65.2.8+dfsg1-15.2.8+dfsg1-2
5.2.8+dfsg1-2ubuntu0.1~esm1
gnuplot
Ubuntu:Pro:14.04:LTS
From an advisory covering 7 CVEs
before 4.6.4-2ubuntu0.1~esm1, plus listed versions
4.6.3-24.6.4-14.6.4-2
4.6.4-2ubuntu0.1~esm1
Show 5 moreShow less
Affected packages
PackageAffectedFixed
gnuplot
Ubuntu:Pro:16.04:LTS
From an advisory covering 7 CVEs
before 4.6.6-3ubuntu0.1+esm1, plus listed versions
4.6.6-24.6.6-34.6.6-3ubuntu0.1
4.6.6-3ubuntu0.1+esm1
gnuplot
Ubuntu:Pro:18.04:LTS
From an advisory covering 7 CVEs
before 5.2.2+dfsg1-2ubuntu1+esm1, plus listed versions
5.0.7+dfsg1-15.2.2+dfsg1-25.2.2+dfsg1-2ubuntu1
5.2.2+dfsg1-2ubuntu1+esm1
gnuplot
Ubuntu:Pro:20.04:LTS
From an advisory covering 7 CVEs
before 5.2.8+dfsg1-2ubuntu0.1~esm1, plus listed versions
5.2.6+dfsg1-25.2.7+dfsg1-65.2.8+dfsg1-15.2.8+dfsg1-2
5.2.8+dfsg1-2ubuntu0.1~esm1
gnuplot
openSUSE:Leap 15.2
before 5.2.2-lp152.6.3.1
5.2.2-lp152.6.3.1
gnuplot
openSUSE:Tumbleweed
From an advisory covering 5 CVEs
before 5.4.2-1.3
5.4.2-1.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-25559 is a high vulnerability (CVSS 7.8) in Gnuplot, published September 16, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in gnuplot 6.0.0+dfsg1-1.

References

Show 17 moreShow less
MoveEnter Open