Every CVE Search/ Get API key

CVE-2020-25815

MediaWiki Cross-site Scripting (XSS) vulnerability

6.1 MediumFix available

An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.10%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

Record
CVE-2020-25815
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

Record
CVE-2020-25815
Updated
2026-11-02
EUVDEUVD-2022-1972 No score

An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

Record
EUVD-2022-1972
Updated
2026-11-03
GitHub AdvisoriesGHSA-2f58-vf6g-6p8x 6.1

MediaWiki Cross-site Scripting (XSS) vulnerability

An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

Record
GHSA-2f58-vf6g-6p8x
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

Record
CVE-2020-25815
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2020-25815 6.1

An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

Record
DEBIAN-CVE-2020-25815
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-2f58-vf6g-6p8x 6.1

MediaWiki Cross-site Scripting (XSS) vulnerability

An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

Record
GHSA-2f58-vf6g-6p8x
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2020-25815 6.1

An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

Record
UBUNTU-CVE-2020-25815
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVBIT-mediawiki-2020-25815 No score

An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().

Record
BIT-mediawiki-2020-25815
Updated
2026-11-02
OSVMGASA-2020-0381 No score

Updated mediawiki packages fix security vulnerability

Multiple security issues were discovered in MediaWiki: SpecialUserRights could leak whether a user existed or not, multiple code paths lacked HTML sanitisation allowing for cross-site scripting and TOTP validation applied insufficient rate limiting against brute force attempts (CVE-2020-25812, CVE-2020-25813, CVE-2020-25814, CVE-2020-25815, CVE-2020-25827, CVE-2020-25828).

Possible issues with actors not being loaded from the correct database or wiki (CVE-2020-25869).

Record
MGASA-2020-0381
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki/core
Packagist
1.32.0 up to 1.34.3
1.34.3
mediawiki/core
Packagist
1.35.0-rc.0 up to 1.35.0
1.35.0
mediawiki
Bitnami
1.32.0 up to 1.34.4
1.34.4
mediawiki
Debian:12
before 1:1.35.0-1
1:1.35.0-1
mediawiki
Debian:13
before 1:1.35.0-1
1:1.35.0-1
mediawiki
Debian:14
before 1:1.35.0-1
1:1.35.0-1
mediawiki/core
Packagist
1.32.0 up to 1.34.3, plus listed versions
1.32.11.32.21.32.31.32.41.32.5
Show 12 moreShow less
1.32.61.33.01.33.0-rc.01.33.11.33.21.33.31.33.41.34.01.34.0-rc.01.34.0-rc.11.34.11.34.2
1.34.3
mediawiki/core
Packagist
1.35.0-rc.0 up to 1.35.0, plus listed versions
1.35.0-rc.11.35.0-rc.21.35.0-rc.3
1.35.0
mediawiki
Mageia:7
From an advisory covering 7 CVEs
before 1.31.10-1.mga7
1.31.10-1.mga7
mediawiki
Ubuntu:18.04:LTS
All versions, plus listed versions
1:1.27.3-11:1.27.4-11:1.27.4-21:1.27.4-3
None known
mediawiki
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
1:1.31.2-1ubuntu11:1.31.5-11:1.31.5-1ubuntu11:1.31.5-21:1.31.5-3
Show 4 moreShow less
1:1.31.5-3ubuntu11:1.31.6-11:1.31.7-11:1.31.7-1ubuntu0.1~esm1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-25815 is a medium vulnerability (CVSS 6.1) in Mediawiki, published September 27, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.10%, the 65th percentile. Fixed in mediawiki/core 1.34.3.

References

Show 13 moreShow less
MoveEnter Open