CVE-2020-25915
ThinkCMF Cross-site Scripting Vulnerability
Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5, allows attackers to execute arbitrary code via crafted user_login.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5, allows attackers to execute arbitrary code via crafted user_login.
- Record
CVE-2020-25915- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5, allows attackers to execute arbitrary code via crafted user_login.
- Record
CVE-2020-25915- Updated
- 2026-11-02
EUVDEUVD-2023-2203 No score
Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5, allows attackers to execute arbitrary code via crafted user_login.
- Record
EUVD-2023-2203- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4847-gqxx-v9xp
5.4
ThinkCMF Cross-site Scripting Vulnerability
Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5, allows attackers to execute arbitrary code via crafted user_login.
- Record
GHSA-4847-gqxx-v9xp- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5, allows attackers to execute arbitrary code via crafted user_login.
- Record
CVE-2020-25915- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-4847-gqxx-v9xp
5.4
ThinkCMF Cross-site Scripting Vulnerability
Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5, allows attackers to execute arbitrary code via crafted user_login.
- Record
GHSA-4847-gqxx-v9xp- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
thinkcmf/thinkcmfPackagist |
before 5.1.7 | 5.1.7 |
thinkcmf/thinkcmfPackagist |
before 5.1.7, plus listed versions 5.0-Beta5.0-RC45.0.1706075.0.1709275.0.170927-rc Show 24 moreShow less5.0.180103-beta5.0.180115-RC5.0.1801235.0.1805015.0.1805085.0.1805255.0.1806265.0.1809015.0.1812125.0.1812315.0.181231-beta5.0.1901115.0.1903125.0.1904195.0RC15.0RC25.0RC35.1.0-betav5.1.0v5.1.1v5.1.2v5.1.3v5.1.4v5.1.5 |
5.1.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-25915 is a medium vulnerability (CVSS 5.4) in Thinkcmf, published August 11, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in thinkcmf/thinkcmf 5.1.7.