Every CVE Search/ Get API key

CVE-2020-26223

Authorization bypass in Spree

7.7 HighFix available

Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.12%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.7

Authorization bypass in Spree

Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

Record
CVE-2020-26223
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2020-1461 7.7

Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

Record
EUVD-2020-1461
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-m2jr-hmc3-qmpr 7.7

Authorization bypass in Spree

Impact

The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token

Patches

Please upgrade to 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

References

Pull request with a fix and in-depth explanation - https://github.com/spree/spree/pull/10573

For more information

If you have any questions or comments about this advisory:

Record
GHSA-m2jr-hmc3-qmpr
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-863
Updated
2026-11-02
NVD 7.7

Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

Record
CVE-2020-26223
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-863
Updated
2026-11-02
OSV 6.5

Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

Record
CVE-2020-26223
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-m2jr-hmc3-qmpr 7.7

Authorization bypass in Spree

Impact

The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token

Patches

Please upgrade to 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

References

Pull request with a fix and in-depth explanation - https://github.com/spree/spree/pull/10573

For more information

If you have any questions or comments about this advisory:

Record
GHSA-m2jr-hmc3-qmpr
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-863
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
spree_api
RubyGems
3.7.0 up to 3.7.13
3.7.13
spree_api
RubyGems
4.0.0 up to 4.0.5
4.0.5
spree_api
RubyGems
4.1.0 up to 4.1.12
4.1.12
spree_api
RubyGems
3.7.0 up to 3.7.13, plus listed versions
3.7.13.7.103.7.113.7.123.7.2
Show 7 moreShow less
3.7.33.7.43.7.53.7.63.7.73.7.83.7.9
3.7.13
spree_api
RubyGems
4.0.0 up to 4.0.5, plus listed versions
4.0.14.0.24.0.34.0.4
4.0.5
spree_api
RubyGems
4.1.0 up to 4.1.12, plus listed versions
4.1.14.1.104.1.114.1.24.1.3
Show 6 moreShow less
4.1.44.1.54.1.64.1.74.1.84.1.9
4.1.12

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-26223 is a high vulnerability (CVSS 7.7) in Spree, published November 13, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.12%, the 66th percentile. Fixed in spree_api 3.7.13.

References

MoveEnter Open