CVE-2020-26523
Froala WYSIWYG Editor XSS Vulnerability
Froala Editor before 3.2.2 allows XSS via pasted content.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Froala Editor before 3.2.2 allows XSS via pasted content.
- Record
CVE-2020-26523- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Froala Editor before 3.2.2 allows XSS via pasted content.
- Record
CVE-2020-26523- Updated
- 2026-11-02
EUVDEUVD-2022-5026 No score
Froala Editor before 3.2.2 allows XSS via pasted content.
- Record
EUVD-2022-5026- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qrhq-x7xh-2784
6.1
Froala WYSIWYG Editor XSS Vulnerability
Froala Editor before 3.2.2 allows XSS via pasted content.
- Record
GHSA-qrhq-x7xh-2784- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Froala Editor before 3.2.2 allows XSS via pasted content.
- Record
CVE-2020-26523- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-qrhq-x7xh-2784
6.1
Froala WYSIWYG Editor XSS Vulnerability
Froala Editor before 3.2.2 allows XSS via pasted content.
- Record
GHSA-qrhq-x7xh-2784- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
froala/wysiwyg-editorPackagist |
before 3.2.2 | 3.2.2 |
froala/wysiwyg-editorPackagist |
before 3.2.2, plus listed versions 2.7.1v2.3.5v2.4.0v2.4.0-rc.1v2.4.1 Show 45 moreShow lessv2.4.2v2.5.0v2.5.1v2.6.0v2.6.1v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.7.0v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4v2.8.5v2.9.0v2.9.1v2.9.2v2.9.3v2.9.4v2.9.5v2.9.6v2.9.7v2.9.8v3.0.0v3.0.0-beta.1v3.0.0-beta.2v3.0.0-rc.1v3.0.0-rc.2v3.0.1v3.0.2v3.0.3v3.0.4v3.0.5v3.0.6v3.1.0v3.1.1v3.2.0 |
3.2.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-26523 is a medium vulnerability (CVSS 6.1) in Froala Editor, published October 2, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 52nd percentile. Fixed in froala/wysiwyg-editor 3.2.2.
References
Left out here: 1 version. The JSON record has them.