CVE-2020-27351
Various memory and file descriptor leaks in apt-python
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170. This issue affects: python-apt 1.1.0beta1 versions prior to 1.1.0beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1;
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
2.0
Various memory and file descriptor leaks in apt-python
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170. This issue affects: python-apt 1.1.0beta1 versions prior to 1.1.0beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1;
- Record
CVE-2020-27351- CVSS 3.1
- 2.0 Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:L - Weakness
- CWE-772
- Updated
- 2026-11-02
EUVDEUVD-2020-19863
2.0
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170. This issue affects: python-apt 1.1.0beta1 versions prior to 1.1.0beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1;
- Record
EUVD-2020-19863- CVSS 3.1
- 2.0 Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mfw3-hgv3-pg44 No score
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python...
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170. This issue affects: python-apt 1.1.0beta1 versions prior to 1.1.0beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1;
- Record
GHSA-mfw3-hgv3-pg44- Weakness
- CWE-772
- Updated
- 2026-11-02
NVD
2.0
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170. This issue affects: python-apt 1.1.0beta1 versions prior to 1.1.0beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1;
- Record
CVE-2020-27351- CVSS 3.1
- 2.0 Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:L - CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L - CVSS 2.0
- 2.1 Low
AV:L/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-772
- Updated
- 2026-11-02
OSV
2.8
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170. This issue affects: python-apt 1.1.0beta1 versions prior to 1.1.0beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1;
- Record
CVE-2020-27351- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-27351
2.8
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170. This issue affects: python-apt 1.1.0beta1 versions prior to 1.1.0beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1;
- Record
DEBIAN-CVE-2020-27351- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-27351
2.8
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170. This issue affects: python-apt 1.1.0beta1 versions prior to 1.1.0beta1ubuntu0.16.04.10; 1.6.5ubuntu0 versions prior to 1.6.5ubuntu0.4; 2.0.0ubuntu0 versions prior to 2.0.0ubuntu0.20.04.2; 2.1.3ubuntu1 versions prior to 2.1.3ubuntu1.1;
- Record
UBUNTU-CVE-2020-27351- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L - CVSS 3.1
- 2.0 Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVUSN-4668-1 No score
python-apt vulnerability
Kevin Backhouse discovered that python-apt incorrectly handled resources. A local attacker could possibly use this issue to cause python-apt to consume resources, leading to a denial of service.
- Record
USN-4668-1- Updated
- 2026-11-02
OSVUSN-4668-4 No score
python-apt vulnerability
USN-4668-1 fixed a vulnerability in python-apt. This update provides the corresponding update for Ubuntu 14.04 ESM.
Original advisory details:
Kevin Backhouse discovered that python-apt incorrectly handled resources. A local attacker could possibly use this issue to cause python-apt to consume resources, leading to a denial of service.
- Record
USN-4668-4- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
python-aptDebian:12 |
before 2.1.7 | 2.1.7 |
python-aptDebian:13 |
before 2.1.7 | 2.1.7 |
python-aptDebian:14 |
before 2.1.7 | 2.1.7 |
python-aptDebian:9 |
before 1.4.2, plus listed versions 1.4.0~beta31.4.1 |
1.4.2 |
python-aptDebian:10 |
before 1.8.4.2, plus listed versions 1.8.41.8.4.1 |
1.8.4.2 |
python-aptUbuntu:Pro:14.04:LTS |
before 0.9.3.5ubuntu3+esm4, plus listed versions 0.8.9.1ubuntu10.9.00.9.10.9.1ubuntu10.9.3.2 Show 10 moreShow less0.9.3.2ubuntu20.9.3.30.9.3.3ubuntu10.9.3.40.9.3.4build10.9.3.50.9.3.5ubuntu10.9.3.5ubuntu20.9.3.5ubuntu30.9.3.5ubuntu3+esm2 |
0.9.3.5ubuntu3+esm4 |
python-aptUbuntu:16.04:LTS |
before 1.1.0~beta1ubuntu0.16.04.10, plus listed versions 1.0.1build11.0.1ubuntu21.1.0~beta11.1.0~beta1build11.1.0~beta1ubuntu0.16.04.1 Show 6 moreShow less1.1.0~beta1ubuntu0.16.04.21.1.0~beta1ubuntu0.16.04.41.1.0~beta1ubuntu0.16.04.51.1.0~beta1ubuntu0.16.04.71.1.0~beta1ubuntu0.16.04.81.1.0~beta1ubuntu0.16.04.9 |
1.1.0~beta1ubuntu0.16.04.10 |
python-aptUbuntu:18.04:LTS |
before 1.6.5ubuntu0.4, plus listed versions 1.4.0~beta3build21.4.0~beta3ubuntu11.6.0~rc2ubuntu11.6.0~rc2ubuntu21.6.0 Show 8 moreShow less1.6.11.6.21.6.31.6.3ubuntu11.6.41.6.5ubuntu0.11.6.5ubuntu0.21.6.5ubuntu0.3 |
1.6.5ubuntu0.4 |
python-aptUbuntu:20.04:LTS |
before 2.0.0ubuntu0.20.04.2, plus listed versions 1.9.0ubuntu11.9.0ubuntu31.9.0ubuntu51.9.3ubuntu21.9.5 Show 6 moreShow less1.9.5build11.9.71.9.81.9.102.0.02.0.0ubuntu0.20.04.1 |
2.0.0ubuntu0.20.04.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-27351 is a low vulnerability (CVSS 2.0) in Canonical Python-apt, published December 9, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 33rd percentile. Fixed in python-apt 2.1.7.