CVE-2020-27780
A flaw was found in Linux-Pam in versions prior to 1.5.1 in the way it handle empty passwords for...
A flaw was found in Linux-Pam in versions prior to 1.5.1 in the way it handle empty passwords for non-existing users. When the user doesn't exist PAM try to authenticate with root and in the case of an empty password it successfully authenticate.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
A flaw was found in Linux-Pam in versions prior to 1.5.1 in the way it handle empty passwords for non-existing users. When the user doesn't exist PAM try to authenticate with root and in the case of an empty password it successfully authenticate.
- Record
CVE-2020-27780- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-287
- Updated
- 2026-11-02
CVE List No score
A flaw was found in Linux-Pam in versions prior to 1.5.1 in the way it handle empty passwords for non-existing users. When the user doesn't exist PAM try to authenticate with root and in the case of an empty password it successfully authenticate.
- Record
CVE-2020-27780- Weakness
- CWE-287
- Updated
- 2026-11-02
EUVDEUVD-2020-20284 No score
A flaw was found in Linux-Pam in versions prior to 1.5.1 in the way it handle empty passwords for non-existing users. When the user doesn't exist PAM try to authenticate with root and in the case of an empty password it successfully authenticate.
- Record
EUVD-2020-20284- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pgjg-jx8c-q35f No score
A flaw was found in Linux-Pam in versions prior to 1.5.1 in the way it handle empty passwords for...
A flaw was found in Linux-Pam in versions prior to 1.5.1 in the way it handle empty passwords for non-existing users. When the user doesn't exist PAM try to authenticate with root and in the case of an empty password it successfully authenticate.
- Record
GHSA-pgjg-jx8c-q35f- Weakness
- CWE-287
- Updated
- 2026-11-02
OSVALPINE-CVE-2020-27780
9.8
A flaw was found in Linux-Pam in versions prior to 1.5.1 in the way it handle empty passwords for non-existing users. When the user doesn't exist PAM try to authenticate with root and in the case of an empty password it successfully authenticate.
- Record
ALPINE-CVE-2020-27780- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBELL-CVE-2020-27780
9.8
CVE-2020-27780 does not affect BellSoft software
- Record
BELL-CVE-2020-27780- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
9.8
A flaw was found in Linux-Pam in versions prior to 1.5.1 in the way it handle empty passwords for non-existing users. When the user doesn't exist PAM try to authenticate with root and in the case of an empty password it successfully authenticate.
- Record
CVE-2020-27780- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11140-1 No score
pam-1.5.2-1.1 on GA media
These are all security issues fixed in the pam-1.5.2-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11140-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
linux-pamAlpine:v3.13 |
1.5.0 up to 1.5.1 | 1.5.1 |
linux-pamAlpine:v3.14 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
linux-pamAlpine:v3.15 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
linux-pamAlpine:v3.16 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
linux-pamAlpine:v3.17 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
linux-pamAlpine:v3.18 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
linux-pamAlpine:v3.19 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
linux-pamAlpine:v3.20 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
linux-pamAlpine:v3.21 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
linux-pamAlpine:v3.22 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
linux-pamAlpine:v3.23 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
linux-pamAlpine:v3.24 |
1.5.0 up to 1.5.1-r0 | 1.5.1-r0 |
pamopenSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 1.5.2-1.1 | 1.5.2-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-27780 is a critical vulnerability (CVSS 9.8) in Linux-pam, published December 17, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.96%, the 80th percentile. Fixed in linux-pam 1.5.1.