Every CVE Search/ Get API key

CVE-2020-28035

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

9.8 CriticalFix available

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.25%Up 2.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

Record
CVE-2020-28035
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

Record
CVE-2020-28035
Updated
2026-11-02
EUVDEUVD-2020-20526 No score

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

Record
EUVD-2020-20526
Updated
2026-11-03
GitHub AdvisoriesGHSA-94cf-q7rf-65xg 9.8

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

Record
GHSA-94cf-q7rf-65xg
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-269
Updated
2026-11-02
OSV 9.8

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

Record
CVE-2020-28035
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-28035 9.8

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

Record
DEBIAN-CVE-2020-28035
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-28035 9.8

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

Record
UBUNTU-CVE-2020-28035
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-wordpress-2020-28035 No score

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

Record
BIT-wordpress-2020-28035
Updated
2026-11-02
OSVBIT-wordpress-multisite-2020-28035 No score

WordPress before 5.5.2 allows attackers to gain privileges via XML-RPC.

Record
BIT-wordpress-multisite-2020-28035
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Bitnami
before 5.5.2
5.5.2
wordpress-multisite
Bitnami
before 5.5.2
5.5.2
wordpress
Debian:12
before 5.5.3+dfsg1-1
5.5.3+dfsg1-1
wordpress
Debian:13
before 5.5.3+dfsg1-1
5.5.3+dfsg1-1
wordpress
Debian:14
before 5.5.3+dfsg1-1
5.5.3+dfsg1-1
wordpress
Debian:9
From an advisory covering 9 CVEs
before 4.7.19+dfsg-1+deb9u1, plus listed versions
4.7.18+dfsg-1+deb9u14.7.5+dfsg-24.7.5+dfsg-2+deb9u14.7.5+dfsg-2+deb9u1~bpo8+14.7.5+dfsg-2+deb9u2
Show 5 moreShow less
4.7.5+dfsg-2+deb9u2~bpo8+14.7.5+dfsg-2+deb9u34.7.5+dfsg-2+deb9u44.7.5+dfsg-2+deb9u54.7.5+dfsg-2+deb9u6
4.7.19+dfsg-1+deb9u1
wordpress
Debian:10
From an advisory covering 9 CVEs
before 5.0.11+dfsg1-0+deb10u1, plus listed versions
5.0.10+dfsg1-0+deb10u15.0.4+dfsg1-15.0.4+dfsg1-1+deb10u15.0.4+dfsg1-1+deb10u2
5.0.11+dfsg1-0+deb10u1
wordpress
Ubuntu:16.04:LTS
All versions, plus listed versions
4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1
None known
wordpress
Ubuntu:18.04:LTS
All versions, plus listed versions
4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1
None known
wordpress
Ubuntu:20.04:LTS
All versions, plus listed versions
5.2.2+dfsg1-15.2.4+dfsg1-15.3.2+dfsg1-15.3.2+dfsg1-1ubuntu1
None known
Show 5 moreShow less
Affected packages
PackageAffectedFixed
wordpress
Ubuntu:22.04:LTS
All versions, plus listed versions
5.7.1+dfsg1-2ubuntu15.8.1+dfsg1-2ubuntu15.8.2+dfsg1-1ubuntu15.8.3+dfsg1-1ubuntu15.8.3+dfsg1-1ubuntu1.1
None known
wordpress
Ubuntu:24.04:LTS
All versions, plus listed versions
6.2+dfsg1-1ubuntu16.4.3+dfsg1-1ubuntu1
None known
wordpress
Ubuntu:25.10
All versions, plus listed versions
6.7.2+dfsg1-1.1ubuntu1
None known
wordpress
Ubuntu:26.10
All versions, plus listed versions
6.7.2+dfsg1-1.1ubuntu2
None known
wordpress
Ubuntu:26.04:LTS
All versions, plus listed versions
6.7.2+dfsg1-1.1ubuntu16.7.2+dfsg1-1.1ubuntu2
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-28035 is a critical vulnerability (CVSS 9.8) in Wordpress, published October 31, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.25%, the 91st percentile. Fixed in wordpress 5.5.2.

References

Show 8 moreShow less
MoveEnter Open