CVE-2020-28038
WordPress before 5.5.2 allows stored XSS via post slugs.
CVE-2020-28038 is a medium vulnerability (CVSS 6.1) in Wordpress, published October 31, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.61%, the 85th percentile. Fixed in wordpress 5.5.2.
WordPress before 5.5.2 allows stored XSS via post slugs.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
WordPress before 5.5.2 allows stored XSS via post slugs.
- Record
CVE-2020-28038- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
WordPress before 5.5.2 allows stored XSS via post slugs.
- Record
CVE-2020-28038- Updated
- 2026-11-02
EUVDEUVD-2020-20529 No score
WordPress before 5.5.2 allows stored XSS via post slugs.
- Record
EUVD-2020-20529- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mwxx-w555-5h5m
6.1
WordPress before 5.5.2 allows stored XSS via post slugs.
WordPress before 5.5.2 allows stored XSS via post slugs.
- Record
GHSA-mwxx-w555-5h5m- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
WordPress before 5.5.2 allows stored XSS via post slugs.
- Record
CVE-2020-28038- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-28038
6.1
WordPress before 5.5.2 allows stored XSS via post slugs.
- Record
DEBIAN-CVE-2020-28038- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-28038
6.1
WordPress before 5.5.2 allows stored XSS via post slugs.
- Record
UBUNTU-CVE-2020-28038- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVBIT-wordpress-2020-28038 No score
WordPress before 5.5.2 allows stored XSS via post slugs.
- Record
BIT-wordpress-2020-28038- Updated
- 2026-11-02
OSVBIT-wordpress-multisite-2020-28038 No score
WordPress before 5.5.2 allows stored XSS via post slugs.
- Record
BIT-wordpress-multisite-2020-28038- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressBitnami |
before 5.5.2 | 5.5.2 |
wordpress-multisiteBitnami |
before 5.5.2 | 5.5.2 |
wordpressDebian:12 |
before 5.5.3+dfsg1-1 | 5.5.3+dfsg1-1 |
wordpressDebian:13 |
before 5.5.3+dfsg1-1 | 5.5.3+dfsg1-1 |
wordpressDebian:14 |
before 5.5.3+dfsg1-1 | 5.5.3+dfsg1-1 |
wordpressDebian:9 |
before 4.7.19+dfsg-1+deb9u1, plus listed versions 4.7.18+dfsg-1+deb9u14.7.5+dfsg-24.7.5+dfsg-2+deb9u14.7.5+dfsg-2+deb9u1~bpo8+14.7.5+dfsg-2+deb9u2 Show 5 moreShow less4.7.5+dfsg-2+deb9u2~bpo8+14.7.5+dfsg-2+deb9u34.7.5+dfsg-2+deb9u44.7.5+dfsg-2+deb9u54.7.5+dfsg-2+deb9u6 |
4.7.19+dfsg-1+deb9u1 |
wordpressDebian:10 |
before 5.0.11+dfsg1-0+deb10u1, plus listed versions 5.0.10+dfsg1-0+deb10u15.0.4+dfsg1-15.0.4+dfsg1-1+deb10u15.0.4+dfsg1-1+deb10u2 |
5.0.11+dfsg1-0+deb10u1 |
wordpressUbuntu:16.04:LTS |
All versions, plus listed versions 4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1 |
None known |
wordpressUbuntu:18.04:LTS |
All versions, plus listed versions 4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1 |
None known |
wordpressUbuntu:20.04:LTS |
All versions, plus listed versions 5.2.2+dfsg1-15.2.4+dfsg1-15.3.2+dfsg1-15.3.2+dfsg1-1ubuntu1 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
wordpressUbuntu:22.04:LTS |
All versions, plus listed versions 5.7.1+dfsg1-2ubuntu15.8.1+dfsg1-2ubuntu15.8.2+dfsg1-1ubuntu15.8.3+dfsg1-1ubuntu15.8.3+dfsg1-1ubuntu1.1 |
None known |
wordpressUbuntu:24.04:LTS |
All versions, plus listed versions 6.2+dfsg1-1ubuntu16.4.3+dfsg1-1ubuntu1 |
None known |
wordpressUbuntu:25.10 |
All versions, plus listed versions 6.7.2+dfsg1-1.1ubuntu1 |
None known |
wordpressUbuntu:26.10 |
All versions, plus listed versions 6.7.2+dfsg1-1.1ubuntu2 |
None known |
wordpressUbuntu:26.04:LTS |
All versions, plus listed versions 6.7.2+dfsg1-1.1ubuntu16.7.2+dfsg1-1.1ubuntu2 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
wordpress.org/news/2020/10/wordpress-5-5-2-security-and-maintenance-release
blog.ripstech.com
lists.debian.org/debian-lts-announce/2020/11/msg00004.html
debian.org/security/2020/dsa-4784
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VAVVYJKA2I6CRQUINECDPBGWMQDEG244
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VUXVUAKL2HL4QYJEPHBNVQQWRMFMII2Y
Show 9 moreShow less
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CHHVNK2WYAM3ZTCXTFSEIT56IKLVJHU3
nvd.nist.gov/vuln/detail/CVE-2020-28038
lists.fedoraproject.org/archives/list/[email protected]/message/CHHVNK2WYAM3ZTCXTFSEIT56IKLVJHU3
lists.fedoraproject.org/archives/list/[email protected]/message/VAVVYJKA2I6CRQUINECDPBGWMQDEG244
lists.fedoraproject.org/archives/list/[email protected]/message/VUXVUAKL2HL4QYJEPHBNVQQWRMFMII2Y
github.com/advisories/GHSA-mwxx-w555-5h5m
security-tracker.debian.org/tracker/CVE-2020-28038
ubuntu.com/security/CVE-2020-28038
cve.org/CVERecord?id=CVE-2020-28038