CVE-2020-28984
Improper Input Validation in SPIP
CVE-2020-28984 is a critical vulnerability (CVSS 9.8) in Spip, published November 23, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.19%, the 82nd percentile. Fixed in spip 3.2.8-1.
prive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
prive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
- Record
CVE-2020-28984- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
prive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
- Record
CVE-2020-28984- Updated
- 2026-11-02
EUVDEUVD-2020-21367 No score
prive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
- Record
EUVD-2020-21367- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5w2r-g8c8-f3m3
9.8
Improper Input Validation in SPIP
prive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
- Record
GHSA-5w2r-g8c8-f3m3- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
9.8
prive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
- Record
CVE-2020-28984- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-28984
9.8
prive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
- Record
DEBIAN-CVE-2020-28984- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-28984
9.8
prive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
- Record
UBUNTU-CVE-2020-28984- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-5482-1 No score
spip vulnerabilities
It was discovered that SPIP incorrectly validated inputs. An authenticated attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 LTS. (CVE-2020-28984)
Charles Fol and Théo Gordyjan discovered that SPIP is vulnerable to Cross Site Scripting (XSS). If a user were tricked into browsing a malicious SVG file, an attacker could possibly exploit this issue to execute arbitrary code. This issue was only fixed in Ubuntu 21.10. (CVE-2021-44118, CVE-2021-44120, CVE-2021-44122, CVE-2021-44123)
It was discovered that SPIP incorrectly handled certain forms. A remote authenticated editor could possibly use this issue to execute arbitrary code, and a remote unauthenticated attacker could possibly use this issue to obtain sensitive information. (CVE-2022-26846, CVE-2022-26847)
- Record
USN-5482-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
spipDebian:13 |
before 3.2.8-1 | 3.2.8-1 |
spipDebian:14 |
before 3.2.8-1 | 3.2.8-1 |
spipDebian:9 |
before 3.1.4-4~deb9u4, plus listed versions 3.1.4-23.1.4-33.1.4-3~deb9u13.1.4-4~deb9u13.1.4-4~deb9u23.1.4-4~deb9u3 |
3.1.4-4~deb9u4 |
spipDebian:10 |
before 3.2.4-1+deb10u3, plus listed versions 3.2.4-13.2.4-1+deb10u13.2.4-1+deb10u2 |
3.2.4-1+deb10u3 |
spipUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 3.0.20-13.0.21-13.0.21-1ubuntu13.0.21-1ubuntu1+esm1 |
None known |
spipUbuntu:18.04:LTS |
before 3.1.4-4~deb9u5build0.18.04.1, plus listed versions 3.1.4-33.1.4-4~deb9u3build0.18.04.1 |
3.1.4-4~deb9u5build0.18.04.1 |
spipUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 3.2.4-13.2.5-13.2.7-13.2.7-1ubuntu0.13.2.7-1ubuntu0.1+esm2 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
git.spip.net/spip/spip/commit/ae4267eba1022dabc12831ddb021c5d6e09040f8
git.spip.net/spip/spip/compare/v3.2.7...v3.2.8
debian.org/security/2020/dsa-4798
lists.debian.org/debian-lts-announce/2020/12/msg00036.html
nvd.nist.gov/vuln/detail/CVE-2020-28984
github.com/advisories/GHSA-5w2r-g8c8-f3m3
Show 10 moreShow less
security-tracker.debian.org/tracker/CVE-2020-28984
ubuntu.com/security/CVE-2020-28984
ubuntu.com/security/notices/USN-5482-1
cve.org/CVERecord?id=CVE-2020-28984
ubuntu.com/security/CVE-2021-44118
ubuntu.com/security/CVE-2021-44120
ubuntu.com/security/CVE-2021-44122
ubuntu.com/security/CVE-2021-44123
ubuntu.com/security/CVE-2022-26846
ubuntu.com/security/CVE-2022-26847