Every CVE Search/ Get API key

CVE-2020-29074

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other...

8.8 HighFix available

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other than the current user.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.78%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other than the current user.

Record
CVE-2020-29074
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-732
Updated
2026-11-02
CVE List No score

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other than the current user.

Record
CVE-2020-29074
Updated
2026-11-02
EUVDEUVD-2020-21456 No score

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other than the current user.

Record
EUVD-2020-21456
Updated
2026-11-03
GitHub AdvisoriesGHSA-qjv2-p92g-q4wq No score

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other...

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other than the current user.

Record
GHSA-qjv2-p92g-q4wq
Weakness
CWE-862
Updated
2026-11-02
OSVALPINE-CVE-2020-29074 8.8

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other than the current user.

Record
ALPINE-CVE-2020-29074
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.8

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other than the current user.

Record
CVE-2020-29074
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2020-29074 8.8

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other than the current user.

Record
DEBIAN-CVE-2020-29074
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-29074 8.8

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other than the current user.

Record
UBUNTU-CVE-2020-29074
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2020-0454 No score

Updated x11vnc package fixes a security vulnerability

scan.c in x11vnc 0.9.16 uses IPC_CREAT|0777 in shmget calls, which allows access by actors other than the current user. (CVE-2020-29074)

Record
MGASA-2020-0454
Updated
2026-11-02
OSVopenSUSE-SU-2024:11496-1 No score

veyon-4.6.0-1.1 on GA media

These are all security issues fixed in the veyon-4.6.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11496-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
x11vnc
Alpine:v3.12
before 0.9.16-r1
0.9.16-r1
x11vnc
Alpine:v3.13
before 0.9.16-r2
0.9.16-r2
x11vnc
Alpine:v3.14
before 0.9.16-r2
0.9.16-r2
x11vnc
Alpine:v3.15
before 0.9.16-r2
0.9.16-r2
x11vnc
Alpine:v3.16
before 0.9.16-r2
0.9.16-r2
x11vnc
Alpine:v3.17
before 0.9.16-r2
0.9.16-r2
x11vnc
Alpine:v3.18
before 0.9.16-r2
0.9.16-r2
x11vnc
Alpine:v3.19
before 0.9.16-r2
0.9.16-r2
x11vnc
Alpine:v3.20
before 0.9.16-r2
0.9.16-r2
x11vnc
Alpine:v3.21
before 0.9.16-r2
0.9.16-r2
Show 11 moreShow less
Affected packages
PackageAffectedFixed
x11vnc
Alpine:v3.22
before 0.9.16-r2
0.9.16-r2
x11vnc
Alpine:v3.23
before 0.9.16-r2
0.9.16-r2
x11vnc
Alpine:v3.24
before 0.9.16-r2
0.9.16-r2
x11vnc
Debian:12
before 0.9.16-5
0.9.16-5
x11vnc
Debian:13
before 0.9.16-5
0.9.16-5
x11vnc
Debian:14
before 0.9.16-5
0.9.16-5
x11vnc
Debian:9
before 0.9.13-2+deb9u2, plus listed versions
0.9.13-20.9.13-2+deb9u1
0.9.13-2+deb9u2
x11vnc
Debian:10
before 0.9.13-6+deb10u1, plus listed versions
0.9.13-6
0.9.13-6+deb10u1
x11vnc
Mageia:7
before 0.9.16-1.1.mga7
0.9.16-1.1.mga7
x11vnc
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
0.9.13-60.9.16-30.9.16-3ubuntu0.1~esm1
None known
veyon
openSUSE:Tumbleweed
before 4.6.0-1.1
4.6.0-1.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-29074 is a high vulnerability (CVSS 8.8) in X11vnc Project X11vnc, published November 25, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.78%, the 78th percentile. Fixed in x11vnc 0.9.16-r1.

References

Show 12 moreShow less
MoveEnter Open