CVE-2020-35124
XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic
A cross-site scripting (XSS) vulnerability in the assets component of Mautic before 3.2.4 allows remote attackers to inject executable JavaScript through the Referer header of asset downloads.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.6
A cross-site scripting (XSS) vulnerability in the assets component of Mautic before 3.2.4 allows remote attackers to inject executable JavaScript through the Referer header of asset downloads.
- Record
CVE-2020-35124- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
A cross-site scripting (XSS) vulnerability in the assets component of Mautic before 3.2.4 allows remote attackers to inject executable JavaScript through the Referer header of asset downloads.
- Record
CVE-2020-35124- Updated
- 2026-11-02
EUVDEUVD-2021-0482 No score
A cross-site scripting (XSS) vulnerability in the assets component of Mautic before 3.2.4 allows remote attackers to inject executable JavaScript through the Referer header of asset downloads.
- Record
EUVD-2021-0482- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-39wj-j3jc-858m No score
XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic
Impact
This is a cross-site scripting vulnerability which affects every version of Mautic and could allow an attacker unauthorised administrator level access to Mautic.
This vulnerability was reported by Naveen Sunkavally at Horizon3.ai.
Patches
Upgrade to 3.2.4 or 2.16.5.
Link to patch for 2.x versions: https://github.com/mautic/mautic/compare/2.16.4...2.16.5.diff
Link to patch for 3.x versions: https://github.com/mautic/mautic/compare/3.2.2...3.2.4.diff
Workarounds
None
For more information
If you have any questions or comments about this advisory:
- Post in https://forum.mautic.org/c/support
- Email us at [email protected]
- Record
GHSA-39wj-j3jc-858m- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
9.6
A cross-site scripting (XSS) vulnerability in the assets component of Mautic before 3.2.4 allows remote attackers to inject executable JavaScript through the Referer header of asset downloads.
- Record
CVE-2020-35124- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-39wj-j3jc-858m No score
XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic
Impact
This is a cross-site scripting vulnerability which affects every version of Mautic and could allow an attacker unauthorised administrator level access to Mautic.
This vulnerability was reported by Naveen Sunkavally at Horizon3.ai.
Patches
Upgrade to 3.2.4 or 2.16.5.
Link to patch for 2.x versions: https://github.com/mautic/mautic/compare/2.16.4...2.16.5.diff
Link to patch for 3.x versions: https://github.com/mautic/mautic/compare/3.2.2...3.2.4.diff
Workarounds
None
For more information
If you have any questions or comments about this advisory:
- Post in https://forum.mautic.org/c/support
- Email us at [email protected]
- Record
GHSA-39wj-j3jc-858m- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mautic/corePackagist |
3.0.0 up to 3.2.4 | 3.2.4 |
mautic/corePackagist |
2.0.0 up to 2.16.5 | 2.16.5 |
mautic/corePackagist |
3.0.0 up to 3.2.4, plus listed versions 3.0.13.0.23.0.2-rc3.1.03.1.0-rc Show 10 moreShow less3.1.13.1.1-rc3.1.23.1.2-rc3.2.03.2.0-rc3.2.13.2.23.2.2-rc3.2.3 |
3.2.4 |
mautic/corePackagist |
2.0.0 up to 2.16.5, plus listed versions 2.0.12.1.02.1.12.10.02.10.0-beta Show 45 moreShow less2.10.12.11.02.11.0-beta2.12.02.12.0-beta2.12.12.12.1-beta2.12.22.12.2-beta2.13.02.13.0-beta2.13.12.14.02.14.0-beta2.14.12.14.1-beta2.14.22.14.2-beta2.15.02.15.0-beta2.15.12.15.1-beta2.15.22.15.2-beta2.15.32.15.3-beta2.16.02.16.0-beta2.16.12.16.1-beta2.16.22.16.2-beta2.16.32.16.3-beta2.16.42.2.02.2.12.3.02.4.02.5.02.5.12.6.02.6.12.7.02.7.1 |
2.16.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-35124 is a critical vulnerability (CVSS 9.6) in Acquia Mautic, published January 19, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.43%, the 84th percentile. Fixed in mautic/core 3.2.4.
References
forum.mautic.org/c/announcements/16
mautic.org/blog/community/security-release-all-versions-mautic-prior-2-16-5-and-3-2-4
horizon3.ai/disclosures/mautic-unauth-xss-to-rce
github.com/mautic/mautic/security/advisories/GHSA-39wj-j3jc-858m
github.com/mautic/mautic/commit/20c5dc39b62164f6922ce53ea42cbb4ccec64e57
packagist.org/packages/mautic/core
nvd.nist.gov/vuln/detail/CVE-2020-35124
github.com/FriendsOfPHP/security-advisories/blob/master/mautic/core/CVE-2020-35124.yaml
github.com/advisories/GHSA-39wj-j3jc-858m
Left out here: 7 versions. The JSON record has them.