Every CVE Search/ Get API key

CVE-2020-35132

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store...

5.4 MediumFix available

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store malicious values that may be executed by other users at a later time via get_request in lib/function.php.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.25%Down 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.4

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store malicious values that may be executed by other users at a later time via get_request in lib/function.php.

Record
CVE-2020-35132
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store malicious values that may be executed by other users at a later time via get_request in lib/function.php.

Record
CVE-2020-35132
Updated
2026-11-02
EUVDEUVD-2020-22824 No score

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store malicious values that may be executed by other users at a later time via get_request in lib/function.php.

Record
EUVD-2020-22824
Updated
2026-11-03
GitHub AdvisoriesGHSA-44vj-36hg-g8rr No score

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store...

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store malicious values that may be executed by other users at a later time via get_request in lib/function.php.

Record
GHSA-44vj-36hg-g8rr
Weakness
CWE-79
Updated
2026-11-02
OSVALPINE-CVE-2020-35132 5.4

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store malicious values that may be executed by other users at a later time via get_request in lib/function.php.

Record
ALPINE-CVE-2020-35132
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-03
OSV 5.4

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store malicious values that may be executed by other users at a later time via get_request in lib/function.php.

Record
CVE-2020-35132
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2020-35132 5.4

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store malicious values that may be executed by other users at a later time via get_request in lib/function.php.

Record
DEBIAN-CVE-2020-35132
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2020-35132 5.4

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store malicious values that may be executed by other users at a later time via get_request in lib/function.php.

Record
UBUNTU-CVE-2020-35132
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVMGASA-2021-0080 No score

Updated phpldapadmin package fixes a security vulnerability

An XSS issue has been discovered in phpLDAPadmin before 1.2.6.2 that allows users to store malicious values that may be executed by other users at a later time via get_request in lib/function.php (CVE-2020-35132).

Record
MGASA-2021-0080
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpldapadmin
Alpine:v3.17
before 1.2.6.6-r0
1.2.6.6-r0
phpldapadmin
Alpine:v3.18
before 1.2.6.6-r0
1.2.6.6-r0
phpldapadmin
Alpine:v3.19
before 1.2.6.6-r0
1.2.6.6-r0
phpldapadmin
Alpine:v3.20
before 1.2.6.6-r0
1.2.6.6-r0
phpldapadmin
Alpine:v3.21
before 1.2.6.6-r0
1.2.6.6-r0
phpldapadmin
Alpine:v3.22
before 1.2.6.6-r0
1.2.6.6-r0
phpldapadmin
Debian:12
before 1.2.6.3-0.3
1.2.6.3-0.3
phpldapadmin
Debian:13
before 1.2.6.3-0.3
1.2.6.3-0.3
phpldapadmin
Debian:14
before 1.2.6.3-0.3
1.2.6.3-0.3
phpldapadmin
Mageia:7
before 1.2.6.2-1.mga7
1.2.6.2-1.mga7
Show 8 moreShow less
Affected packages
PackageAffectedFixed
phpldapadmin
Ubuntu:16.04:LTS
All versions, plus listed versions
1.2.2-5.21.2.2-5.2ubuntu11.2.2-5.2ubuntu21.2.2-5.2ubuntu2.1
None known
phpldapadmin
Ubuntu:18.04:LTS
All versions, plus listed versions
1.2.2-6ubuntu11.2.2-6ubuntu1.1
None known
phpldapadmin
Ubuntu:20.04:LTS
All versions, plus listed versions
1.2.2-6.1ubuntu11.2.2-6.2ubuntu11.2.2-6.3
None known
phpldapadmin
Ubuntu:22.04:LTS
All versions, plus listed versions
1.2.2-6.31.2.6.3-0.2
None known
phpldapadmin
Ubuntu:24.04:LTS
All versions, plus listed versions
1.2.6.3-0.31.2.6.6-21.2.6.7-1
None known
phpldapadmin
Ubuntu:25.10
All versions, plus listed versions
1.2.6.7-4
None known
phpldapadmin
Ubuntu:26.10
All versions, plus listed versions
1.2.6.7-4
None known
phpldapadmin
Ubuntu:26.04:LTS
All versions, plus listed versions
1.2.6.7-4
None known

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-35132 is a medium vulnerability (CVSS 5.4) in Phpldapadmin Project Phpldapadmin, published December 11, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.25%, the 69th percentile. Fixed in phpldapadmin 1.2.6.6-r0.

References

Show 11 moreShow less
MoveEnter Open