CVE-2020-35981
An issue was discovered in GPAC version 0.8.0 and 1.0.1. There is an invalid pointer dereference...
An issue was discovered in GPAC version 0.8.0 and 1.0.1. There is an invalid pointer dereference in the function SetupWriters() in isomedia/isom_store.c.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
An issue was discovered in GPAC version 0.8.0 and 1.0.1. There is an invalid pointer dereference in the function SetupWriters() in isomedia/isom_store.c.
- Record
CVE-2020-35981- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-476
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in GPAC version 0.8.0 and 1.0.1. There is an invalid pointer dereference in the function SetupWriters() in isomedia/isom_store.c.
- Record
CVE-2020-35981- Updated
- 2026-11-02
EUVDEUVD-2020-23564 No score
An issue was discovered in GPAC version 0.8.0 and 1.0.1. There is an invalid pointer dereference in the function SetupWriters() in isomedia/isom_store.c.
- Record
EUVD-2020-23564- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gxqw-pvp2-vpq6 No score
An issue was discovered in GPAC version 0.8.0 and 1.0.1. There is an invalid pointer dereference...
An issue was discovered in GPAC version 0.8.0 and 1.0.1. There is an invalid pointer dereference in the function SetupWriters() in isomedia/isom_store.c.
- Record
GHSA-gxqw-pvp2-vpq6- Weakness
- CWE-476
- Updated
- 2026-11-02
OSV
7.8
An issue was discovered in GPAC version 0.8.0 and 1.0.1. There is an invalid pointer dereference in the function SetupWriters() in isomedia/isom_store.c.
- Record
CVE-2020-35981- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-35981
7.8
An issue was discovered in GPAC version 0.8.0 and 1.0.1. There is an invalid pointer dereference in the function SetupWriters() in isomedia/isom_store.c.
- Record
DEBIAN-CVE-2020-35981- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-35981
7.8
An issue was discovered in GPAC version 0.8.0 and 1.0.1. There is an invalid pointer dereference in the function SetupWriters() in isomedia/isom_store.c.
- Record
UBUNTU-CVE-2020-35981- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ccextractorDebian:11 |
All versions, plus listed versions 0.88+ds1-10.93+ds1-10.93+ds2-10.93+ds2-20.94+ds1-10.94+ds1-20.94+ds1-3 |
None known |
gpacDebian:11 |
before 1.0.1+dfsg1-4 | 1.0.1+dfsg1-4 |
gpacUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 0.5.0+svn4288~dfsg1-1ubuntu10.5.0+svn4288~dfsg1-40.5.0+svn4288~dfsg1-4ubuntu10.5.0+svn4288~dfsg1-4ubuntu1+esm10.5.0+svn4288~dfsg1-4ubuntu1+esm2 |
None known |
gpacUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 0.5.2-426-gc5ad4e4+dfsg5-1build10.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.10.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2 |
None known |
gpacUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 0.5.2-426-gc5ad4e4+dfsg5-30.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.10.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1 |
None known |
gpacUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 0.5.2-426-gc5ad4e4+dfsg5-4ubuntu10.5.2-426-gc5ad4e4+dfsg5-50.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2 |
None known |
gpacUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 1.0.1+dfsg1-41.0.1+dfsg1-52.0.0+dfsg1-22.0.0+dfsg1-2ubuntu0.1~esm2 |
None known |
gpacUbuntu:Pro:24.04:LTS |
All versions, plus listed versions 2.2.1+dfsg1-32.2.1+dfsg1-3.12.2.1+dfsg1-3.1build12.2.1+dfsg1-3.1build22.2.1+dfsg1-3.1ubuntu0.1~esm2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-35981 is a high vulnerability (CVSS 7.8) in Gpac, published April 21, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.11%, the 66th percentile. Fixed in gpac 1.0.1+dfsg1-4.